Forum / Remote Desktop Manager - Support

SSH Shell randomly displaying ^E

  • Create an Issue
  • Cancel

All my SSH Shell connections have started injecting ^E at what appears to be random intervals. Is this a bug or can this be turned off some how? Happens to embedded appliances and Linux servers; doesn't seem to be related to the SSH Server daemon.

Clock2 mths

I will report this to our dev.

Regards

David Hervieux

signaturesignature

Clock2 mths

Here is an example

linux_e.PNG
linux_e2.PNG
Clock2 mths

Thanks for this printscreen, I looks with the dev and it seems that when the Enable TCP keep alive is enable in the SSH Shell entry the ^E appear.

Base on our internal ticket (WIN-1287) the issue should be corrected in RDM 13.9.8 and above. We aren't able to have the same issue internally, so if you could test RDM Beta 13.9.9 which is the latest version it could be good.

Before testing it please read this forum because RDM beta 13.9.9 include a database update.

If updating to a beta version is not an option, go on the SSH Shell entry and uncheck "Enable TCP keepalives"

SSH Shell Keepalive

Best regards,



David Grandolfo

signaturesignature

SSH_Shell_Keepalive.png
Clock2 mths

Thanks for the info. I will try out the beta version since some of my connections use the keepalive so the connection doesn't get closed. I thought it might have something to do with the keepalive settings but I can leave sessions open for hours without seeing the ^E show up but then other times it appears once a minute or so.

Clock2 mths

Just to confirm: the ^E is the result of a "feature" I programmed but corrected since. It is related to the "ping interval" and some servers do not echo this control character (those I used for testing obviously). The ping timeout is reset each key stroke, so if you're using the terminal more often than the ping interval, you will not see that ^E.

Regards.

Denis Vincent

signaturesignature

Clock2 mths

Please not that on some other shells, another string than ^E is written. For instance, on an ESXi shell, the "PuTTY" string is written, as shown on the attached video.

Bug.mp4
Clock2 mths

Hi,

I am using the version 13.9.14.0 and I am still getting the ^E.

Which version will solve this issue?

Cheers,

Clock29 days

@Thiago,

Is the Keep Alive and Ping Interval are enabled in the Advanced tab of your SSH Shell session?

Best regards,



Jeff Dagenais

signaturesignature

Clock29 days

@Jeff,

Yes, keep alive and ping interval are enable every 1s.

Cheers,

Clock29 days

I still have the issue as well, with RDM Free 5.0.0.0.

Enable TCP keepalives is checked, Ping interval = 30 sec.

Clock29 days

Hi,

This issue will be resolved in RDM 14. Apparently, my last fix was inconclusive, sorry for that.

Regards

Denis Vincent

signaturesignature

Clock29 days

I confirm this is fixed for me in RDM Free 5.0.1.0.

Thanks Denis!

Clock27 days