Forum / Remote Desktop Manager - Beta

RDM 14 Beta

  • Create an Issue
  • Cancel

Hello guys,
We are really happy to release RDM 14 beta. This version requires .NET 4.7.2 and backup your database before installing this beta for a maximum of safety.

The initial release is 13.9.0.0 and the final version will be labelled 14.0.0.0. This is major update and it requires a database update. This update is backward compatible with our current stable version (13.6.X) for SQL Server and Devolutions Password Server.
This update is NOT COMPATIBLE with the latest stable database of mySQL and it's not recommended to use it in production if you plan to keep the last stable version during the beta.

Post any issue in a separate thread since it's much easier for us to answer you and keep track of it.

=== What's new ===

* 1Password opvault support
* Execute security right
* Repository manager right
* FTP/SFTP live edit
* Google Drive data source
* Documentation search
* I've Been Pwned integration
* mySQL improvements (Repository, Documentation, Favorites and more)
* Many UI improvements


http://cdn.devolutions.net/download/Devolutions.RemoteDesktopManager.Bin.13.9.8.0.zip
http://cdn.devolutions.net/download/Setup.RemoteDesktopManager.13.9.8.0.exe

David Hervieux

signaturesignature

Clock12 mths

Is it possible, that 13.9.1.0 beta cannot be used with Devolutions password server?
It's always complaining that my password is wrong, but it's definitely entered correct.

Clock12 mths

@Rene,

I am able to reproduce your issue with RDM 13.9.1.0 and DPS 5.1.1.0.

Let me verify with our engineering department and get back to you.

Best regards,



Jeff Dagenais

OFFICE CLOSURE!
Although our various support queues will be monitored for emergencies, Devolutions' offices will be closed on September 2nd 2019.

signaturesignature

Clock12 mths

Any hope for multiple OTP key support in RDM 14? I believe right now it supports one key, but if that key is lost then access is lost as well. I have two Yubikeys, one as a backup.

Clock12 mths

Do you mean in Devolutions Password Server or directly in RDM?

Regards

David Hervieux

signaturesignature

Clock12 mths

Directly in RDM.

https://forum.devolutions.net/topic30072-multiple-yubikey-support.aspx

Capture.PNG
Clock12 mths

In RDM 13.9.1.0 selecting Help>About brings up this pop-up before going to the proper 'About' window.

Capture.PNG
Clock12 mths

This should not be there. Thank you.

Regards

David Hervieux

signaturesignature

Clock12 mths

I have uploaded an updated version with the fixes for DPS

David Hervieux

signaturesignature

Clock12 mths

Perfect, thank you very much. I can confirm, 13.9.2.0 is working with DPS.

One bug report I have, which is present since many versions. Maybe this could be fixed in RDM 14.

If I have already one RDP session openend withing RDM and do a quick connect with password prompt, the new session does not get the focus, instead it's switching back the focus to the already openend RDP session instead.

It's not a huge thing, but it's annoying.

Clock12 mths

13.9.2.0

I confirm Rene Zimmermann issue with focus switching with Quick Connect session.

Also, I'm getting a certificate error when opening RDM.

Clock12 mths

Also the extremely annoying double click bug is back in 13.9.2.0. Double clicking an entry, does not open it. Even with multiple times closing and reopening RDM, it's not working.

Btw. I'm using the "portable" installation.

Clock12 mths

@Rene Zimmermannm

Hello,

For the double click issue!

We have not been able to reproduce this issue once or even had someone experience it internally. In the past it has been mentionned that restarting RDM fix the issue up until it shows up again. Are you saying that even after restarting the application, you're getting the issue right away ?

Regards,

Alexandre Roy

signaturesignature

Clock12 mths

Alexandre Roy wrote:

@Rene Zimmermannm

Hello,

For the double click issue!

We have not been able to reproduce this issue once or even had someone experience it internally. In the past it has been mentionned that restarting RDM fix the issue up until it shows up again. Are you saying that even after restarting the application, you're getting the issue right away ?

Regards,


That‘s correct. I have closed and re-opened RDM several times and it does not work ar all.
If you need any additional logs or anything, just let me know. Maybe I can help you in analysis.

Unfortunately I no longer remember, with which version it happened first time. With the latest version 13.6.7.0 I no longer had this issue.

Clock12 mths

@Rene Zimmermann

There was a new permission implimented in 13.9, the permission "Execute", and it prevents you to open session.

Can you confirm that in the root this permission "Execute" is allowed for the user that is currently experiencing the issue?

New+permission+Execute

If your root permissions are set to never, the double click might not be working because of this new permission.

Best regards,

Alexandre Roy

signaturesignature

New permission Execute.jpg
Clock12 mths

@zim2323 and Rene Zimmermann,

We have been able to reproduce the Quick Connect focus issue.

A ticket has been opened to our engineering department regarding this.

Thank you for reporting.

Best regards,



Jeff Dagenais

OFFICE CLOSURE!
Although our various support queues will be monitored for emergencies, Devolutions' offices will be closed on September 2nd 2019.

signaturesignature

Clock12 mths

Some broken iconography in the ribbon. Also, can the items pinned to the ribbon be made moveable / able to drag?

Capture.PNG
Clock12 mths

I think this is not so important to create an extra thread but I have one question about the UI improvement - I noticed that you made a heavy change regarding the dark theme - Anyone other use the Office 2016 (Dark) theme?
Honestly I think the dark theme from the latest beta is too bright - I know Office use the same color, but RDM use it in larger areas.. So if you work at the evening without additional light your screen is really (heavy) light now. Whaaaaa? smile

Regards,
Min

Clock12 mths

@Min

Do you have a compare for the two different Dark mode?

Regards

David Hervieux

signaturesignature

Clock12 mths

Yes, here you are: wink

2018+09+06+20+56+32+

Regards,
Min

2018-09-06 20_56_32-.png
Clock12 mths

Alexandre Roy wrote:

@Rene Zimmermann

There was a new permission implimented in 13.9, the permission "Execute", and it prevents you to open session.

Can you confirm that in the root this permission "Execute" is allowed for the user that is currently experiencing the issue?

image

If your root permissions are set to never, the double click might not be working because of this new permission.

Best regards,


The execute permission is on "Default". However, I can open sessions, but only by pressing "Enter" instead of double clicking it.
On strage thing I've just seen. I have multiple data sources. Some local databases and a DPS account.

If I startup RDM with a local database, double clicking works, as soon as I switch over to the DPS datasource, it's no longer working. Switching back to the local datasource, double click is also no longer working on the local data source.

As I told, if you wanna see the problem or do some trouble shooting on my device, please just let me know.

Clock12 mths

I just deleted my "config" folder and re-created a complete new configuration from scratch.

Starting with the new config, double click seems to work. But as soon as I do make some UI changes in the options, regarding the tree view, it sometimes stops working again. I'm not completely sure, but it may have something to do with showing the data source in navigation pane.

Clock12 mths

Rene Zimmermann wrote:

I just deleted my "config" folder and re-created a complete new configuration from scratch.

Starting with the new config, double click seems to work. But as soon as I do make some UI changes in the options, regarding the tree view, it sometimes stops working again. I'm not completely sure, but it may have something to do with showing the data source in navigation pane.

Thank you for those information @Rene Zimmermann, I'll be investigating to see if I could reproduce the issue with what you provided us.

Regards,

Alexandre Roy

signaturesignature

Clock12 mths

So, 2 things,

1) As of 13.9.3.0 I now have the double-click issue. I'll restart the app and also try installing 13.9.4.0 later today to see if either resolves the issue.

2) I opened a help desk quite a while ago about issues with screen paint/redraw issues. I tried several suggestions for "similar" issues that you received calls on, but I want to bring this up here to see if it can get a little more attention to fix. When I have 1 or more sessions (RDP) open within RDM, I will randomly have issues where the underlying windows on my desktop will take focus. Sometimes those windows come forward in whole and I'm now "in that window", and other times I have a half "painted" RDP session where the RDP session windows are either not there or partially drawn. Help Desk requested a video but this is a business PC and I cannot take videos, though I could do a remote session. I have confirmed that other vendors when I'm sharing my screen with them also see this, as well as when mirroring my screen to a monitor. I do not have this issue when using RDM on my home PC. Any help, thoughts, etc. would be greatly appreciated. I have grown increasingly frustrated with this issue.

Clock11 mths

@zim2323

Could you try RDM 13.9.4 to see if your issues are still there. I've made a two really interesting potential fix for the focus issues.

Regards

David Hervieux

signaturesignature

Clock11 mths

I closed and reopened 13.9.3 and the problem "went away". It was the first time I had experienced this in a LONG time. I think early v10 or v11 was the last time I saw it. I'm installing 13.9.4 now.

Clock11 mths

Yesterday afternoon I used RDM quite a bit and didn't notice any specific focus issues. I'll report back if they are still present.

Thanks!

Clock12 mths

Ok, so I've had enough time already this morning with 13.9.4.0 to tell you that the focus/screen redraw issues are actually "worse". That is, mouse clicks are far less responsive, and instead of being able to click to any other TAB and then back to fix the issue, now I have to flip back and forth several times before the screen updates properly.

Clock12 mths

@zim2323

That is odd, is it possible for you to make a short video of the issue and give us some information to reproduce the issue ?

1- The operating system version?
2- are you using the 64 or 32 bit version of RDM ?
3- if you are on windows 7, did you update the RDP activeX to have RDP 8.1 working?

Also I would like to obtain your RDM configuration file by email to aroy@devolutions.net.
Please follow these steps here before sending it https://help.remotedesktopmanager.com/howto_configurationfile.htm.

With all those info I should have a good start to reproduce the issue so we can have a look at it.

Thank you for reporting this.

Best regards,

Alexandre Roy

signaturesignature

Clock12 mths

@Alexandre

As I stated before, unfortunately I am not allowed to video my desktop, however I can get you on for a remote session (go figure).

It's been this way for several RDM versions from Windows 64bit version 7 through all builds of Windows 10. Currently we're still on build 1703. 1803 is slated to roll out later next month.

Email sent.

Clock12 mths