Forum / Remote Desktop Manager Mac - Bug Report

SSH Shell Automatically Spamming Session with Characters

RDM Version: 4.5.1.0 on macOS

With the newest RDM version SSH Shell has become pretty much unusable for me.
* When I, e.g., open vim and enter command mode ( : ) I get spammed with "^@" characters. Please see the screenshot below after starting vim and waiting for a few seconds: https://www.dropbox.com/s/g3jh9yl1ih5quyf/Issue.png?dl=0
* When I go to insert mode (i) to edit a file it almost immediately exits - most likely also because the "^@" event is happening.

Clock2 yrs

Hi Benjamin,

I've reproduced your issue. This is due to the modification to the keep alive we've done. We had to create our own way to inform the server to keep alive, but vim seems to take the <null> character we send and write it down (^@). That being said, there seems another issue where the keep alive is still enabled even if we uncheck the option...

For the moment, you can either set an absurd delay for the keep alive (86400 for instance) or revert to a previous version (http://cdn.devolutions.net/download/Mac/Devolutions.RemoteDesktopManager.Mac.4.5.1.0.dmg).

Sorry for any inconveniences. We'll fix this ASAP.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

Hey Xavier,
thank you for the quick response. I think the issue around the keep alive happens for all interactive CLI apps (e.g. I'm running one of my programs in a tmux and I see the keepalive every second or so on the screen.)

Could you provide a link to a version before regression https://forum.devolutions.net/topic28165-esc-button-in-ssh-shell-doent-work-mac.aspx was introduced?

Thanks a lot!

Clock2 yrs

Hi,

Sorry, I've linked the wrong version in my previous post. Here it is: http://cdn.devolutions.net/download/Mac/Devolutions.RemoteDesktopManager.Mac.4.4.2.0.dmg

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

Hi Benjamin,

This has been fixed internally and I'll get a version out next week.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs