Hi,
I'm trying to intergrate RDM with ManageEngine Password Manager Pro.
Basically Password Manager Pro doesn't have a domain field for password-entries and if I try to specify the username in this format: username@domain or domain\username I can login on my servers with RDM but the password reset module in Password Manager Pro stops working...
I've tried talking to their support and according to them their system can't handle anything other than the username alone in the username-field.
BUT when I looked around I found a thread on your forum where someone else basically had the same problem! Great! I thought...
https://forum.devolutions.net/topic29055-password-manager-pro-domain-user.aspx
The person in this thread enabled the option "Override domain: Custom Domain" and specified the domain in the Information-tab.
However when I tried exactly that, I suddenly got a weird "Unable to resolve the host name: 192.168.1.10".
We are connecting to IP-addresses on all our entries (Computer-field under Properties -> General) and it seems that the Custom Domain property goes haywire when using IP-addresses.
So I went along with my investigation and created a dns-entry "computername.domain -> IP" in the HOSTS-file on my client and voila! the custom domain property started working as intended. Even with the address still being just an IP-address!
For me this seems super-weird!
Why is the custom domain property depending on a valid dns-entry, even when not using the dns-entry to connect to the machine?
Is RDM for some reason doing a reverse-lookup?
To be honest though, for me, the best option would be to be able to specify a domain in the credentials pulled from Password Manager Pro..
So this is my two wishes:
* Fix the custom domain property bug. (It has to be a bug...?)
* Create a field in the Password Manager Pro integration where we can specify domain.
Looking forward to your response!
Best regards
Jonathan
Hello,
Domain Field
Adding a domain field inside the Password Manager Pro credential entry, I don't think this would be possible.
Our integration is based on the API provided by Password Manager Pro and since they don't have any domain field in their application, there's no domain field in the API as well. If they add a domain field one day and that the API support it, we will integrate it for sure.
Override Domain Issue
The issue you have of not resolving the domain properly seems to be a issue/bug in RDM.
I will make some tests on my computer and get back to you regarding this.
Best regards,
Jeff Dagenais
Hello,
I have made a few tests and I am not able to reproduce the override domain issue that you have with your IP address.
I have tried with the username/password configured in Password Manager, in a Username / Password credential entry or directly in the session.
Could you post a screenshot of the properties of your RDP session please.
Best regards,
Jeff Dagenais
Hi Jeff.
I tried with username/password under General but the problem is the same as with Password Manager.
Please see attached screenshot of my example-configuration.
The error-message pops up when i tries to connect to the server and the domain "test.local" is never passed to the server during authentication.
However if I add the following line in my hosts-file (192.168.1.10 testserver.test.local) there is no error and test.local is passed to the server as domain and login is successful.
Are you sure you are using an IP-address that's not resolvable by DNS in your test-environment?
Screenshot4.png
Screenshot3.png
Screenshot2.png
Screenshot1.png
Hello,
Could you elaborate on your last question please? What do you mean by using an IP address that is not resolvable by DNS?
Best regards,
Jeff Dagenais
Hi.
The problem doesn't appear when I try to connect to an IP-address that's known (reverse-lookup on DNS-server or local HOSTS-file) by my computer.
Hope this makes sense and will help you reproduce the problem.
Thanks
Hello,
The PMP entry is of the credential family. What type of entry are you creating that makes use of that credential?
There is no DNS resolution involved in RDM. We open with the IP.
My tests were conclusive with a RDP entry, that is why I am asking what type you are using.
best regards,
Maurice
Hi Maurice.
I'm experiencing these problems with a standard RDP-entry. The problem with custom domain not being passed during login has nothing to do with PMP. I can easily reproduce the error in a RDM-environment without PMP.
Please follow these simple steps to reproduce the error:
At this point, if this would have been a "real" IP-address, the domain you specified under the Information-tab would not have been passed to the server and logon would fail.
Now try this:
At this point, if this would have been a "real" IP-address, the domain you specified under the Information-tab would have been passed to the server and logon would be successful.
Thanks!
Hello,
We set the ip address in the host field of the Microsoft RDP ActiveX for embedded sessions, and for external sessions we create a RDP file and call mstsc.exe. There is not DNS wizardry taking place as part of the RDP protocol being established.
On the other hand, we have a system to detect if a host is up by doing a ping (or port scan). On my system, when I type a non-existent ip, I see a SILENT_EXCEPTION in my log because our PingManager was not able to identify the host name from the IP address, then right after I see the RDP protocol error.
When investigating, I saw the DNS error even before the rdp file is created. I now have to intercept our handling of the credentials in the Windows Credential Manager to see if indeed the custom domain is used or not.
TL;DR;
a - we have a PingManager testing if the remote system is up before establishing the RDP connection. (I have all ping features turned off BTW)
b - This doesnt interfere with the RDP connection itself (proven by looking at a temporary rdp file that we generate)
c - I have yet to prove that the custom domain is used or not
I will get back to you shortly
best regards,
Maurice
Hello,
The PingManager call is in the wrong place. It causes the exception and the domain name is not returned as it should.
I have opened a bug and hopefully it will be fixed soon.
best regards,
Maurice
for crossref, the ticket number is WIN-755
Maurice
Hi,
Awesome, thank you.
I have a customer with a PMP+RDM-project waiting for this to be fixed.
Do you know if we're talking about a week, a month or a year til we can expect a fix?
Thanks again for taking the time to research this issue!
Best regards
Hello,
It will be done in our code base by the end of the day. I haven't been informed of the build schedule, but our previous one was last week. Worst case will be two weeks before it is released. (QA testing done and critical bugs being absent)
Best regards,
Maurice
Hi.
Great! Thank you.
Looking forward to the next release then. :)
Take care.
Best regards
Hi Maurice,
Do you have any idea when the next release will be?
Regards
Hello,
As per I can see, this has been resolved in the latest release of RDM, which is 13.5.9.0.
Could you try this version? You can download this version here
https://remotedesktopmanager.com/home/download#Beta
Best regards,
Jeff Dagenais