Entry with sub-entry using $PARENT_HOST$ variable doesn't pass through in RDM Jump
RDM 12.0.8.0 on local and remote system.
Remote system configured as jump box, agent is installed.
Bug 1:
Session is HTTPS and has a sub-entry that is SSH. HTTPS entry works properly and opens on jump box. The SSH sub-entry is using $PARENT_HOST$ variable for the host to SSH to. SSH sub-entry works correctly locally. If I associate that sub-entry with the remote jump box by selecting the session in the RDM jump screen, it opens the jump connection and opens the SSH connection which then fails:
"Unable to connect. Verify your settings. Hostname is invalid. Parameter name: serverName"
Assuming it's just passing $PARENT_HOST$ and not the actual variable value, but not really sure.
Bug 2:
If you choose "inherited" for the RDM jump type of the sub-entry, it doesn't appear to actually inherit from the parent. Parent will open on the jumpbox, sub-entry is still opening locally.
Bug 3:
With "prompt for comment on open (required)" and "prompt for comment on close (required)" selected in either session, it prompts twice. Once when you initiate the session to the jump server, and then a second time on the actual jump server itself.
Hello,
#1: I was able able to reproduce your error message in RDM 12.0.8.0, but not in RDM 12.0.12.0. Could you try this latest release please. You can download this version at the bottom of this page - https://remotedesktopmanager.com/Home/Download
#2: I was able to reproduce your issue. A ticket has been opened to our engineering department.
#3: I was able to reproduce your issue. A ticket has been opened to our engineering department.
Best regards,
Jeff Dagenais
#2 & #3 have been resolved and will be available in the next beta release, any version after 12.0.14.0 will do the trick.
https://remotedesktopmanager.com/Home/Download#Beta
Stéfane Lavergne