Checking if Keepass is running (and it's not) shows an error dialog
Since version 11.6.x, and still with version 12.0.5.0, there is an issue with RDM when checking if Keepass is already running. We use some password stored in a Keepass database, and until version 11.5.x all worked pretty well. As said, starting with version 11.6.x if Keepass is not running and an entry in RDM is open, which requires access to a Keepass stored password, the following error dialog is shown:
The same happens with the latest RDM version, currently 12.0.5.0:
As in the case of the other thread related I've opened, the network where RDM is running is not connected to the Internet (just in case it matters, maybe it has no relation with that), and once Keepass is started (or if it was started before running accessing a RDM entry using a Keepass stored password) the dialog is not shown.
Thanks.
Hello,
That kind of error should only appear in the Application Logs rather than as a pop up, and in this specific case they shouldn't affect how RDM handles KeePass. Could I ask you what the name of your workstation is?
I attached to this message a .reg file that will force the disabling of these error pop ups (but still keep them in the application logs as intended). Could you run it then restart RDM and see if it fixes the issue?
Regards,
Hubert Mireault
DisableIsDevelopmentComputer.reg
Hello Hubert,
I have applied the registry entries, but the dialog is still shown with the conditions explained in my original post. We are using the 64 bit version of RDM, if it is of any help.
Thanks!
Could you make sure the registry key "IsDevelopmentComputer" exists and is set to value "0" in both HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\RemoteDesktopManager and HKEY_LOCAL_MACHINE\SOFTWARE\RemoteDesktopManager
If they are both there, make sure to completely close and restart RDM. I've been unable to reproduce the issue with these steps.
We will still change how it handles these errors in RDM for the next version in case this still doesn't work.
Regards,
Hubert Mireault
And could you make sure to set the debug level to 0 in the profiler? You can access this by going in Help > Profiler > Debug only
Regards,
Hubert Mireault
Hello Hubert,
This last one did the trick! The debug level was set at 3, I don't know why, maybe I did set the parameter to that value while I was investigating the startup dialog complaining the failed connection to remotedesktopmanager.com (still unresolved)
BTW, setting the two registry values as per your .reg file did not solve the issue.
Many thanks!
Glad to hear it works! There are some dialogs like it that will appear if you have the debug level set to 1 or higher in the profiler, which explains the issue.
Regards,
Hubert Mireault