Problems with RDM dabase backup/restore on SQL Azure

Problems with RDM dabase backup/restore on SQL Azure

avatar

Hello

I'm facing issues with the backup/restore of our RDM SQL Azure database from one Azure subscription to another.
Once the backup/restore is done, we're able to logon to RDM with the SQL azure database admin.
But other user can't login.

They get this kind of error messages:
Login failed for user '<user>'. This session has been assigned a tracing ID of '{Tracking

When I connect to SQL management studio I see the user in the database and in SQL server.

Anyone an idea?
I think something is wrong with the user mappings.

New created users can login, but we have too many sql users to recreate.

Regards
Frederik

All Comments (2)

avatar

Frederik,

Can the old users connect using SQL Server Management Studio (SSMS)?

We've tested here with an Azure DB restored on the same server as the original DB and all works as expected, no error message.

We've also tested a restore on different server and here we encounter an issue but not the same error message you are getting. Solving this was a question of resetting the user's password on the new server. Connect to the new server's master DB and running the following solved it for us:ALTER LOGIN User2 WITH PASSWORD = 'mypassword';
You might need to contact Microsoft Azure using that tracking number to get additional help on this issue.

Best regards,

Stéfane Lavergne

avatar

Hi Stefane,

i've fixed the issue by resetting the password with the alter command.
this will cost some time,, but there is no other solution.

Thanks