Forum / Remote Desktop Manager - Support

RDM as Citrix Published app has black screen when selecting session

  • Create an Issue
  • Cancel

We use RDM in Citrix Virtual apps (version 1909) as an published app on a Windows server 2019.
Last time we experiance a black part outsite the RDM window when opening a session in RDM:

image


When the session is not selected (e.g. when selecting the tab dashboard) we do not see the black part:

image


When using 2 monitors and RDM is full screen on the right monitor we experience a large black bar on the left screen which is caused by the black part.

I am not sure if this is caused by Citrix of bij RDM? Anyone else experiencing this and how to avoid it?

Clock2 mths

Hello,

Could you please try the following solution that was helpful for other customers?

With the tool Winspector we could find out what the RDM application ID is and which you had to use.
Then you need to add a class name of RDM in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CITRIX\wfshell\TWI

image

You can also find the detailed information on the following web page.
http://techgenix.com/seamless-application-explained/

Let me know if this solution helps to resolve your issue too!

Best regards,



Érica Poirier

signaturesignature

Clock2 mths

Hi,

I found the ClassName of RDM in my case (which is a cryptical name: WindowsForms10.Window.8.app.0.2b89eaa_r14_ad1 smile), but not sure what flags could be usefull for me.
Tried with flag 0x80, but no result.

Any suggestions?

Clock2 mths

What version of Citrix Receiver\Workspace are you using? Does this issue occur using Workspace for HTML5?

Clock2 mths

Never used HTML5 receiver.
I have version 19.11.0.50 of the Workspace app. But also a collegue with version 19.9.0.21 has the same experience.

Clock2 mths

Use the HTML5 client a lot to isolate the issue, I suspect it will work and the issue is with the the seamless application. Is the end device single screen or multi-screen display? If multi does it work normally in single screen display.

Clock2 mths

I have HTML5 client not available at the moment, so need to appy that for testing.
I used multi-screen, but also single screen has the same issue.

Clock2 mths

HTML5 will probably resolve the issue but the experience changes since the app is locked in the browser.

I haven't started looking at Win2019. Don't have any other suggestions. Good luck.

Clock2 mths

Hi
We have the same issue
arno02 have you found a solution?

Clock2 mths


Hello,

This issue seems to be on Citrix and Microsoft side. From many articles I have read online, it seems that the computer must have the latest GPU drivers installed, the Windows desktop zoom must set at 100%, or it could be a single Microsoft KB that needs to be installed. Here are few articles but not sure if they are relevant in your situation.
https://gridforums.nvidia.com/default/topic/2056/xenapp/published-application-black-window/
https://support.citrix.com/article/CTX218217
https://support.citrix.com/article/CTX225819
https://support.citrix.com/article/CTX235681

Best regards,



Érica Poirier

signaturesignature

Clock2 mths


Hello,

As an additional information, please check if your Citrix VDI version is at least 7.18 or above according to the following article.
https://devolutions.atlassian.net/servicedesk/customer/portal/1/article/709459992

Best regards,



Érica Poirier

signaturesignature

Clock20 days


Hi Érica,


Many thanks. I can confirm this works. The black square which is visible in the original post is gone when opening a session.


If you apply the fix. Please make sure the the Window ID is in fact WindowsForms10.Window.0.app.0.<version> as WindowHistory for ex. shows
WindowsForms10.Window.8.app.<version> for the main window. The seamless flag option to set is 0x1000 as outlined in the article, which can conveniently be done using the CAXTool or manually in the registry https://support.citrix.com/article/CTX222592



Option Explanation:



FORCE MENU WINDOW TO HAVE OWNER
Value: 0x1000
Explanation: Specifies that Menu Windows will always be re-created on the ICA client with an owner window.



See the attached screenshot for the required CAXTool configuration.


Regards





Seamless-Flags_RDM.png
Clock6 days

Hello,

Thank you for your feedback @christoph and glad that you have successfully get rid of the black boxes.

Best regards,



Érica Poirier

signaturesignature

Clock6 days

Thanks Christoph, changing the 8 to a 0 in the windowsID did the trick.
Now the black square also disappeared in our environment.

Clock6 days