Forum / Remote Desktop Manager - Support

Cannot login to Devolutions for FREE Remote Desktop Manager

  • Create an Issue
  • Cancel

I have installed free RDM on Win10.
Also registered for Devolutions Cloud and confirmed account.
When I launch RDm, I get a popup screen for registration; I select there Devolutions.
This leads me to the window "Devolutions Account Login" but the form is empty - no fields for email adress or password.
Regards, Ger

2019-06-24_15-46-37.jpg
Clock5 mths

Hello,

Which version of RDM Free are you currently using? If it is not RDM 2019.1.33, would it be possible for you to update to this version and see if this issue persist? To do so, please use the download link below:
https://remotedesktopmanager.com/home/thankyou/rdmfreesetup

On the other end, if you are currently on this version, could you please go under Help -> Register Product and register your RDM Free serial manually by selecting the "Use Serial" option.

Your RDM Free serial can be found under the "My Serials" section of your Devolutions Cloud Account:
https://cloud.devolutions.net/serials

Best regards,



James Lafleur

signaturesignature

Clock5 mths

I am having the same issue as well. I am currently on the latest version 2019.1.33 and even though I have my email, serial, and it says it is registered, I keep receiving the cloud login page.

I can login online but not through this prompt which I believe may be blocked by the proxy. Until this version I have never been prompted by the cloud login after adding the serial.

I am able to cancel the cloud login and use Remote Desktop Manager as usual but he login prompt on startup is becoming quite annoying.

I have been using your product for over 10 years now and would just like it fixed.

Thanks,

Mike

Clock5 mths

James,
Thank you.
I found the serial number; didn't know that it was there.
All's working fine now.
Ger

Clock5 mths

Hello,

@clage12345 , I am glad to see that the workaround worked for you.

@micheal , I am sorry to see that you are also experiencing this issue. That being said, would it be possible for you to go under File -> Devolutions Account and uncheck "Automatically sign-in at startup" option. Doing so might affect this issue.

In the meantime, please note that we are currently investigating this issue and that we will inform you as soon as we will have an update on this situation.

Best regards,



James Lafleur

signaturesignature

Clock5 mths