Forum / Remote Desktop Manager - Support

Cannot open RDM free after update

  • Create an Issue
  • Cancel


Hi. Just received a notification telling new versiona available.
Launched the update and now, when trying to open the RDM it freezes (see attached img).
Tried to repair, uninstall and reinstall but nothing changes.
Someone know how ti fix this?
Thanks

Immagine.png
Clock13 days

Same here.

Clock13 days

well...mine is'nt evenshowing the script error you have..

Clock13 days


just downgraded to Setup.RemoteDesktopManagerFree.2019.1.9.0 and it's workin.
hope this helps

Clock12 days

Hello,
This update uses our new Devolutions Account which support 2FA. Is it possible that your firewall is blocking login.devolutions.com?

Regards

David Hervieux

signaturesignature

Clock12 days

Almost identical problem. Hanging on connecting to Devolutions Cloud ... I never setup 2FA and our firewall is not blocking login.devolutions.com

Capture.JPG
Clock12 days

Exactly the same issue here. No firewall in place blocking access to anything.

Clock11 days

Same here upset No firewall blocking, just perpetual 'Connecting to Devolutions Cloud' popup.

Trying an older version as it certainly used to work!

Clock8 days

Just to be sure, Do you all have Internet Explorer 11 installed?

Regards

David Hervieux

signaturesignature

Clock8 days

Yes, IE11.

Clock8 days

Could you retry this morning? We have made few fixes to the login page.

Regards

David Hervieux

signaturesignature

Clock7 days

Same issue after upgrade. Windows 10 b1803. Launched application at 10:47 ET.

RDM Free Error.jpg
Clock7 days

@Bruce_harris

Could you post a print screen of Help->Diagnostic?

Regards

David Hervieux

signaturesignature

Clock7 days

I am able to close the blank authentication screen. However, I cannot click on anything on the main application screen and need to end task to close it. So I am unable to provide that information.

Clock7 days

As Bruce, same for me.
I jus joined captures!

Capture.JPG
help, diagnostic.JPG
Clock7 days

so ??

Clock7 days

We are still working on some other possible fixes. We are unable to reproduce it here. I hope to deploy another login screen in RDM. Some people might ask why it's happening with this version and not the other. The reason is simple, we now support 2FA with this release which is not the case with the previous version. This means that the authentication must be done by the web browser (embedded in our case).

@Boubou, just to be sure, are you using RDM Free 2019.1.29?

David Hervieux

signaturesignature

Clock7 days

@David: I always use the latest version! wink
I cant connect to Devolutions Cloud to restore online backup too...
Same issue happens... Blank screen and I cant click anything.

Capture.JPG
Clock7 days

Hello,
We have been able to reproduce it with Windows 7. We are still working on this problem and it's our priority #1.

Regards

David Hervieux

signaturesignature

Clock7 days

Got same problem.
tried to change default Web Browser to IE11 (Chrome is my default).... NOK

Tried to disable antivirus/firewall.... NOK
Tried to bypass our Proxy (i'm network admin and can choose to go directly to Internet) : OK!!!
Hope this can Help


Regards,

Eric

Clock6 days

Hello,

This will be fixed in the next version of RDM, which should be in Beta in the evening or tomorrow.

The problem with Windows 7 was that RDM used an old version of TLS (1.0) to authenticate. The next build will now gives the correct version of TLS (1.2).

If you don't want to wait for the next version, you can add these registry keys into your Regedit:


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
"SchUseStrongCrypto"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]
"SchUseStrongCrypto"=dword:00000001

Antoine Mauger

signaturesignature

Clock6 days

I am still having an issue. The screen to log in using the Devolutions Cloud Account does not have any fields to fill in. Windows 10 here.

Launch_Login_Hang.jpg
Clock5 days

@Bruce_harris,
Could you cancel and use the Register Later? After that try to open a quick connection (web) with https://login.devolutions.com

Regards

David Hervieux

signaturesignature

Clock5 days

I can get into the application. I created a web connection to that site and have a logon page.

Clock5 days

Same for me!
Devolutions Account Login is blank!

Clock5 days

Are you able to right click and click Refresh in the menu?

David Hervieux

signaturesignature

Clock5 days

@boubou

Do you know if TLS 1.2 is enabled for you Windows 2008?

https://support.quovadisglobal.com/kb/a433/how-to-enable-tls-1_2-on-windows-server-2008-r2.aspx

David Hervieux

signaturesignature

Clock5 days

Thanks A LOT David.
That link fix my problem!

All work perfectly now (from what I see.).

Big Grin

Clock5 days

Great news! I still have to find why it does not work for @bruce_harris

David Hervieux

signaturesignature

Clock5 days

@Bruce_harris

Are you able to post a print screen of Help->Diagnostic, I can't find it on the forum

David Hervieux

signaturesignature

Clock5 days