Forum / Remote Desktop Manager - Bug Report

Embedded VNC: Unable to type special character which require pressing ALT+KEY

  • Create an Issue
  • Cancel

Hello,

using the embedded VNC viewer i'm not able to type on the remote server special charaters which require the use of the ALT key. For example in my italian keyboard if i want to type the special character @ i have to keep pressed "Alt Gr" and then press "ò":

image

If i try to press that combination of keys using the embedded VNC viewer no character is written on the remote server.

Using the embedded VNC viewer i have this problem with different VNC servers (TigerVNC and RealVNC) and different desktop environment (LXDE and MATE).

I don't have this problem with others VNC viewer, like UltraVNC.

Regards

Clock2 mths


Hi,

Thank you for the detailed explanation.
I will look into this issue.

Regards

Jonathan Lafontaine

signaturesignature

Clock2 mths


Hi,

I was able to reproduce and fix your issue.
The next release should let your correctly use alt-gr key combinations.

To fully support alt-gr, your VNC session should be set to apply windows key combinations on the remote computer.
To do so, in the "Advanced" tab of the VNC session properties, set "Apply Windows key combinations" to "On the remote computer".

Let me know if you have any questions or experience any other problems with the alt-gr key.
Regards

Jonathan Lafontaine

signaturesignature

Clock2 mths

Hello,

unfortunately i still have this problem with the latest version of RDM on all my server.

In addition setting "Apply Windows key combinations" to "On the remote computer" create another problem: the right shift key is not working anymore and it can't be used for making uppercase letters. Left shift key is working correctly.

Clock2 mths

What version was RDM updated to?

Jonathan Lafontaine

signaturesignature

Clock2 mths

2019.1.29.0

Clock2 mths

What is your local keyboard layout?

Jonathan Lafontaine

signaturesignature

Clock2 mths

Italian QWERTY layout, like the image on the first post

Clock2 mths


I know my setup doesn't match yours completely but here's what I have:

TigerVNC server running as a service on a Windows 10 host.
Italian layout locally and remotely.

Connecting with RDM default viewer, AltGr+ò doesnt print @.
I had to restart my vnc server before I was able to make this combination. Looks like sending the wrong key combination (normal alt+ò) screwed my server.

If you have not already, could you please try to restart your vnc server and try again?

Jonathan Lafontaine

signaturesignature

Clock2 mths

I tried to restart the server but still no luck.

I don't think it is a server problem; in my case it is not related to Tigervnc, nor to the desktop environment. I have the same exact problem with the following servers:

- Ubuntu 16.04.5 with LXDE desktop environment and TigerVNC server;
- Ubuntu 18.04.2 with MATE desktop environment and TigerVNC server;
- Raspbian April 2019 Update with PIXEL desktop environment and RealVNC server.

All the servers show the same problem with the embedded VNC viewer; other VNC viewer doesn't have this problem.

I think that embedded VNC viewer has some nasty bugs when connected to a linux machine; it would be better if you can set up a linux server to debug this problem.

Regards


Clock2 mths

I'll look into that.

Jonathan Lafontaine

signaturesignature

Clock2 mths