Forum / Remote Desktop Manager - Bug Report

PuTTY/KiTTY with LastPass - can't load default settings

I've followed the suggestions that Community members have made with regard to loading a PuTTY or KiTTY profile, but this doesn't work when you're using LastPass for credentials. It always says "Send automatic password" which fails, instead of using the creds from LastPass. I have to use 'Embedded session', which ignores the saved session name, or 'Session' and a unique session name for the LastPass creds to be successfully passed through. I would have thought that I could use 'Session' and choose a saved PuTTY profile. Is this a bug?

Clock7 days

Hi Clark,

Which version of RDM are you testing with?
Also, could you test using SSH Shell entry, which is Putty but integrated in RDM.

Best regards,



David Grandolfo

signaturesignature

Clock6 days

Hi David,

I'm using v 13.5.6.0 64-bit.

I just tried SSH Shell and it connects with the LastPass creds, but I can't see where to specify the session logging options, which is what I'm trying to use with PuTTY. I want to be able to specify a location and to use the hostname in an automatically-rotated session log. Can I do that with built-in ssh shell?

Thanks, Clark

Clock6 days

Hello Clark,

I just sent you a private message to see if you are available for a remote session?

Best regards,



David Grandolfo

signaturesignature

Clock5 days

Hi Clark,

Thanks for the private message. To log information from a SSH Session please go to the Advanced tab and check Enable logging box.

Then you can use variables to log sessions with or without overwriting.

If you look at my configuration below, I use the variable $NAME$ $DATE_TEXT_ISO$ and $TIME_TEXT_ISO$
My Log path is " C:\Devolutions\Logs\$NAME$_$DATE_TEXT_ISO$_$TIME_TEXT_ISO$.LOG "

$NAME$ refers to the session name. But you could also use $HOST$ if you want to see the host name
$DATE_TEXT_ISO$ add the date when the user connect
and to be sure that I do not overwrite logs I add
$TIME_TEXT_ISO$ to add the time.

Of course it is the user connect multiple time at the same time you could add other variables. This help topic the variables supported https://help.remotedesktopmanager.com/settings_variables.htm

SSH Loggin

Best regards,



David Grandolfo

signaturesignature

SSH_Loggin.png
Clock4 days

Hi David,

My dialog looks quite different to yours. The Advanced tab contains encryption and authentication algorithm settings. I found the logging options under a 'Recording' tab.

As I share the RDM configuration with several users, I changed the path to be %userprofile%\documents\logs\$NAME$_$DATE_TEXT_ISO$_$TIME_TEXT_ISO$.LOG to make it user-agnostic.

This works, but I would prefer to use Putty or Kitty. The behaviour I experienced does appear buggy.

Thanks, Clark

Clock4 days

Hi,

We could continue the Putty and LastPass diagnostic, could you please send us print screen of the Putty sessions.

If you don't want to post it on the forum you can send it to support@devolutions.net

Best regards,



David Grandolfo

signaturesignature

Clock3 days