Forum / Remote Desktop Manager Mac - Support

Lots of Lag using Remote Desktop Manager Free

  • Create an Issue
  • Cancel

I am using "Remote Desktop Manager Free" on a new iMac (version 4.2.1.0) and I am finding that the display performance is poor. Maximizing/minimizing Windows in a remote connection to Windows 7 or Server 2012 is very slow and "jerky", and dragging to resize a Window or moving it on the desktop is very hard to do since the display lags so much it is hard to be precise. The window continues to resize long after I have stopped dragging it, so it usually ends up too big or too small, and when moving a window, it continues to move well after I stopped the dragging motion with the mouse.

In addition, I can't seem to get the window for the session to match the resolution of the remote computer, so I get scroll bars which makes it hard to use the sessions. I don't know if the resolution mismatch is related to the lag issue, or if they are independent, but I thought I would mention it.

If I use the Microsoft Remote Desktop for OS/X app (version 8.0.39), i don't get any lag whatsoever, and I did not get lag using mstsc.exe previously on my old Windows computer, so this is new to me. The Ethernet network I am connected to is very modern and high-speed, with no other slowness issues that I am aware of, and I am not using a VPN or anything.

I have the display set as embedded (tabbed) on my primary monitor only. I have tried various "experience" settings to try to reduce the amount of data sent (even though with a local LAN connection it seems that I should not need to do so) and display settings, but nothing seems to change with the lag even when reducing the amount of data being sent.

If you have any suggestions I would love to hear them. I really like this product overall, but the lagginess and screen resolution matching issues are forcing me back to the Microsoft RPD app instead.

Clock3 yrs

Hello,

In embedded mode, we use FreeRDP to esatablish the remote connection. In external mode, we use Microsoft RDP.

Could you post a print screen of what you see when the RDP connection is establish in embedded mode.

Best regards,



Jeff Dagenais

OFFICE CLOSURE!
Although our various support queues will be monitored for emergencies, Devolutions' offices will be closed on June 24 and July 1st, 2019.

signaturesignature

Clock3 yrs

Thanks for the quick reply. Just to confirm - you just want to see what a session looks like when in embedded mode?

Clock3 yrs

Hello,

Yes, exactly.

Best regards,



Jeff Dagenais

OFFICE CLOSURE!
Although our various support queues will be monitored for emergencies, Devolutions' offices will be closed on June 24 and July 1st, 2019.

signaturesignature

Clock3 yrs

I am not sure how to post an image in-line in the post itself, so I attached the screenshot to the post. Hopefully that is what you were looking for.

Screen Shot 2017-06-21 at 9.10.15 AM.png
Clock3 yrs

Hi Mark,

I have a couple of suggestions for you.

The window continues to resize long after I have stopped dragging it, so it usually ends up too big or too small, and when moving a window, it continues to move well after I stopped the dragging motion with the mouse.

Some options might be the cause of your issues. I would like you to tell me the values of those settings:

Under your RDP session properties, what is set in RDP Engine (Microsoft Remote Desktop (RDP) -> General -> RDP Engine), what is set in Activate sandboxing (Microsoft Remote Desktop (RDP) -> Advanced -> Activate sandboxing) and what is set in Use OpenGL (Microsoft Remote Desktop (RDP) -> Advanced -> Use OpenGL)?

Under your RDM preferences, what are the corresponding values (RDP Engine, Activate sandboxing and Use OpenGL) under SessionType -> RDP -> General?

Making sure you use the RDP Engine V4 is currently the best way to ensure you get the best stability and performances. Using OpenGL should also improve performances (this will become default in the next release). Playing with the Codec level might also improve the situation.

In addition, I can't seem to get the window for the session to match the resolution of the remote computer, so I get scroll bars which makes it hard to use the sessions. I don't know if the resolution mismatch is related to the lag issue, or if they are independent, but I thought I would mention it.

This is an issue that sneaked into the app in the previous release and has been reported by another user. You won't have to worry about it in the next release.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Under your RDP session properties, what is set in RDP Engine (Microsoft Remote Desktop (RDP) -> General -> RDP Engine) (this was set to default - I changed it to V4), what is set in Activate sandboxing (Microsoft Remote Desktop (RDP) -> Advanced -> Activate sandboxing) (this is set to default - should it be changed?) and what is set in Use OpenGL (Microsoft Remote Desktop (RDP) -> Advanced -> Use OpenGL) (was set to no, I changed it to yes).


Under your RDM preferences, what are the corresponding values (RDP Engine (was set to 4), Activate sandboxing (set to true) and Use OpenGL (was unchecked so I checked the box) under SessionType -> RDP -> General?


I exited the program and restarted it, and opened the session that I made the changes to above. There may be a very slight improvement, but it still is laggy. However, now if I change the "experience" to "low-speed broadband," things seem to be as I would expect them to be performance-wise, where before I made the changes above it was still laggy even at this lower setting so that is an improvement. That setting of course removes a number of the niceties of the display, but it is workable since most of what I do is server administration that does not really require higher graphic capabilities. Bumping that setting up to "high speed broadband" then brings back the lag.


I can probably live with the lower experience setting if that is the best that can be done at this time. I am looking forward to being able to match the screen resolution so that I do not have to use scroll bars, which makes certain tasks more difficult.


Thanks for the help. If you have any more suggestions, please let me know.

Clock3 yrs

This is intriguing. The FreeRDP control should provide you with far better performances than what you describe.

Would you be willing to export your session and send it to me (via private message) so I can examine the settings more in details (right click on the session, Export -> Export Selection (.rdm)...)? You can open the file in a text editor (this will be an XML file) to remove any sensitive information (e.g. passwords).

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

I sent the session information via PM, as well as the videos I created showing the lag via email. Let me know if you have other questions or need more info.

Thx.

Mark

Clock2 yrs

Hi Mark,

I've looked at your session information and everything seems fine. I had optimal performance with the same settings connecting to one of our own server. The issue must lies elsewhere. Could you provide us with the log of one of your RDP session? This is usually more to monitor connection issues but it might contains relevant information nonetheless. You can do so by following those instructions: https://helpmac.remotedesktopmanager.com/howto_rdplogs.htm. Just send this to me directly instead of the support.

Out of curiosity, could you try the RDP Engine V5? This is still kind of a beta feature and might cause other problems, but I'd like to see if your issue might have been resolved in this Engine.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs