Forum / Remote Desktop Manager - Feature Request

SSH Tunnel with variables for host and port

  • Create an Issue
  • Cancel

I have earlier tried to add "Remote host" and "Remote port" as variables, where the remote host name/ip and remote port are "forwarded" to the "SSH Tunnel" session before opening it as a gateway. Then it would work from any sessions using the "SSH Tunnel" as gateway.
If this was possible, then "SSH Tunnel" would be enough for me i think, but it would also require devolutions to open mulitple sessions of the same "SSH Tunnel" and also require the "SSH Tunnel" to use dynamic port selection for my Local port on each remote session opened.
It would allow me to have only one "SSH Tunnel" configured for all sessions on the specific network, but using it now, I have to configure 1 "SSH Tunnel" for each remote session I need to tunnel through a gateway.


(I have tried "SSH Port Forward" type using $PARENT_HOST$, but it requires one port pr. host statically configured and when opening a session using the "SSH Port Forward" session as gateway, it does create the port forward, but RDM tries to connect to the HOST ip, not localhost as expected)


BR


Michael

Clock2 yrs

Hello,

Changes have been made internally to support this, let me describe how it will work and the limitations that come with it:

1. Create an SSH Tunnel entry with $PARENT_HOST$ as the remote host
2. Edit the entries that will use the previously created SSH Tunnel entry
3. In the VPN/SSH/Gateway tab, in the Settings section, there will be an option "force allow multiple instances of vpn" which will allow the same SSH tunnel to be started multiple times.
4. Make sure "Override parent" option is selected too.

This will work with the dynamic port too.
Here are the limitations you must work with though:
1. If you don't put the same VPN group on all of the entries using that tunnel, closing one entry will close all the tunnels
2. If you put the same VPN group on all of the entries, closing one entry will not close any tunnel, unless the last entry from the tunnelgroup was closed. Then, it will close all the tunnels

This happens because internally, all of the opened tunnels are the "same entry". This is a limitation of RDM and it is currently not possible to easily deal with this.

I hope these changes will work out for you.

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs

Thank you very much..

I managed to setup 1 session for this, but I can't get the next session to use the same SSH Tunnel

BTW, I can't seem to find the setting
3. In the VPN/SSH/Gateway tab, in the Settings section, there will be an option "force allow multiple instances of vpn" which will allow the same SSH tunnel to be started multiple times.
I only have "Use dynamic port" and the Other section inside Settings tab of VPN/SSH/Gateway
And the Other section incl. Override Parent and Override visibility

Both sessions are in the same VPN group.
The 2nd session I try to open does the "Wait for VPN", then tries to connect to the IP and port 3389 of the Remote host, instead of localhost:dynamicPort
This happens no matter which one I open last.

Also I'm having a strange issue, where the VPN Wait always does a static 5 second wait timeout, followed by a new timeout of the seconds I have configured in the VPN/SSG/Gateway -> Advanced sections, I can't get rid of the first 5 second wait timeout popup.

BR

Michael

Clock2 yrs

Sorry, I forgot to mention that the new option will be available in the next build of RDM (12.0.10.0), it isn't currently available.

I'll check for the duplicate time out, I can reproduce it on my end.

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs

Ok, sounds good .

Looking forward to 12.0.10.0 :-)

Regards

Michael

Clock2 yrs

Oh btw.
Could it be possible to just allow multiple sessions of the "SSH Tunnel", so we don't need to force allow from every Remote Sessions using it?
If I allow multiple sessions of my "SSH Tunnel", it is actually possible to open more than one, but only if I open it manually.

Regards

Michael

Clock2 yrs

Yes, the option in the settings of the SSH Tunnel to "allow multiple connections" will work too.

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs