Forum / Remote Desktop Manager - AddOns

Bomgar password

  • Create an Issue
  • Cancel

Hi there,

I'm about to setup a Bomgar connection, but I'm having some issues with the password field.
Although it has been defined in the config, it doesn't seem to be sent over to Bomgar.

This is the config:
bomgar+config

And this is the error:
bomgar+error

I'm using the latest version of RDM (v.11.7.3.0) and the Bomgar add-on (2.2.0.0)

Thanks,
Rick

bomgar_config.png
bomgar_error.png
Clock3 yrs

Hello,

I am not able to reproduce your issue with RDM 11.7.3.0 and Bomgar add-on 2.2.0.0.

Does bomgar is already opened in your task bar? Bomgar needs to be completely closed on your computer.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 yrs

Hello Jean-François,

Bomgar is completely closed.
Tried it on different machines. Also with fresh install of the Bomgar Representative Console. Same issue.


For what it's worth; the Bomgar version is 16.1.1 (62199)

Thanks,
Rick

Clock3 yrs

Hello,

Inside your folder C:\Program Files\Bomgar\Bomgar Representative Console, do you have a bomgar-rep.exe file?

In RDM, please go in File -> Options -> Path and make sure that the Bomgar add-on is pointing to the folder C:\Program Files\Bomgar\Bomgar Representative Console.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 yrs

RDM is pointed at C:\Program Files\Bomgar\Bomgar Representative Console
Inside this folder, there are no files. Only one subfolder which contains the bomgar-rep.exe file.
I've copied that single file to C:\Program Files\Bomgar\Bomgar Representative Console as well, but get the same error.

Clock3 yrs

Hello,

Maybe something has changed in the bomgar command line with your version.

Could you try to open the Bomgar console with the appropriate username and password via a command line.

The command line should look like C:\Program Files\Bomgar\Bomgar Representative Console\bomgar-rep.exe -username user123 -password password123 pass -submit-login

I am not able to found documentation on their command line on their website. Maybe you have this documentation in hand because you are a Bomgar customer.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 yrs

That only seems to open the Rep Console. Doesn't fill in the username or password.
Have tried to find the appropriate command line options myself, but haven't found them as well..

Clock3 yrs

Hello,

Maybe the issue is caused by the version that you are using.

As per a previous post, you are using 16.1.1. My trial version is 14.1.3.

Is it possible to send us at support@devolutions.net your 16.1.1 installer so that we can test this version in our environment.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 yrs

Hello,

I just sent you the email with the installation file.

Thank you,
Rick

Clock3 yrs

@everyone,

It seems that the Bomgar command line parameters has changed between Bomgar 14.1.3 and Bomgar 16.1.1.

With Bomgar 16.1.1, the following command line doesn't send the password
"C:\Program Files\Bomgar\Bomgar Representative Console\XXXX\bomgar-rep.exe" --username user1 --password Passw0rd
With Bomgar 14.1.3, this command line works properly.

Does someone is able to provide us (if there's one) the apporpriate command line to send the password with Bomgar 16.1.1?

Best regards,



Jeff Dagenais

signaturesignature

Clock3 yrs

The only thing I've been able to find so far is this:
https://www.bomgar.com/docs/remote-support/how-to/integrations/api/client-script/login.htm

Haven't been able to test it though..

Clock3 yrs

Hello,

The link that you provide us is for a webpage, this link doesn't include any command line paremeters.

Maybe you can try to send an email to Bomgar and ask them the question directly about the command line.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 yrs

True. But from what I understand, the website can create a Bomgar login script which can be executed by RDM.
If this works, it wouldn't be a fix, but a decent workaround.

Clock3 yrs

Hello,

If you can provide us the proper command line to use, this would be great.

This will allow us to update our code with the proper command line.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 yrs

Hello,

the same problem come back now. i have a bomgar 18.2.5.32978 and the last verison of add-on.

best regards

Clock5 mths

@support26,

As I understand, the password is not sent. Am I correct?

If it's the case, is it possible for you to provide us a proper command line that is sending the password properly so that we can adjust our integration?

Best regards,



Jeff Dagenais

signaturesignature

Clock5 mths

Hi,

I'm having the same issue now. I'm not sure what the command line command is though RDM version 14.1.3.0 Bomgar 18.2.9 Bomgar Add-On 2.3.0.0. The command-line options gives me the same thing(username gets sent but not the password)

Clock4 mths

Hello,

If the command line from Bomgar doesn't sent the password outside RDM, this may explain why inside RDM, the password is not send.

Best regards,



Jeff Dagenais

signaturesignature

Clock4 mths