Forum / Remote Desktop Manager Mac - Support

iterm/ssh on mac cursor

  • Create an Issue
  • Cancel

When I start an SSH iterm connection to an Ubuntu 14.04 server, the cursor is a $ only and the actual cursor is at the first column, right on top of the $. When I type it goes horizontal for two or three characters then jumps back to the first column. Almost like it thinks it's a 3 column wide display. When I type a command though it displays correctly. I have xterm-256 color selected. I am expecting to have the current directory before the $ and allow me to see what I type. smile What am I missing? I can't seem to find an option that changes this behavior. When I ssh with iterm into an arch linux distribution it seems to work fine with the same settings.

Thanks
-Steve

Clock5 yrs

Hi Steve,

Your post ended up on the wrong forum and I didn't see it before this morning.
Do you have iTerm installed on your mac? https://www.iterm2.com
To help us determine if the issue is in iTerm or in our implementation could you verify if you have the same behaviour using the iTerm app instead of Remote Desktop Manager.

Thank you

Benoît Sansregret

signaturesignature

Clock5 yrs

Hi,

I've managed to reproduce your issue.
In my case changing the terminal type to ansi fixed the cursor position.

Tell me if that helped you

Regards,

Benoît Sansregret

signaturesignature

Clock5 yrs

I would have bet money that I'd tried every one of those settings. Guess not. ANSI fixed it for me also.

Thanks
-Steve

Clock5 yrs