Unable to update PAM account attributes when provider unreachable. Need Provider maintenance mode feature
0 vote
Hello,
Using DLVS v2023.3.6.
Previously imported a domain account into PAM successfully, however with provider now being being offline temporarily, we are unable to set the account to be unmanaged. Also suspect its not possible to update other attributes such as description etc.
Both the account and provider show as a failure in the email alerts during periodic PAM heartbeats, which obfuscates legitimate alert content
Ideally individual providers could be put into a form of 'maintenance mode' that doesnt result in alerts being generated for the respective accounts / provider during periodic heartbeat checks.
Pls let me know if you would like any additional info.
Thanks
Joe
Hello,
I have moved this topic to the feature request forum.
Best regards,
Richard Boisvert
Hi Richard,
Is it not still a bug that a PAM account cannot be set to unmanaged when the provider is unreachable? While the maintenance mode option maybe a feature request, the underlying cause/bug still needs to be resolved.
Thanks
Joe
Hello,
You are right, the PAM account should be editable even if the provider is unreachable. We will have a look. About the maintenance mode, I understand you're point. We are working currently to improve notification sent to administrators. It should be possible to enable/disable notifications. So in cases where it is "normal" to have the heartbeat failing, it will be possible to disable the notification. It should help in your situation.
Best regards,
François Dubois
Hello,
For your information, with our latest build, 2024.1.4.0, you should be able to edit the PAM account even if the provider is not available. Let us know if it works.
Best regards,
François Dubois
Hi François,
Just tried adding a description to an existing PAM account where the provider is experiencing issues, but it didnt work. If I click yes on the first message, it shows second error shown below.
Thanks
Joe

387410df-7d0f-48e5-abfb-513fe9723574.png
c427b02f-a3ca-468b-8cad-a09a0bf8e2d5.png
Hello Joe,
I'm sorry to hear that. We are investigating the issue and will let you know as soon as we have an update.
Best regards,
François Dubois
HI François,
Just an fyi, the PAM account I tried to update the description of is also affected by the password reset/validation issue with LDAP referals described at https://forum.devolutions.net/topics/41289/ldap-referals-to-unreachable-child-domain-breaks-pam-password-resetval#188591
Irrespective, it should be possible ot update attributes such as the description even when the associated provider may have other issues.
Pls let me know if you would like any additional info.
Thanks
joe
Hello Joe,
Absolutely, we just found the issue and fixed it. A new build should be available early next week.
Sorry for the inconvenience.
Best regards,
François Dubois
Hi joe
This issue has been fixed in our latest version 2024.1.6.0
Best regards
Marc-Andre Bouchard
Thank you Marc-Andre. I've confirmed the issue is resolved with DVLS 2024.1.6.0