Forum / Remote Desktop Manager - Beta

Devolutions cloud credentials prompt

  • Create an Issue
  • Cancel

Despite having the box ticket, I am still prompted for Devolutions cloud credentials nearly every time I unlock the app (it locks when idle). Interestingly, it isn't every single time so seems pretty odd, but I don't think this is expected behavior.

image

Clock7 mths

image

Clock7 mths

Hello,

Could you send us a screenshot of your data source configuration?
To do so, go in File -> Data Sources.

Best regards,



Jeff Dagenais

signaturesignature

Clock7 mths

image

Clock7 mths

Hello,

If you navigate to %localappdata%\Devolutions\RemoteDesktopManager, edit the RemoteDesktopManager.cfg file in notepad, do you see the following line inside?
RDMOAutomaticSignIn>true</RDMOAutomaticSignIn>

Is the option set to true?


Best regards,



Jeff Dagenais

signaturesignature

Clock7 mths

It is, here is a screenshot of what I found:

image

Clock7 mths

Hello,

I suspect something wrong with your configuration file.

Could you close RDM and rename the RemoteDesktopManager.cfg file into RemoteDesktopManager.old. Reopening RDM will create a new configuration file automatically.
Hope this will resolve your issue.

Best regards,



Jeff Dagenais

signaturesignature

Clock7 mths

I've recreated the configuration file from scratch and put back all my customizations. Seems ok so far but I'll report back after a few days of usage. For what it's worth, this did not resolve bug 'DEVO-2124 Navigation Pane/UI Issue', which I thought may be related to this corrupted config file issue.

Clock7 mths

The app has again prompted for devolutions credentials. This was after the system was idle and locked, and the app was locked too. I had to enter in my normal application password, and then the cloud credentials. I do not know if this is intended behavior, but I can confirm it happens every time the app is locked.

Clock7 mths

Hello,

Could you go in File -> DataSources -> Edit -> Advanced tab and check the Disable Lock option and see if that help.

Best regards,



Jeff Dagenais

signaturesignature

Clock7 mths

Yep that removed it. Was this intended behavior all along? I guess the idea is the 'always lock' option overrides the 'always remember' option?

Clock7 mths

Hello,

Probably that the issue was this option not checked all along.
When you lock RDM, foe security reasons, RDM will ask to enter the password to authenticate on the database.
If you don't want this behavior, this is why we need to enable the Disable lock option.

Glad that is now working!

Best regards,



Jeff Dagenais

signaturesignature

Clock7 mths