Forum / Remote Desktop Manager - Beta

14.0.6.0 RDM uses proxy for LastPass when main option is set to none

  • Create an Issue
  • Cancel

Since the last beta and now this one, RDM is trying to use my system proxy even though the main application setting is set to "None" - this is making the use of LastPass impossible. See attached screenshot of the log view.

It doesn't seem to effect update downloads as they connect and download just fine.

Clipboard01.jpg
Clock2 yrs

Hello,

Where have you configured your Proxy? Is it configured directly in RDM or on your workstation?

Also, would it be possible for you to provide me a screenshot of the Properties of your LastPass entry? If it is, please send it to support@devolutions.net and I will see what might cause this issue.


Best regards,



James Lafleur

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock2 yrs

It's configured on both the workstation (proxy is set) and in RDM (no proxy set), but RDM does not need to use it in fact it gets blocked to LastPass and a few other things if it tries to use the proxy.

Clock2 yrs

Hello,


According to the log you sent us above, it seems that RDM is not able to authenticate on your proxy.

You could also try to have RDM use your currently configured Proxy by going to File -> Options -> General -> Proxy (Web) -> Proxy Settings -> Check System Default
SystemProxy

Best regards,



James Lafleur

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

SystemProxy.jpg
Clock2 yrs

I don't want to use the proxy, and when I did in the past I had the same problem and do now when I try it again (and no I am not going to use the manual option either).

There's a special firewall bypass I use on my machine so I don't have to use the proxy, yet for some reason RDM still wants to use it even though it's set to "No Proxy". Before 14.0.5.0 it worked fine and didn't use the proxy.

Clock2 yrs

Hello,

Thank you for this information.

That being said, do you remember on which version of RDM this used to work?

I will test this scenario in my environment and I will contact you as soon as I have more information on that matter.

Best regards,



James Lafleur

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock2 yrs

It worked with whatever the previous version was to 14.0.5.0 as I update almost every time you release one.

Clock2 yrs

Hello,

Thank you for this information and sorry for the delay.

A ticket has been created on that matter. I am building an environment that will allow me to test this issue and I will notify you as soon as I have more information on that topic.

For further reference, the ticket number is Devo-1049

Best regards,



James Lafleur

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock2 yrs

Sorry, I've been kind of busy of late but it does seem that things might have resolved themselves since installing v14.0.7.0 - LastPass hasn't even been asking me for authentication which is a bit odd. So I'm not sure if it's now using the saved credentials in Windows, or somewhere else as I deleted them all and it still connects me.

What's the best debug log level and setting for me to capture more of what is going on? It's not informing of updates either, had to discover 14.0.7.0 and 14.0.8.0 by looking at your site, and also I have another issue as I'm moving away from LastPass to Bitwarden and it won't let me connect (I submitted a separate thread for that one).

Cheers,
Taomyn

Clock2 yrs

Hello,

This is an odd behavior indeed.

Regarding the question you had with the Debug Level log, you could use the Profiler with the Debug level set to 1. Doing so would allow you to gather more information on this behavior.

For more information on that matter, please refer to the following link: https://help.remotedesktopmanager.com/help_profiler.htm.

Also, regarding the issue you reported with Bitwarden, I will leave let my colleague in charge of this thread help you with this.

Best regards,



James Lafleur

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock2 yrs

Hi again,

I tried to submit a new ticket for this, no idea if it worked as I never received an email, so I thought I would update this thread as it has started happening again since installing the latest beta, 2019.1.3.0 today.

The proxy settings in RDM are disabled, the system setting is enabled, yet RDM tries to use the proxy to access my LastPass credentials unless I also disable the system proxy.

Perhaps the attachments here can help.

RDM.xml
{6F35260F-B171-415E-AD6C-CB7B5D5BB9FB}.png.jpg
RemoteDesktopManager6404-03-2019.log
Clock10 mths

Hello,

We received the email that you have sent to support@devolutions.net . This address does not provide an automatic reply to validate that we have received your email. To receive one and to create a ticket, you need to send an email to ticket@devolutions.net.

That being said, I created the ticket Devo-2135 upon the reception of your email. I will contact you using this ticket and update the current forum topic as soon as a solution will be found.

You should also receive an email from support@devolutions.net to confirm that your request have been moved to our ticketing system.

Best regards,



James Lafleur

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock10 mths

James Lafleur wrote:

Hello,

We received the email that you have sent to support@devolutions.net . This address does not provide an automatic reply to validate that we have received your email. To receive one and to create a ticket, you need to send an email to ticket@devolutions.net.

That being said, I created the ticket Devo-2135 upon the reception of your email. I will contact you using this ticket and update the current forum topic as soon as a solution will be found.

You should also receive an email from support@devolutions.net to confirm that your request have been moved to our ticketing system.

Best regards,


Got the ticket, sent a response to the question.

Clock10 mths

@everyone,

Our tests regarding this issue have led us to the conclusion that this issue was caused by a restriction in the environment of the user preventing RDM from contacting LastPass.

Best regards,



James Lafleur

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock10 mths

For the record: the issue is not with my environment, it is with LastPass within RDM always forcing the use of the system proxy settings and not obeying the proxy setting of RDM.

Clock10 mths

Hello,

The proxy is always enabled on your workstation right?
Is it possible for your workstation to go on the internet without going through the proxy?
Is LastPass blocked by your proxy server?

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock9 mths

Jean-Francois Dagenais wrote:

Hello,

The proxy is always enabled on your workstation right?
Is it possible for your workstation to go on the internet without going through the proxy?
Is LastPass blocked by your proxy server?

Best regards,


No, not always though most of the time I am not using the proxy - it depends on what I am doing and where I am (laptop), but if I tell RDM to no use the proxy I expect it to behave that way.

Yes and no - depends on where I am, but mostly yes.

Yes, LastPass is blocked by our proxy (don't ask me why), but BitWarden isn't but that's not to say it won't be in the future as it grows in popularity. Plus we're changing proxy from ClearSwift to McAfee so who knows what will change.

The proxy also requires authentication which is another reason I don't often use it as so much fall flat just because of that - I know RDM supports it, but it's just annoying to keep updating my credentials when I'm forced to change my password.

Clock10 mths

Hello,

Thank you for the explanation.

Indeed, if you don't have a proxy configured on your workstation, RDM should not go through the proxy.

From your home computer, which probably doesn't use a proxy at all, are you able to use LastPass entries as expected inside RDM?

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock10 mths

From home yes no problem - I have a different set-up of RDM at home with a MariaDB source for my personal machines, and I share the local database for my work machines using ownCloud. I'm never on both at the same time so the file never gets messed up.

Clock10 mths

Hello,

I was expecting this kind of answer.

This means that the proxy on your workstation at work seems to interfere even if you turn it off. Is this possible?
How the proxy is configured? Under IE? How do you disable it?

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock10 mths

Jean-Francois Dagenais wrote:

Hello,

I was expecting this kind of answer.

This means that the proxy on your workstation at work seems to interfere even if you turn it off. Is this possible?
How the proxy is configured? Under IE? How do you disable it?

Best regards,


It's the proxy settings in Internet Options for IE - it's set by GPO at logon but I can temporarily disable it during the day in order to bypass it long enough to make a connection before it gets set back automatically. I do a lot of work with Azure and Office 365 services and the proxy gets in my way, and only some aspects e.g. PowerShell, allow me to set the proxy to "none".

Clock10 mths

Hello,

Sorry for the late reply.

I would try to get a test environment with a proxy like you have, but I cannot guarantee that it would be possible.
If yes, I will then try to test your behavior and see if I am able to reproduce your issue.

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock9 mths