Forum / Remote Desktop Manager Mac - Feature Request

Send press key as unicode option ...

  • Create an Issue
  • Cancel

Hello,


I used this software Royal RTX. For some reason I changed for yours.
But one of the features I loved on Royal TSX is when I hit the "@" key on my Mac, I had an "@" in my Windows RDP connection on the screen.
And with Remote Desktop Manager I can not find this option.
This option is called "Send press key as unicode" on Royal TSX "(see attached file)
Can you add this option in the next version?


Thanks,

Regards.
Lucien.

keybord.jpg
Clock9 mths

Hi,

We'll need to investigate a bit, but I'll come back to this thread as soon as I have more information.

Best regards,

Xavier Fortin

signaturesignature

Clock9 mths

Hi,

OK thanks.

Regards,
Lucien

Clock9 mths

Hi Lucien,

We've identified the option and its behavior. We should have this done for a coming version (if not the next, the other after it).

Best regards,

Xavier Fortin

signaturesignature

Clock9 mths

Hi Xavier,

It's a great news. I test this app for now, as soon as this option as available I will but it.
Thanks a lot.

Regards,

Lucien

Clock9 mths

Hi Lucien,

This has been done and will be available in the next release of RDM Mac.

You'll find the option (Send input as unicode) in the RDP session settings under the Local Resources tab, in the Keyboard box.

Note that this will only be supported with the RDP Modern Engine. You can change which engine your sessions use globally in the Preferences, under the Session Type -> RDP tab, in the General box. The option is called RDP Engine.

Best regards,

Xavier Fortin

signaturesignature

Clock9 mths

Hi Xavier,


Awesome ! You are terribly efficient guys.
I will test it when it will be available and I will make you aa feedback.

Thank you.


Regards,

Lucien.

Clock9 mths

Hi, is it possible to make it as Global option?

Clock5 mths

Hi,

I've filed the request. I'll post back when it is done.

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

I just find out, that keys are correct with this option, but ENTER key behave strangly.
I can use it in text editors just fine, but not for actually run/confirm anything (like icons on desktop, cmd shell etc.). It does nothing.
I have Czech keyboard on Mac and cs-CZ keyboard in target Windows.

Clock5 mths

Hi Martin,

I've reproduced the issue and filed the issue. I'll post back in the thread when it is resolved.

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

Hi Martin,

The issue with the Enter key has been resolved internally. You can expect a fix in the next official release.

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths