Forum

Posts by JohnDoe (JohnDoe)

JohnDoe
JohnDoe
Posts: 55

I%27m%20not%20really%20sure%20if%20this%20is%20a%20bug%20or%20a%20feature%20request%2C%20but%20if%20you%20refactor%20an%20entry%20with%20a%20template%2C%20there%20are%20some%20options%20that%20are%20replaced%2C%20where%20I%27m%20not%20sure%20if%20this%20correct.%3Cdiv%3EIf%20you%20check%20all%20boxes%20at%20%22Entry%20parts%20to%20keep%22%20RDM%20still%20replaces%20for%20example%20the%20icon%20or%20the%20sort%20order%20of%20the%20entry.%20Shouldn%27t%20at%20least%20the%20icon%20should%20remain%20the%20old%3F%3C/div%3E%3Cdiv%3E%3Cbr%3E%3C/div%3E%3Cdiv%3E%3Cspan%20style%3D%22font-size%3A%2011.8181819915771px%3B%22%3EUse%20Case%3A%20We%20make%20heavy%20use%20of%20the%20sub%20connection%20feature%20and%20have%20different%20templates%20for%20creating%20entries.%20To%20make%20life%20even%20easier%20we%20also%26nbsp%3B%3C/span%3E%3Cspan%20style%3D%22font-size%3A%2011.8181819915771px%3B%22%3Ehave%26nbsp%3B%3C/span%3E%3Cspan%20style%3D%22font-size%3A%2011.8181819915771px%3B%22%3E%22addon%22%20templates%2C%20that%20create%20special%20subconnections%20on%20existing%20connection%20entries.%20If%20we%20use%20these%20addon%20templates%20we%20always%20have%20to%20correct%20the%20icon%20and%20sort%20order.%3C/span%3E%3C/div%3E%3Cdiv%3E%3Cspan%20style%3D%22font-size%3A%2011.8181819915771px%3B%22%3E%3Cbr%3E%3C/span%3E%3C/div%3E%3Cdiv%3E%3Cspan%20style%3D%22font-size%3A%2011.8181819915771px%3B%22%3EKind%20regargs%3C/span%3E%3C/div%3E%3Cdiv%3E%3Cspan%20style%3D%22font-size%3A%2011.8181819915771px%3B%22%3EJohn%20Doe%3C/span%3E%3C/div%3E

5 yrs Refactoring overwrites to much
JohnDoe
JohnDoe
Posts: 55

I'm not really sure if this is a bug or a feature request, but if you refactor an entry with a template, there are some options that are replaced, where I'm not sure if this correct.
If you check all boxes at "Entry parts to keep" RDM still replaces for example the icon or the sort order of the entry. Shouldn't at least the icon should remain the old?

Use Case: We make heavy use of the sub connection feature and have different templates for creating entries. To make life even easier we also have "addon" templates, that create special subconnections on existing connection entries. If we use these addon templates we always have to correct the icon and sort order.


Kind regargs
John Doe

5 yrs Refactoring overwrites to much
JohnDoe
JohnDoe
Posts: 55

I just thought several times about asking the same thing. So +1 from me wink There are many scenarios, where this would be a really helpful feature in environments, that make heavy use of DNS.

Kind regards
John

6 yrs Resolve Hostname first. If fail; use IP history...
JohnDoe
JohnDoe
Posts: 55

Hi RDM Team,

I just wanted to report back, that the new versions fixed the problem for us.

Thanks and kind regards
John

JohnDoe wrote:

I think I maybe found a bug with sub connections. When the description field is edited by double clicking the description field, a new connection is created when saving the changed description. For details see the attached PSR recording.
This is not happening when the description is edited with the normal edit dialog (Ctrl+E).

6 yrs Remote Desktop Manager 9.5 Beta
JohnDoe
JohnDoe
Posts: 55

Hi RDM Team,

I think I maybe found a bug with sub connections. When the description field is edited by double clicking the description field, a new connection is created when saving the changed description. For details see the attached PSR recording.
This is not happening when the description is edited with the normal edit dialog (Ctrl+E).
I don't know if its relevant, but we use a MySQL Datasource. Let me know if you need some more Input.

Regards
John

6 yrs Remote Desktop Manager 9.5 Beta
JohnDoe
JohnDoe
Posts: 55

Hello David, thanks for the new build - it works like a charm now. wink

6 yrs Remote Desktop Manager 9.5 Beta
JohnDoe
JohnDoe
Posts: 55

Hello David, thanks for the confirmation of the behavior. I will test again as soon as there is build available where this is a configuration option or the default setting.

Thank you for the real fast help!

6 yrs Remote Desktop Manager 9.5 Beta
JohnDoe
JohnDoe
Posts: 55

@Jean-Fran├žois and dhervieux: Sorry, I only looked at the local app data directory and deleted the Devolution Stuff in there. While testing on a second machine with a copy of the program directoy form the netshare I realized, that in the versions after 9.4.7.0 the offline.db file is created in the program directory instead of the local app data folder. One could have seen this if looking in the data source information... wink


So there the problem starts with our shared program folder. In terms of using RDM from an usb stick this seems a valid location. But by using the program from a shared location or without local admin (or write) rights in the program files folder it's maybe not the best decision. Is there a way to configure the offline.db path?

6 yrs Remote Desktop Manager 9.5 Beta
JohnDoe
JohnDoe
Posts: 55

@Jean-Fran├žois: Thank you for the hint, but deleting the whole Devolutions stuff in the Local App Data folder doesn't make any change.

6 yrs Remote Desktop Manager 9.5 Beta
JohnDoe
JohnDoe
Posts: 55

We use RDM with a MySQL DB from a network share. Since Version 9.4.8.0 we have the problem, that RDM only starts on the machine, where the datasource was initially configured. All other machines receive the following error message after opening RDM from the share an typing the MySQL password:

System.Data.SQLite.SQLiteException (0x80004005): file is encrypted or is not a database
file is encrypted or is not a database
at System.Data.SQLite.SQLite3.Prepare(SQLiteConnection cnn, String strSql, SQLiteStatement previous, UInt32 timeoutMS, String& strRemain)
at System.Data.SQLite.SQLiteCommand.BuildNextCommand()
at System.Data.SQLite.SQLiteCommand.GetStatement(Int32 index)
at System.Data.SQLite.SQLiteDataReader.NextResult()
at System.Data.SQLite.SQLiteDataReader..ctor(SQLiteCommand cmd, CommandBehavior behave)
at System.Data.SQLite.SQLiteCommand.ExecuteReader(CommandBehavior behavior)
at System.Data.SQLite.SQLiteCommand.ExecuteScalar(CommandBehavior behavior)
at System.Data.SQLite.SQLiteCommand.ExecuteScalar()
at Devolutions.RemoteDesktopManager.Business.SQLiteHelper.ExecuteScalar[T](String connectionString, String sql, SQLiteParameter[] parameters, Boolean rethrow)
at Devolutions.RemoteDesktopManager.Managers.OfflineManager.ExecuteScalar[T](BaseConnectionDataSource dataSource, String connectionString, String sql, SQLiteParameter[] parameters, Boolean rethrow)
at Devolutions.RemoteDesktopManager.Managers.OfflineManager.Upgrade(BaseConnectionDataSource dataSource)
at Devolutions.RemoteDesktopManager.Managers.OfflineManager.Initialize(BaseConnectionDataSource dataSource, Boolean force)
at Devolutions.RemoteDesktopManager.Managers.OfflineManager.Save(BaseConnectionDataSource dataSource)
at Devolutions.RemoteDesktopManager.Managers.SecurityManager.LoadSecurity()
at Devolutions.RemoteDesktopManager.Managers.ConnectionManager.LoadConnectionsFromDataSource(BaseConnectionDataSource connectionDataSource

Do you have any idea what has changed sind 9.4.8.0? The problem also applies to version 9.4.9.0. At the moment we are still running 9.4.7.0 as it is running fine...

Thank you

6 yrs Remote Desktop Manager 9.5 Beta
JohnDoe
JohnDoe
Posts: 55

Thats the content of "RemoteDesktopManager.log":

[17.09.2013 13:34:24]ERROR SILENT System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
at System.Reflection.Module._GetTypesInternal(StackCrawlMark& stackMark)
at System.Reflection.Assembly.GetTypes()
at Devolutions.RemoteDesktopManager.Managers.AddOnManager.Load()
[17.09.2013 13:34:24]ERROR SILENT System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
at System.Reflection.Module._GetTypesInternal(StackCrawlMark& stackMark)
at System.Reflection.Assembly.GetTypes()
at Devolutions.RemoteDesktopManager.Managers.AddOnManager.Load()
[17.09.2013 13:36:00]ERROR SILENT System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
at System.Reflection.Module._GetTypesInternal(StackCrawlMark& stackMark)
at System.Reflection.Assembly.GetTypes()
at Devolutions.RemoteDesktopManager.Managers.AddOnManager.Load()
[17.09.2013 13:36:52]ERROR SILENT System.Net.WebException: The remote name could not be resolved: 'remotedesktopmanager.com'
at System.Net.HttpWebRequest.GetResponse()
at Devolutions.Utils.StreamUtils.ReadFileStreamFromWeb(String filenameUrl, Boolean useDefaultCredentials)
at Devolutions.RemoteDesktopManager.Business.BusinessHelper.GetXmlStringFromWeb(String url)

I just realized, that the message only appears in the 64bit version of RDM. the 32bit version works fine so far.

Small Sidestep (or enhancement suggestion?): Would it be possible to make an option to call the 32bit version of Internet Explorer in the 64bit version of RDM (or make it the default behavior)? Some Browser Plugins are a bit problematic with the 64bit version...

7 yrs Could not download the content from the internet
JohnDoe
JohnDoe
Posts: 55

Ok, thanks for the answer. Let's hope that it was a special case in our environment... wink

7 yrs MySQL scheme update issue
JohnDoe
JohnDoe
Posts: 55

Here a screenshot of the message. For reproducing the message box I just edited a sessions Description.
SnipToolPlusImg
edited by JohnDoe on 9/16/2013

7 yrs Could not download the content from the internet
JohnDoe
JohnDoe
Posts: 55

Since updating to RDM 8.9.15.0 we see the message box "Could not download the content from the internet" very often. It states that RDM can't lookup "remotedesktopmanager.com" and if we wan't to configure a proxy. As we have a closed network without direct internet access for our administration machines that fact is very annoying, because the message pops up on every 2nd action...

Seems a bit strange as we disabled auto update. So why is RDM actually calling home?

Kind regards

7 yrs Could not download the content from the internet
JohnDoe
JohnDoe
Posts: 55

Hi, I encountered a Problem while updating the MySQL DB scheme while upgrading from Version 8.4.1.0 to 8.9.15.0.
The scheme update ran fine till version 113 and stopped there, stating that the table TodoUsers is already there.


I reverted my database to the backup I had done before the update. At this point this table wasn't there. So the scheme update creates the table and later on it struggles because it is already there.
I dropped the table TodoUsers after the error occured again and ran the scheme update afterwards and created the table again. The update ran fine than, so I think it should be only an error in the database update script...


Kind regards.

7 yrs MySQL scheme update issue
JohnDoe
JohnDoe
Posts: 55

Thanks for the effort! I just PMd you an URL where you can test the behavior.

7 yrs Web Browser Session ControlID/Name choose box
JohnDoe
JohnDoe
Posts: 55

Thanks for the quick reply and the tip, but sadly for this specific webpage it can't work in this way.
This login page doesn't have those two boxes displayed on the same page. One has to fill in the username first, click login and than it prompts for the password.

7 yrs Web Browser Session ControlID/Name choose box
JohnDoe
JohnDoe
Posts: 55

Would it be possible to have the possibility to choose whether the given information is a HTML Control ID or if its a Control Name for the "Form Login" function of the Web Browser Session?

I ask because we have a WebInterface where the IDs are a bit strange.

username input box:
input type="text" name="username" maxlength="50" value="" id="password"

an the password input box:
input id="password" type="password" name="password" size="20" value=""

As you can see, the Control ID is "password" for both boxes. For sure that's an error in the webinterface.
But without the possibility do declare that the given ID/Name specifies a Control Name the form filler fills in the password in both fields.

It would be nice if you could have a look into this.
Best regards

7 yrs Web Browser Session ControlID/Name choose box
JohnDoe
JohnDoe
Posts: 55

Hi, we just updated to the latest Version. Works like a charm now.

Thank You for fixing this and keep up the good work!

7 yrs Copy Password of putty session using Parent Cred.
JohnDoe
JohnDoe
Posts: 55

It's a "credential entry", but I tried with "default" and it doesn't work either...

7 yrs Copy Password of putty session using Parent Cred.
JohnDoe
JohnDoe
Posts: 55

The parent entry is a Host Entry. And sorry, I think my OP has gone to the wrong subforum - we see this with RDM, not Password Manager Vault :/

7 yrs Copy Password of putty session using Parent Cred.
JohnDoe
JohnDoe
Posts: 55

In our environment its not possible to copy the password of putty Sub-Connections to the clipboard when using "Parent" Credentials. It always states that there is nothing to copy. A scp entry as child of the same connection with similar settings works as expected.

We are running Version 8.0.25.0 with a MySQL Data Source.


Can you reproduce this behavior?

7 yrs Copy Password of putty session using Parent Cred.
JohnDoe
JohnDoe
Posts: 55

Thanks, that would be perfect! wink

7 yrs Disable "Collapse tree view on clear filter"
JohnDoe
JohnDoe
Posts: 55

Hmm, thanks for the answer. But since its not a bug, is there a way of having the old behavior back?

We organized our sessions and additional information in a manner, that relies on this feature. Before the change we could search our sessions, find the right entry and hit the clear button and had all entries for a specific server/device in a folder at hand. Especially when using the description field to have some sort of full text search in additional information this was very streamlined.

It would be great if this behavior could be made optional!

7 yrs Disable "Collapse tree view on clear filter"
JohnDoe
JohnDoe
Posts: 55

At first, thanks for this great tool. Before we used RDM we had all our connection related things in batch files. So no one would make changes to the stuff and you never found what you were searching for. So RDM makes keeping track of all systems and credentials for our IT staff a lot easier.

But since updating to Version 8.0.11.0 the option "Collapse tree view on clear filter" seems to be always on. Even if the tick isn't in the checkbox.
Because we have a large number of hierarchical entries, we make heavy use of the search box, so it is very annoying that focus jumps to session root and collapses all entries on hitting the "clear" button.

Can you confirm this as a bug or do we have a problem?
Thanks!

7 yrs Disable "Collapse tree view on clear filter"