Forum

Posts by pll (pll)

pll
pll
Posts: 12

Hi

@erica no i did not, but the NETBIOS name did the trick here too! We can now logon using Windows Authentication. Yay!

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

Hi all

I've changed the Default Web Site, and the Application Authentication Settings to the pictures above.

Also tried MarcST1984 workaround, all with the same outcome "Invalid username or password, please verify your credentials!"


No errors in DPS log and all 200-ok http status in the W3SVC log to urls like loginWindows/partial, security/forcepublicipvalidation and the IIS is seeing my credential but as DOMAIN\initials. We logon on using initials@domain.tld

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

yeah sure thing I'll do that right away

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

Is there anything inside IIS that we should cross check?
My setup is:
Running in the Default Web Site, in the dvls subfolder as an enabled application.
Application is running with a SSL certificate and authentication enabled for Anoymous Authentcation enabled and Windows Authentication enabled (HTTP 401 Challenge).
Read/Write feature delegation on the server for Authentication - Anoymous and Autentication Windows features, as described in your KB.

Apart from that a pretty basic Windows Server 2016 1607 14393.2248 virtual machine built only for the purpurse of hosting DPS, so no fancy configs besides the stuff in your KB regarding DPS and Windows Authentication.
Local SQL express with a local db-account for DPS. Both Test Server and Test Database turns up Successfull.

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

Just to clarify:

Connecting using:
- Prompt for credentials - works
- Username and password, with or without "Always ask password" option on/off - works
Successfull authentication using "Test connection" button or starting RDM with the above options.

Unsuccessfull authentication using "Test connection" button or starting RDM, as soon as i check the "Use Windows authentication"

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

@erica

No nothing new.
https://imgur.com/rPebomX
image

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

Hi

@erica sure thing, sadly no change in behaviour:
https://imgur.com/a/NQBWbxC
image

I click "ok", the same dialog pops up again
I click "ok" again, the same dialog pops up/stays on (cant determine),
I click "ok" 2-3 times more, before the dialog disappears, and turns back to a disconnected RDM.

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

@erica

Hi again,

I've checked the log in DPS, nothing special here. I have a couple of ArgumentException from the Scheduler, but they are a 10-15 minutes old. Nothing when I push the "Test Autentication" button from RDM.

Kind regards
Peter

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

Hi Erica,

My fault, just expected the DPS Console to upgrade along with server.
Anyway, I've upgraded the DPS Console to the latest, and re-run the Upgrade Server procedure by clicking the Upgrade Server button.

Results: The same, still gives me a login error, when trying to use Windows Authentication from my workstation.

I'll send a DPS Diagostic report again.

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

I've sent my diagnostic report too.

We are seeing the same "errors". No 500 error anymore, but the Windows authentication mechanisme does not work. As others has mentioned it states invalid username or password.

- Peter

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

Hi Erica,

I'm not getting the 500 error message anymore.

I'm getting the "Invalid username or password, please verify your credentials" when using Remote Desktop Manager and a prompt for login if I visit the Password Server via Chrome browser (site is added to trusted sites with automatic logon with current user name and password enabled).

I've tried adding a domain admin account to the Authentication > Domain > Domain Authentication page, with the same result. Dont know if i'm missing something in my setup.

- Peter

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14
pll
pll
Posts: 12

Hi,

Upgraded to the latest server and client today, but sadly no change here.

No matter which "Username Format" I choose in DPS, I get the "Connection failed!" in RDM.

@Erica I have sent a diagnostic report to you.

2 yrs Windows Authentication feature not working with DPS 6.0/RDM 14