Forum

Posts by acf_fordy (acf_fordy)

acf_fordy
acf_fordy
Posts: 1

I was directed here from the Google Play Store to post the issue that I'm having with both Port Forwards and SSH Tunnels on my Android devices. I have my sessions saved in the Devolutions Drive and use that to sync them between devices but I have also tried creating the session on the device with the same settings to no avail. It should be noted that the sessions work on both my Desktop and Laptop and that other sessions such as SSH Shell and SFTP work on the Android devices.

Upon trying to open my port forward session I get asked for and enter my SSH Key passphrase and a black screen appears with the text

Unable to listen for tunnel: error -17 Unable to create tunnel: error -17
which repeats for all 4 of my port forwards, but I eventually receive a toast message saying the connection was a success (even though none of the port forwards work afterwards). I have also tried creating an SHH Tunnel for just one port but the same issue occurs.

I originally thought it might just be my Android device (LG G4) so I have tried the sessions on another phone and an Android tablet which results in the same error. I know my devices can support Fort Forwards as I can use another app (JuiceSSH) which forwards the ports without issue. I have tried both with this app installed and uninstalled with the device being rebooted frequently to ensure there are no potential issues.


Please let me know what information is needed but if you require logs that may contain information about my sessions I would have to ask that I send it privately.

2 yrs Port Forwards and SSH Tunnel: error -17