Forum

Posts by magnus01 (magnus01)

magnus01
magnus01
Posts: 82

My high CPU usage went away but then came back again , and i am also seeing the same log entrys as William wrote

ArgumentException - An item with the same key has already been added.

at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
at Devolutions.Server.SettingManager.<>c__DisplayClass558_0.<GetAppSetting>b__0(DataRow r)
at Devolutions.Utils.ExtensionUtils.ForEach[T](IEnumerable`1 list, Action`1 act)
at Devolutions.Server.SettingManager.GetAppSetting(String folderInstallation)

9 mths DevolutionsSchedulerService high CPU
magnus01
magnus01
Posts: 82

Hi Erica

I have sent you screenshot of the Disk Usage by Table report.

When user is "Standard" the time takes about 40-50 seconds to load Vault in web client
When user is changed to "Administrator" or added as member of AD group that makes the gives the user "Administrator" role the time takes about 5 seconds to load Vault in web client

I also have uninstalled the Scheduler client because I got high CPU usage again after upgrading to 6.0.1.0

9 mths DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

Hi again Erica

I figured out what you mean , and I have done second modification now and also upgraded to 6.0.1.0 but I still have slowness

It takes about 45 seconds to display the Vault content in web client , but running with desktop client it goes fast

9 mths DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

Hi Erica

The first modification is already done , i use the same account for that.

I´m not sure what you mean by the second modification ?

Also , should I upgrade to 6.0.1.0 ? Im currently still on 6.0.0.0

9 mths DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

Hi

DPS server is running Windows Server 2016
AD and Forest Schema Level is 2012 R2

9 mths DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

I configured the "Web Configuration" with path and time/repeat and after that it seems that the high cpu usage has disappeard

9 mths DevolutionsSchedulerService high CPU
magnus01
magnus01
Posts: 82

Sent the Diagnostic

9 mths DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

When i Enable the cache option and try to login via web nothing happens at the web window , but i get an error emailed to me containing the error below


I noticed though that in my test DVLS i could login today , i left the box checked yesterday. Unchecked it now saved and then checked it again and now when I try to login I get the error in RDM client, so i guess there is some time delay of some sort ?

I will try later to login again and se if and when i can login and update here.


Error:
NullReferenceException - Object reference not set to an instance of an object. at Devolutions.Server.Managers.AuthenticationProvider.ProcessDomainUserInfo(String userName, String password, LoginContext membershipLoginData) at Devolutions.Server.Managers.AuthenticationProvider.DoValidateUserAgainstDomain(LoginContext loginData, UserEntity userEntity, String password) at Devolutions.Server.Managers.AuthenticationProvider.DoValidateUser(LoginContext loginData, String username, String password, UserData userData) at Devolutions.Server.Managers.AuthenticationProvider.DoValidateUser(LoginContext loginData, String username, String password) at Devolutions.Server.Managers.AuthenticationProvider.AuthenticateUser(LoginContext loginData, String userName, String password) at Devolutions.Server.Managers.AuthenticationProvider.DoValidateUserFull(LoginContext loginData, String userName, String password) at Devolutions.Server.Controllers.APIControllers.V2.BackendApiController.DoLogin(SessionContext context, String userName, String password, ClientApplicationInfo clientApplicationInfo, String twoFactorID, TwoFactorInfo twoFactorInfo, String publicIPAddress, Byte[] sessionKey, String repositoryId, Boolean partialMode, Boolean useWindowsAuthentication, Boolean useAzureADAuthentication, String localMachineName, String localMachineUserName) at Devolutions.Server.Controllers.APIControllers.V2.BackendApiController.Login(LoginData loginData, Boolean partialMode) at lambda_method(Closure , Object , Object[] ) at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ActionExecutor.<>c__DisplayClass10.b__9(Object instance, Object[] methodParameters) at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ExecuteAsync(HttpControllerContext controllerContext, IDictionary`2 arguments, CancellationToken cancellationToken) --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.Http.Controllers.ApiControllerActionInvoker.d__0.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.Http.Filters.ActionFilterAttribute.d__5.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Web.Http.Filters.ActionFilterAttribute.d__5.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.Http.Filters.ActionFilterAttribute.d__0.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.Http.Filters.ActionFilterAttribute.d__5.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Web.Http.Filters.ActionFilterAttribute.d__5.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.Http.Filters.ActionFilterAttribute.d__0.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.Http.Controllers.ActionFilterResult.d__2.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.Http.Controllers.ExceptionFilterResult.d__0.MoveNext() --- Default
Source:
Devolutions.Server.Common

9 mths DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

Hi

Yes this is configured and has been working fine before upgrading to DPS 6.0.0.0
But I noticed a setting that was strange that I now have changed so i will check if the process still goes up and down with the cpu high usage

9 mths DevolutionsSchedulerService high CPU
magnus01
magnus01
Posts: 82

After upgrading to DPS 6.0.0.0 i am experiencing that the service "DevolutionsSchedulerService" uses a lot of CPU and won´t stop doing that

I have tried to uninstall and reinstall the service but with the same result, after a while the CPU usage goes up and won´t come down unless stopping the service

9 mths DevolutionsSchedulerService high CPU
magnus01
magnus01
Posts: 82

Hi

After enabling the Domain Users and Role cache option in the Domain tab i am unable to connect to DVLS server. Following error is given.
Unchecking the box again and i am able to login again

Devolutions.RemoteDesktopManager.Business.TryGoOfflineException: DVLS server is not responding.

Unexpected exception
at Devolutions.RemoteDesktopManager.Business.DataSources.RDMSConnectionDataSource.cb6f90699089bd1c9688221883b0c338f(String c18973cea236a9feff75c32ca7d1697d5, String ceb81d1ee93f91e0bc57f34876c263863, Boolean c8c947c51eb176e7175409fd081e947ab, Boolean c2de1417c23cd0676ca16f3b418d16455, Boolean cd1019342f38d18a4083300b0c0b48efb)
at Devolutions.RemoteDesktopManager.Business.DataSources.RDMSConnectionDataSource.c88b8bc6e236931f324b713404e90b15d(Boolean c5d807049ab3ae30aad5318fa57dc6159, String& c18973cea236a9feff75c32ca7d1697d5, String& ceb81d1ee93f91e0bc57f34876c263863, Boolean c88d1c88a1983c4218837515ad03a99d0)
at Devolutions.RemoteDesktopManager.Business.DataSources.RDMSConnectionDataSource.Login(Boolean useCredentials)
at Devolutions.RemoteDesktopManager.Business.DataSources.RDMSWebApiClient.get_c3e2a9eaefc85e07772d691a26117253e()
at Devolutions.RemoteDesktopManager.Business.DataSources.RDMSWebApiClient.ce18a34186459a94774b0658f116cce91.c49e0e32005a95753415224597668b218()
at Devolutions.RemoteDesktopManager.Business.DataSources.RDMSWebApiClient.c5f4f6c72c053c0cd60a62abeeaa43fdf[cb75a0a5d15a1ad8b8a8a5e57cca214a3](c31561c0d54939abd223ac7c0cf30e7e6`1 c6cc9ab02b2ea9ccd42c7c0497677bcc2, ExecuteActionLogMode c92f46156e371279a4f61cd5822be5fee)
at Devolutions.RemoteDesktopManager.Business.DataSources.RDMSWebApiClient.GetData(String proxyConnectionCacheID, Byte[] version, String repositoryID)
at Devolutions.RemoteDesktopManager.Business.DataSources.RDMSConnectionDataSource.GetDataSourceSettings()
at Devolutions.RemoteDesktopManager.Managers.ConnectionManager.c29fbd34504079a3525ca4c390d5d4074(BaseConnectionDataSource c7f28727fc7a5daa94ba08f688b2a5781)
at Devolutions.RemoteDesktopManager.Managers.ConnectionManager.ca4799bebd8b706f34eea94a778843b55(BaseConnectionDataSource c7f28727fc7a5daa94ba08f688b2a5781, Boolean cfe205b02d73750f8fd14d199343fe545)
at Devolutions.RemoteDesktopManager.Managers.ConnectionManager.LoadConnections(BaseConnectionDataSource dataSource)

9 mths DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

Hi Erica

I have upgraded to DPS 6.0 and RDM 14 now and we have the slowness still after this when accessing the Vault via DVLS Web

Accessing the Vault takes about 49 seconds for normal user.
Making the same user Administrator it takes 5 seconds

9 mths DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

Hi Erica

DVLS 5.1.1.0 , 2480 entries and 7 roles

2 yrs DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

When we login to the web client in DVLS and click on Vaults it takes about 30-35 seconds to display the content tree of the vault which doesn´t sound correct.

We use ActiveDirectory domain accounts to log in and roles to set rights in the content tree

When logging in with Admin user it takes about 3 seconds

Doing the same with RDM client it takes about 7 seconds with both domain accounts and admin account

Making my domain user temporary as Administrator the time is reduced to about 3 seconds in the web client

2 yrs DVLS Web slow to show Vault content
magnus01
magnus01
Posts: 82

Yes, i now thats availabe but 13.5.13.0 is a beta release.

I wanted to download the latest NO beta release that according to release notes is 13.5.11.0 but I can only download 13.5.6.0

2 yrs Unable to download RDM 13.5.11.0
magnus01
magnus01
Posts: 82

Release notes indicates that 13.5.11.0 is the latest none beta release but when downloading it is only 13.5.6.0

2 yrs Unable to download RDM 13.5.11.0
magnus01
magnus01
Posts: 82

Hi Jeff

Yes we have backup before that time and have restored that database and recovered the information

2 yrs Problem with entry/session - changed type
magnus01
magnus01
Posts: 82

I upgraded DVLS and RDM to 5.0.0.0 and 13.5.0.0 on March 21

There are a few other sessions that where edited on March 22 but far from all

2 yrs Problem with entry/session - changed type
magnus01
magnus01
Posts: 82

Hi David

Thats the problem, we haven´t done anything to the session that should have altered the type of the session.

We use DVLS 5.0.2.0 and RDM 13.5.6.0

I can´t find right-click -> View -> Entry History but if you mean the logs there only is entry for creating the entry and two edit entry, and one of the edit entry has wrong information (pic3)

2 yrs Problem with entry/session - changed type
magnus01
magnus01
Posts: 82

Hi

We have noticed a problem in out database with a session that was created as "Data (Note/Secure Note)" 2018-01-10 then somehow been changed to "Login (Account)" sometime after that.

Since it has been changed to "Credential" we cannot se the information that was written there before.

2 yrs Problem with entry/session - changed type
magnus01
magnus01
Posts: 82

Hi Erica

It seems that DVLS 5.0.2.0 solved the problem with creating shortcut of a session

2 yrs Problem creating folder in 13.5.0.0
magnus01
magnus01
Posts: 82

Hi Erica

My Move problem went away with that SQL statement which is good. But i noticed that there is another strange problem

Any user that is NOT administrator can´t create a shortcut of a session , when trying to do that I get the same error as before with the move , "Unable to save the entry; access denied"

I can now after the move fix we did move the same session to where I want to create the shortcut, but im not able to create a shortcut in the same place.

2 yrs Problem creating folder in 13.5.0.0
magnus01
magnus01
Posts: 82

Hi again Erica

Also I can add, if I have the User type set to read only user there is no option for giving the user "move" rights trough the Roles so that leaves "Move" option greyed out in the client, and now that I change back to "Restricted User" and check "Add, Edit, Delete, Move" the Move option is lit up again but the outcome is not the same anymore as I wrote in my previous post. Now I get the error but nothing is moved.

2 yrs Problem creating folder in 13.5.0.0
magnus01
magnus01
Posts: 82

Hi Erica

Ok, now that i try again i see that i get the error "Unable to save the entry; access denied" once for every session/entry that is under the folder that i move, BUT the folder/session is acctually moved.

And as I showed you in the remote session if i move the same folder again I don´t get this error again.


So if I move a folder with 5 session under I will get 6 errors but after clicking OK on all of them the folder and session has moved correctly.

2 yrs Problem creating folder in 13.5.0.0
magnus01
magnus01
Posts: 82

Hi Grawe Grawe

With DVLS 5.0.1.0 and RDM 13.5.1.0 i dont have the object reference error anymore when i want to change in Root Setting

2 yrs Problem creating folder in 13.5.0.0
magnus01
magnus01
Posts: 82

Hi David and Erica

DVLS 5.0.1.0 solved the problem with not being able to create new folder as mentioned in the change history.

But problem is still there with moving older entrys/sessions as we discussed in the remote session with Erica, so i will be waiting for the fix for that.

2 yrs Problem creating folder in 13.5.0.0
magnus01
magnus01
Posts: 82

Hi Erica

I see that DVLS 5.0.1.0 was released 23rd March but I can´t download it anywhere.

I the change history for that version it says that the create folder problem is solved.

2 yrs Problem creating folder in 13.5.0.0
magnus01
magnus01
Posts: 82

Hi Erica

I think that we might have some problems in the database regarding rights issues. We have noticed now that there is other rights issues even with RDM 13.0.6.0

It´s hard to explain but i will try (have also recorded it if i can send it somewhere private)

When we want to move or delete an existing session from one place to another this doesn´t work. Right click choosing Move and pointing to the new location gives "Unable to save the entry; access denied" (see error.jpg)

Right click again and choose Move and choosing the place that it´s already at gives no error and now after this when you move it to a new location it workes fine. But it seems to be like this on very many sessions/folders

2 yrs Problem creating folder in 13.5.0.0
magnus01
magnus01
Posts: 82

Attached requested screenshot in pic4

Also, when I in DVLS/RDM server with client 13.5.0.0 goto File - Administration - Root Settings - Permissions and choose Custom and try to click to add groups/users I get this error (pic3)


NullReferenceException - Object reference not set to an instance of an object.


at Devolutions.RemoteDesktopManager.Forms.FrmSecurityRoleBrowser.c1e414d001238be8d4d11869d3285c465(Object c19f185fd70cefc696ba148af1c4faf54, EventArgs cf1018bb83ec7debd818319fd3cb4844e)
at System.Windows.Forms.Form.OnShown(EventArgs e)
at Devolutions.RemoteDesktopManager.Forms.FrmBase.OnShown(EventArgs e)
at System.Windows.Forms.Form.CallShownEvent()
at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbacks()

2 yrs Problem creating folder in 13.5.0.0
magnus01
magnus01
Posts: 82

Attached my settings.

I have added my self "mf" , but as you can se in pic2 i still have a red X

But as i wrote , if i use an older RDM client (13.0.6.0) it workes fine to create the folder

2 yrs Problem creating folder in 13.5.0.0