Forum

Posts by rene01 (rene01)

rene01
rene01
Posts: 10

Hallo,

nach der Rückmeldung von Johannes01 habe ich mal nachgesehen ob der Security Provider von uns den Fehler hervorruft, welcher beio uns in der Instanz auf Passphrase eingestellt ist.
Nachdem ich die Passphrase deaktiviert habe und danach wieder aktiviert hab funktioniert das erstellen von neuen Verbindungen wieder.
Hatte den Security Provider weil mir Verbindungen zumindest angezeigt wurden ihrgendwie übersehen.

2 yrs Fehlermeldung: Unable to save entry; invalid data sent! Beim pflegen der Verbindungen
rene01
rene01
Posts: 10

Hallo Etienne,
Für den Import benutze ich eine CSV Datei, welche mit einem Synchronizer\Comma-separated values(CSV) eingelesen wird. Das einzige Skript welches mit dem Server Interagiert ist:
#initialise Modul and Datasource
#---------------------------------------------------------------------------------------------------------------------------
Import-Module "C:\Program Files (x86)\Devolutions\Remote Desktop Manager\RemoteDesktopManager.PowerShellModule.psd1"
$encrypted = "01000000d08c9ddf0115d1118c7a00c04fc297eb010000003902de6d792ce346b47ef6fda56671ce0000000002000000000003660000c000000010000000e1f8930ed39bf9fa52954d5c931f3b3b0000000004800000a0000000100000004012d2dc4a06904d2cf4e4684e25270c20000000455e896668115e40350caa8014a51dbc860467c4d9058917e402b905a4f84c0f1400000075f3e598169a1d7465f335f652fb85dbf2a48bfb"
$password = ConvertTo-SecureString -String $encrypted
Set-RDMCurrentDataSource -ID c69480b6-cec5-455d-bd98-13d24392d9cf -Username Updater -Password $password
$pathcsv = "C:\DVLS\csv"

#Import new Entrys
#---------------------------------------------------------------------------------------------------------------------------
Start-Sleep -s 2
Open-RDMSession -ID 9092f28a-66e7-4c33-b826-cd8298464748 -Silent
Start-Sleep -s 10
#Clean Old Entrys
#---------------------------------------------------------------------------------------------------------------------------
[string[]] $namecurrent = ""
$t="false"
$altehosts = Get-RDMSession
Get-Content "$($pathcsv)\old.csv" | ForEach-Object {
$namecurrent= $namecurrent + $_
}
$altehosts | % {
if(($namecurrent -contains $_.name)){
if((Get-RDMSessionProperty -ID $_.id -Path MetaInformation -Property BladeDetails) -notlike "ignore"){
Remove-RDMSession -id $_.id -Force
"$($_.name)" | Out-File -FilePath "$($pathcsv)\debug-remove.log" -Append
}
}
}
#Update Description
#---------------------------------------------------------------------------------------------------------------------------
[string[]] $name = ""
[string[]] $description = ""
Get-Content "$($pathcsv)\newserver.csv" | ForEach-Object {
$fields = $_.split(',')
$name = $name + $fields[0]
$description = $description + $fields[4]
}
Get-RDMSession | % {
if($name -contains $_.Name){
if((Get-RDMSessionProperty -ID $_.ID -Property Description) -notlike $description[$name.IndexOf($_.name)]){
Set-RDMSessionProperty -ID $_.ID -Property Description -Value $description[$name.IndexOf($_.name)]
Set-RDMSessionProperty -ID $_.ID -Property Description -Value $description[$name.IndexOf($_.name)]
"$($_.name)" | Out-File -FilePath "$($pathcsv)\debug-change.log" -Append
}

}
}
exit

Gesteuert wird alles über einen Sheduled Task. Der User Updater ist ein Devolutions Passwort Server custom user.
Die Datenbank wird von mit normalerweise nicht direkt angesprochen, das hatte ich nur als Test gemacht um festzustellen ob ich dann Einträge pflegen oder der Fehler direkt mit der Datenbank zusammenhängt.

2 yrs Fehlermeldung: Unable to save entry; invalid data sent! Beim pflegen der Verbindungen
rene01
rene01
Posts: 10

Hallo Etienne,

die Instanz ist separat.

2 yrs Fehlermeldung: Unable to save entry; invalid data sent! Beim pflegen der Verbindungen
rene01
rene01
Posts: 10

Hallo Etienne,
unsere Umgebung umfasst 3 Server mit 2 Instanzen.
Eine hochverfügbare Installation mit 2 Servern in einem abgeschotteten Netzwerk. Dies ist die Instanz welche ohne Fehler läuft.
Und die Instanz welche mir Kopfschmerzen bereitet auf einem einzelnen Server.

2 yrs Fehlermeldung: Unable to save entry; invalid data sent! Beim pflegen der Verbindungen
rene01
rene01
Posts: 10

Hallo,

ich bin nicht sicher ob das Problem nach einem Update aufgetreten ist, weil die beiden Server Instanzen die wir Betreiben zu 90% selbstpflegend sind.
Neue Systeme werden per CSV automatisiert Importiert und per Powershell Skript werden außerbetrieb genommene Systeme gelöscht. Ein manueller Eingriff ist dadurch nur sehr selten nötig.
Bei einer direkten Verbindung mit dem SQL Server habe ich in der Database Diagnostics keine fehler.
Die Liste der nicht deserialized Session über den Devolutions Passwort Server beinhaltet jede Session der Instance. Wir haben in dem Fall etwas Glück da es sich bei dem Fehlerhaften Server um den deutlich kleineren Handelt.

2 yrs Fehlermeldung: Unable to save entry; invalid data sent! Beim pflegen der Verbindungen
rene01
rene01
Posts: 10

Screenshots vergessen..

2 yrs Fehlermeldung: Unable to save entry; invalid data sent! Beim pflegen der Verbindungen
rene01
rene01
Posts: 10

Guten Tag Zusammen,

Bei einem unserer Server kommt, wenn man Änderungen vornehmen will nur die im Titel stehende Fehlermeldung. Im Applikation Log des RDM ist kein Eintrag vorhanden, im Log des Servers steht ein Eintrag ‚InvalidOperationException – There is an error in XML document (1,1)‘. Wenn ich die Datenbank Diagnostizieren lasse stehen 164 Sessions als failed in der deserialization.
Wenn ich mir die im Server Konfigurierte SQL Datenbank direkt im RDM verbinde, kann ich ohne Fehlermeldungen die Einträge pflegen.
RDM Version: 13.6.6
Devolutions Passwort Server: 5.1.1
Auth: Domain,Custom User,Database User – Windows auth enabled

2 yrs Fehlermeldung: Unable to save entry; invalid data sent! Beim pflegen der Verbindungen
rene01
rene01
Posts: 10

With the setting “Auto create domain users in database”, could it be possible to add the email from ad-account to the user account from RDM too? Currently I can’t find another way except to add it manually afterwards.

4 yrs AD-Account + E-Mail
rene01
rene01
Posts: 10

We got it working on a test machine, on another pc it was the oracle client which caused the problem.
Thanks for your fast reply, seems an update didn't go right and damaged the client's command line features only

4 yrs Toad V12.5 and newer error
rene01
rene01
Posts: 10

Hello,

when we use the toad add-on we get this error message in toad V 12.5 and newer

Fehlermeldung
we think it could be something with the parameters the add-on transfers to toad because it worked in older toad versions than 12.5

4 yrs Toad V12.5 and newer error