Forum

Posts by andreas01 (andreas01)

andreas01
andreas01
Posts: 17

Hi Xavier,

Thank you for your detailed explanation! Now I understand how this should work and were able to successfully create such a connection over our proxy. For the username and password junk data is working fine.

It would have been great if that could work as a per user setting, but as we have just a few affected hosts I will create additional sessions where needed.

Thank you again and have a nice weekend.

BR Andreas

2 yrs RDP over HTTP-Proxy
andreas01
andreas01
Posts: 17

Hi Xavier,

The Proxy Tunnel doesn’t work for me, but that may be because not all parameters of the Proxy Tunnel are clear to me. The status window output is as following:
Listening on 127.0.0.1:23451
proxyTunnel_Completed: SUCCESS
proxyTunnel_Disconnected: SUCCESS
Connection Status is Not connected

I tried the following values:
- Host and Port: hostname and port of the proxy.
- Username and Password: x, because empty is not allowed
- Proxy type: HTTP
- Localhost and port: 127.0.0.1, 23451
- Remote host and port: hostname and port of the proxy

Can you give me some hint here?

Configurable per user was meant like you wrote. We have different locations and on some of them it’s necessary to use the proxy for some sessions. I found no option for this. If that’s currently not possible I think we could live with the workaround to create additional sessions for them.

Best regards
Andreas

2 yrs RDP over HTTP-Proxy
andreas01
andreas01
Posts: 17

Hello,

I’m looking for a way to connect to a host by RDP over a HTTP proxy, configurable per user. How can I do that in RDM Enterprise Edition (current installed version is 5.1.0.0) on Mac? Same question for the Windows version, but more of our users use Macs.

So the way would be user with RDM-Client -> proxy server -> target host RDP
The proxy is a standard HTTP proxy and doesn’t need username or password.

Best regards
Andreas

2 yrs RDP over HTTP-Proxy
andreas01
andreas01
Posts: 17

Hi Xavier,

great, thank you very much!

Best regards,
Andreas

4 yrs RDM@Mac: can not change password of a user
andreas01
andreas01
Posts: 17

Hello,

I have two questions regarding the user management in RDM on Mac.

The first is that I can't change a users password. My RDM account has administrator rights so I should be able to, but the field seems to be disabled.
Reproduce: Click Administration, Users, pick a SQL user (not an Active Directory user; we have a mixed user base), try to click into the password field. That doesn't work and I can't change the password.

The second thing is more a feature request: it would be nice to be able to sort the user list somehow. On Windows the user list is sorted by the user name, but on Mac it doesn't look to be sorted in any order.

Best regards,
Andreas

4 yrs RDM@Mac: can not change password of a user
andreas01
andreas01
Posts: 17

Hi Benoit,

thank you for fixing this and letting me know about the possible workaround. I think we will simply wait for the next version.

Best regards,
Andreas

4 yrs Auto-type macros on Mac?
andreas01
andreas01
Posts: 17

Hi Benoit,

yep, that's how it should work smile
I captured a video on my Mac, maybe you see something wrong on it: (edit: removed link)

Best regards,
Andreas

4 yrs Auto-type macros on Mac?
andreas01
andreas01
Posts: 17

Hi Benoit,

sorry for my late answer, I was on holiday last week.
I tried to increase the Initial wait value at a few SSH sessions but it doesn't work for me. The sessions are to local servers, so the prompt is ready within a second. I tried values up to 30 seconds, but while it works on Windows without a problem it doesn't work on Mac at all. The other settings are like in your screenshot. Is there something else I can check?

Best regards,
Andreas

4 yrs Auto-type macros on Mac?
andreas01
andreas01
Posts: 17

Hi Benoit,

oh sorry, you're right, that informations would have been helpful... It's an SSH connection and I try to automatically sign in as root, while the connection use another user for login. Unfortunately the macro isn't executed at all. While this works in the Windows version of RDM, it fails in the Mac version for all SSH connectons. RDM-Version is 3.5.4.2.
Reproduction: Edit an entry, go to events, after connect, Typing macro f.e. "su -{ENTER}{DELAY}$CUSTOM_FIELD1${ENTER}".

Best regards,
Andreas

4 yrs Auto-type macros on Mac?
andreas01
andreas01
Posts: 17

Hi everybody,

is it a known issue that typing macros after connect does not work in the Mac version? Does a work-around exist or will this be fixed in the future?

Best regards,
Andreas

4 yrs Auto-type macros on Mac?
andreas01
andreas01
Posts: 17

Hi,

is it possible to copy all user specific settings to another user?

Background story: we need to migrate a lot of domain (integrated security) users to standard users. The only way I see is to recreate all of them. As they are new users then, they will miss all their saved user specific settings in the sessions.
Is there a way to simply export them from User A and import them to User Anew or do they need to type in them manually one after one?

Best regards,
Andreas

4 yrs Copy user specific settings to another user
andreas01
andreas01
Posts: 17

Hi Maurice, okay, thank you for your fast reply.

4 yrs Cannot Connect to MS SQL Database from non-domain computer
andreas01
andreas01
Posts: 17

Hi, this seems to be only possible in the other OS versions, like on Mac or Android. There you can activate Integrated security and enter the username, domain and password. This works fine, even if these operating systems doesn't know anything about the domain.
Is there really no way to make this possible in the windows version too, except for the runas-"solution"?

4 yrs Cannot Connect to MS SQL Database from non-domain computer
andreas01
andreas01
Posts: 17

Hi Erica,

yes, if I add the proxy as system proxy and set use system proxy settings it would work. But this proxy is session dependent, I can not use it as proxy for the whole system.

Best regards,
Andreas

4 yrs Error with embedded firefox and proxy
andreas01
andreas01
Posts: 17

Hi,

if I configure an embedded web browser session, set Firefox as the browser and set a proxy, then no content tab becomes visable. RDM tries to start the session, it shortly changes the button "Open Session" to "Close Session", but nothing more happens.
The configured URL is a http-url (no ssl). The proxy and the URL are working in a normal browser window. It makes no difference if I choose MozNET R19.8 or geckofx. RDM version is 11.1.0.0 on Windows 7 64 Bit. This error happens with the 32- and 64-bit version of RDM. Firefox version is 45.0.1. Antivirus is disabled. Team Viewer is not installed on the system.

Output of the debug log:
Starting process
PID: 9732
MainWindowHandle: 0
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Wait 100ms
Silent: System.InvalidOperationException: Process has exited, so the requested information is not available.
at System.Diagnostics.Process.EnsureState(State state)
at System.Diagnostics.Process.get_MainWindowHandle()
at Devolutions.RemoteDesktopManager.Frames.Embedded.FreEmbedded32Cmd.ProcessVisibleChanged()
Process has exited.

Is this a known problem and what can I do to resolve that? Do you need more information?

Best regards,
Andreas

4 yrs Error with embedded firefox and proxy
andreas01
andreas01
Posts: 17

Yep, scaling was "middle - 125% (Standard)". I changed it to 100% and it works now.
Thank you very much for the fast answer!

4 yrs Missing checkboxes for user rights
andreas01
andreas01
Posts: 17

Hi,

I miss some checkboxes for setting user rights in RDM Enterprise 10.6.7.0 - 11.1.0.0. My user is marked as administrator. It works on another machine, but not on my main workstation. System: Windows 7 Professional (both). Shared database (MSSQL).

It affects this dialoges:
Administration - Security Groups - Assign rights
Administration - Users - Edit User - Roles - Roles

In both dialoges I can not see the checkboxes for the rights (view, add, ...) or the checkbox for Is Member (see attached files).

In other dialoges I can see the permission checkboxes, f.e. in Administration - Users - Edit User - Permissions.

What I already tried:
- Reinstall Remote Desktop Manager
- Reinstalled RDM + all dependencies (Visual C++ Redistributable 2010+2013)
- Copy the %LOCALAPPDATA%/Devolutions/RemoteDesktopManager folder from the working workstation to mine

Unfortunately nothing helped. Do you have any ideas how I can solve this or do you need more informations?

Thanks, Andreas

4 yrs Missing checkboxes for user rights