Forum

Posts by advjohn (advjohn)

advjohn
advjohn
Posts: 11

I am having this exact same issue. However being a vendor myself using this to connect I cant get my hands on the latest version. Is there anyone who might have this can post it somehow so we can all get our hands on this cisco anyconnect client?

2 yrs Cisco Anyconnect VPN not typing full password
advjohn
advjohn
Posts: 11

Hi there, I just thought I'd throw my hat in on this too as we have a client that can only give us access via the Bomgar Access Console - apparently it has more features than the Rep Console does. Please let me know if there is any movement on the request to allow for either console from Bomgar or just a new plugin which hits the right executable.

Thanks!

John

3 yrs Bomgar Access Console
advjohn
advjohn
Posts: 11

Hi there, I'd like to throw my hat in on this and say we also have more clients moving to this vpn so it would be great if there was an integration. Anything I can do I am happy to help.

John

4 yrs Palo Alto Networks firewalls VPN add-on
advjohn
advjohn
Posts: 11

Hi Jean,

We tried both these on a workstation with this issue and neither fixed the issue.

4 yrs AnyConnect AddOn with credentials
advjohn
advjohn
Posts: 11

Thanks Jean Francois much appreciated. If I can be of assistance I am happy to help. Perhaps I could create a virtual machine from one of my workstations where this isnt working? ANyways let me know if I can help or if you want to do a webex with one of our people to troubleshoot.

John

4 yrs AnyConnect AddOn with credentials
advjohn
advjohn
Posts: 11

Hi!

I would like to resurrect this thread if you dont mind. We continue to have issues with the anyconnect client. Our issue is that we have some workstations that can run all these flawlessly and some who end up with the credential information being inputted incorrectly or slowly or intermittently - just erratic behavior. However when we invoke the vpncli for anyconnect via a powershell script it works fine for everyone no matter what. The problem with that is that then we have to write these scripts and embed credential info into it etc etc. I believe that if I can figure out why this only happens on certain people's workstations that this will work great for me. Why would invoking the vpncli from powershell correct these issues but when it is invoked by RDM it struggles and fails only for a percentage of workstations?

We have tried a number of things - we have the latest anyconnect client installed 4.2, we have tried 64bit mode vs 32 bit mode. I have machines with Windows 10 and Windows 7 that work fine. Other Windows 7 machines have issues. We also had a support session with Devolutions but we had no success to make this work. Clearly this thread is pretty old so perhaps some of you after battling with this might have an idea or what the issue is here? We have about 40 more clients who are moving to anyconnect from the old client. I just want the addon to work without having to configure embedded scripts to correct this environment issue.

Any help would be appreciated. Below si the powershell script that works for those who are having this issue:


#Source www.cze.cz
#This script is tested with "Cisco AnyConnect Secure Mobility Client version 3.0.5080"
#Please change following variables
##FROM WEB SITE
## http://www.velocityreviews.com/threads/automatic-login-using-cisco-vpn-client.947891/
##
#IP address or host name of cisco vpn
[string]$CiscoVPNHost = [removed]
[string]$GROUP = "1"
[string]$Login = [removed]
[string]$Password = [removed]
[string]$Confirmation="y"

#Please check if file exists on following paths
[string]$vpncliAbsolutePath = 'C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpncli.exe'
[string]$vpnuiAbsolutePath = 'C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnui.exe'

#****************************************************************************
#**** Please do not modify code below unless you know what you are doing ****
#****************************************************************************

Add-Type -AssemblyName System.Windows.Forms -ErrorAction Stop

#Set foreground window function
#This function is called in VPNConnect
Add-Type @'
using System;
using System.Runtime.InteropServices;
public class Win {
[DllImport("user32.dll")]
[return: MarshalAs(UnmanagedType.Bool)]
public static extern bool SetForegroundWindow(IntPtr hWnd);
}
'@ -ErrorAction Stop

#quickly start VPN
#This function is called later in the code
Function VPNConnect()
{
Start-Process -FilePath $vpncliAbsolutePath -ArgumentList "connect $CiscoVPNHost"
$counter = 0; $h = 0;
while($counter++ -lt 1000 -and $h -eq 0)
{
sleep -m 10
$h = (Get-Process vpncli).MainWindowHandle
}
#if it takes more than 10 seconds then display message
if($h -eq 0){echo "Could not start VPNUI it takes too long."}
else{[void] [Win]::SetForegroundWindow($h)}
}

#Terminate all vpnui processes.
Get-Process | ForEach-Object {if($_.ProcessName.ToLower() -eq "vpnui")
{$Id = $_.Id; Stop-Process $Id; echo "Process vpnui with id: $Id was stopped"}}
#Terminate all vpncli processes.
Get-Process | ForEach-Object {if($_.ProcessName.ToLower() -eq "vpncli")
{$Id = $_.Id; Stop-Process $Id; echo "Process vpncli with id: $Id was stopped"}}


#Disconnect from VPN
#echo "Trying to terminate remaining vpn connections"
#start-Process -FilePath $vpncliAbsolutePath -ArgumentList 'disconnect' -wait
#Connect to VPN
echo "Connecting to VPN address '$CiscoVPNHost' as user '$Login'."
VPNConnect
sleep -m 3000
#Write login and password
##[System.Windows.Forms.SendKeys]::SendWait("$Confirmation{ENTER}")
#[System.Windows.Forms.SendKeys]::SendWait("$GROUP{ENTER}")
##sleep -m 3000
[System.Windows.Forms.SendKeys]::SendWait("$Login{ENTER}")
sleep -m 3000
[System.Windows.Forms.SendKeys]::SendWait("$Password{ENTER}")
##sleep -m 7000
##[System.Windows.Forms.SendKeys]::SendWait("{TAB} ")
sleep -m 10000

#Start vpnui
start-Process -FilePath $vpnuiAbsolutePath
#Wait for keydown

4 yrs AnyConnect AddOn with credentials
advjohn
advjohn
Posts: 11

We use AD integration. Our AD usernames are not our actual names but a number. When we look at Global Sessions, we see a user name like DOMAIN\876789 instead of the person's actual name. Under Administration in Devolutions Server we do enter the person's First and Last Name with teh account. Can we possibly have the option to show the person's name instead of the actual user logged in?

Thanks!

John

4 yrs Show "Name" instead of "User" in Global Sessions
advjohn
advjohn
Posts: 11

I just thought I would check to see if anyone has had intermittent problems with the cisco anyconnect plugin? I have some workstations that work fine and others that will insert messed up info or insert it very slowly. The versions of the client and the vpn client are the same across both. Does anyone have any idea what could be wrong with the specific workstation and what I could check with regards to this? Anyone seen anythign like this before?

Thanks!


John

4 yrs Cisco Anyconnect plugin not submitting credentials properly
advjohn
advjohn
Posts: 11

Much like the "Mail" function that brings up the Mailto: feature in an email client, it would be great if we could say "Call" and this bring up skype or skype for business and allow us to call?

4 yrs Make Skype for Business calls from the Contact menu
advjohn
advjohn
Posts: 11

Hi! I was really impressed with the Welcome page in 11.6. I think it would be great to have something similar that we can make announcements of sorts through? Maybe something that instructs people how to add a new feature or gives us an opportunity to point out what connections have been added etc etc? I know there is the System Message feature - but it is just text based. Something were we could add images or html would be really great.

John

4 yrs Configurable Welcome Page
advjohn
advjohn
Posts: 11

Has gotomypc ever been on the table? Does anyone have any tips for setting up a connection other than the usual web connection?

5 yrs Gotomypc?