Forum

Posts by zomby (zomby)

zomby
zomby
Posts: 60

Daniel Wahlgren wrote:

October has come and I don't see this in the latest releasenotes. Any news?


Fingers crossed

2 yrs Azure SQL Database using Azure AD identities
zomby
zomby
Posts: 60

I have to agree, still waiting for the solution, checking on every update.

2 yrs Azure SQL Database using Azure AD identities
zomby
zomby
Posts: 60

Hi Jonathan,

Seems to work, thank you.

Now only the Jump support is missing.

Zomby

3 yrs FreeRDP: unable to connect to Hyper-V enhanced sesstion
zomby
zomby
Posts: 60

Hi Jonathan,

This seems to solve the issue, but it's not a generic solution.

I have 2 issues:

1. I am store the username and password in Keepass. The username is entered in UPN format, and the NETBIOS domain was filled in. If I just changed the Username format to "{User}@{Domain}", it tried to login with firstname.lastname@NETBIOSDOMAIN.
I had to remove the "DOMAIN" setting from keepass to make it work.

2. This account is used in other places, it would be better if it can work with the default setting, if the username is in UPN format {USERNAME}@{DOMAIN}.{TLD) auto switch to UPN. (maybe doesn't work for others...)
It can be detected by after @ , there is a FQDN not just a NetBIOS domain name without dot.

3 yrs FreeRDP: UPN login
zomby
zomby
Posts: 60

Please note that the NETBIOS login is different in my case.

Example
NETBIOS DOMAIN NAME: DOMAIN
SamAccountName: username
UserPrincipalName: firstname.lastname@differentdomain.tld


I am trying to use firstname.lastname@differentdomain.tld to log in, when it's not working.
DOMAIN\username works.

As far as I see if I enter firstname.lastname@differentdomain.tld (UPN) to log in, FreeRDP tries to use:
DIFFERENTDOMAIN.TLD\firstname.lastname which doesn't work.

3 yrs FreeRDP: UPN login
zomby
zomby
Posts: 60

Jonathan Lafontaine wrote:

HI zomby,

What OS are you launching your connections from?
We have found some issues with RDP8 (which FreeRDP uses) and Server 2012 R2 (and possibly Windows 8.1).


I am tried it from Windows 10 x64 Enterprise 1703

3 yrs FreeRDP: UPN login
zomby
zomby
Posts: 60

Yes, I think it's Kerberos using CredSSP. No client certificate is used.

Didn't checked, but I think, the authentication method is the same. The only difference is that instead using NETBIOSDOMAIN\samAccountName, I am using UserPrincipalName ( user@domain.tld ) to log in.

NetBIOS domain and UPN domain can be diffrerent. As far as I see the client just converts user@domain.tld to DOMAIN.TLD\user which is not the same. That is still NetBIOS login, which may or may not work.

3 yrs FreeRDP: UPN login
zomby
zomby
Posts: 60

Oh sorry. I forgot to answer.

No, it's not related to Hyper-V, I didn't tried it.

I am logging in to a normal RDP server using NLA, but the username is the UPN. (username@domain.net format ) It is the UserPrincipalName property in AD.
The UPN is different from the samAccountName.

3 yrs FreeRDP: UPN login
zomby
zomby
Posts: 60

This was the first two sessions I had tried freeRDP (UPN issue is the other). Neither worked :S. I use the Hyper-V session as a jump host.

The reason: Customer doesn't allow local connections in VPN and we need enhanced session to make jump work.

3 yrs FreeRDP: unable to connect to Hyper-V enhanced sesstion
zomby
zomby
Posts: 60

Unable connect to Hyper-V enhanced session. The error message is:
Unable to connect to host <hostname>

Where <hostname> is the host name I am try to connect to.

3 yrs FreeRDP: unable to connect to Hyper-V enhanced sesstion
zomby
zomby
Posts: 60

After switching to FreeRDP, the rdp session can't logon with UserPrincipalname

As far as I see it converts user@domain.com to DOMAIN.COM\user but that's not a real UPN login. The user part can be different, just for example.

3 yrs FreeRDP: UPN login
zomby
zomby
Posts: 60

Just tested it, as far as I see it doesn't seems to support Modern Authentication (ADAL) yet. We have Azure AD MFA setup...

The error message:
Unable to connect to the database!
Failed to authenticate the user NT Authority\Anonymous Logon in Active Directory (Authentication=ActiveDirectoryIntegrated).
Error code 0xCAA2000C; state 10
AADSTS50076: Due to a configuration change made by your administrator, or because you moved to a new location, you must use multi-factor authentication to access 'https://xyz.abc.com/'.
Trace ID: 615cbd65-3659-4faa-ac69-1a34431c1cfa
Correlation ID: a03aac05-567d-493a-935e-ebc1a5b9843a
Timestamp: 2017-02-15 21:47:42Z

3 yrs Azure SQL Database using Azure AD identities
zomby
zomby
Posts: 60

Hi Stefane,

Thanks for making it! I am more than happy to test it.
Zoltan

3 yrs Azure SQL Database using Azure AD identities
zomby
zomby
Posts: 60

Hi David,

Any news on this? For us it would be an important feature to use AzureAD accounts on AzureSQL

3 yrs Azure SQL Database using Azure AD identities
zomby
zomby
Posts: 60

+1 on this, Active Directory integrated authentication would be a great security improvement with Azure SQL

4 yrs Azure SQL Database using Azure AD identities
zomby
zomby
Posts: 60

Any news?

4 yrs Azure SQL
zomby
zomby
Posts: 60

Yes, the error message is:
"Unable to connect to the server!
Server closed the connection."

The connection works well with the same data (Server, username, password, database) using the desktop version of RDM.
I had sent the logs using Settings/logs/Sent Trace to Support.

4 yrs Azure SQL
zomby
zomby
Posts: 60

I get a following error message trying to connect our Azure SQL database:


Unable to connect to the database!
Server closed the connection.

4 yrs Azure SQL
zomby
zomby
Posts: 60

Do a jump session counts as a RDP session on the Jump host? I assume yes, so the 2 concurrent RDP limit applies, if you don't have the RDP session host installed.

6 yrs Remote Desktop Manager Jump Beta
zomby
zomby
Posts: 60

I found a bug with SSH shell, since about 8.9.5.x (I am not sure), the SSH Shell freezes the whole program if the application doesn't have focus for a time.

It simply the whole RDM is not responding at all and I have to kill it. It happens very often, but only if an SSH shell is used or active.

I didn't found the exact way to reproduce it now, sometimes a simple switch to an another program and switch back causes the issue. Last time I left open the SSH Shell running and locked the desktop and the RDM was frozen.

7 yrs VMware Synchronizer - VM Tags
zomby
zomby
Posts: 60

LoadConnections [AzureSQL]...
Offline Mode : ReadOnly
Caching Type : IntelligentCaching
Current cache version: 0x0000000000000000
OfflineManager.GetDataSourceSettings : 872 ms
OfflineManager.LoadConnections...
LoadConnectionsFromOfflineFile : 448 ms
Preloaded: 285
Offline cache version: 0x0000000000000133
OfflineManager.LoadConnections : 542 ms
LoadConnectionsFromDataSource...
LoadDataSourceSettingsFromDataSource...
GetDataSourceSettings : 414 ms
LoadDataSourceSettingsFromDataSource : 1787 ms
OfflineManager.Save : 341 ms
---------------------------
OfflineManager.OfflineMode : ReadOnly

ConnectionManager.DataSource.OfflineMode : ReadOnly
ConnectionManager.DataSourceSettings.OfflineMode : ReadOnly
SecurityManager.CustomSecurity.OfflineMode : ReadOnly
ConnectionManager.DataSource.SupportOfflineMode : True
---------------------------
GetConnections...
Database.GetConnections...
Reading connections from database : 0 ms
Decrypt (multi-threaded) : 0 ms
Deserialize (multi-threaded) : 1 ms
Process entries (overhead) : 8 ms
Connection cache version: 0x0000000000000133
Fetched 0 sessions
Fetched 0 removed sessions
Database.GetConnections : 91 ms
GetConnections : 115 ms
PrepareConnectionList : 0 ms
DoMergeConnections : 10 ms
LoadConnectionsFromDataSource : 2515 ms
LoadConnections [AzureSQL] : 4282 ms
TreeView.LoadConnectionList...
GetGroupInfos : 0 ms
BeginUpdate...
ApplyGroupCustomImages : 0 ms
LoadConnectionInTreeNode : 109 ms
PreCreateGroups : 33 ms
BeginUpdate : 54 ms
TreeView.LoadConnectionList : 215 ms
LoadTrayiconContextMenu : 7 ms

7 yrs long delay loading sessions 8.9.14.0
zomby
zomby
Posts: 60

My RDM is also starts slower than before:

LoadConnections [AzureSQL]...
Offline Mode : ReadOnly
Caching Type : IntelligentCaching
Current cache version: 0x0000000000000000
OfflineManager.GetDataSourceSettings : 617 ms
OfflineManager.LoadConnections...
LoadConnectionsFromOfflineFile : 527 ms
Preloaded: 285
Offline cache version: 0x0000000000000133
OfflineManager.LoadConnections : 619 ms
LoadConnectionsFromDataSource...
LoadDataSourceSettingsFromDataSource...
GetDataSourceSettings : 1616 ms
LoadDataSourceSettingsFromDataSource : 2738 ms
OfflineManager.Save : 322 ms
---------------------------
OfflineManager.OfflineMode : ReadOnly

ConnectionManager.DataSource.OfflineMode : ReadOnly
ConnectionManager.DataSourceSettings.OfflineMode : ReadOnly
SecurityManager.CustomSecurity.OfflineMode : ReadOnly
ConnectionManager.DataSource.SupportOfflineMode : True
---------------------------
GetConnections...
Database.GetConnections...
Reading connections from database : 0 ms
Decrypt (multi-threaded) : 0 ms
Deserialize (multi-threaded) : 0 ms
Process entries (overhead) : 5 ms
Connection cache version: 0x0000000000000133
Fetched 0 sessions
Fetched 0 removed sessions
Database.GetConnections : 196 ms
GetConnections : 210 ms
PrepareConnectionList : 0 ms
DoMergeConnections : 7 ms
LoadConnectionsFromDataSource : 3980 ms
LoadConnections [AzureSQL] : 5426 ms
TreeView.LoadConnectionList...
GetGroupInfos : 0 ms
BeginUpdate...
ApplyGroupCustomImages : 0 ms
LoadConnectionInTreeNode : 94 ms
PreCreateGroups : 31 ms
BeginUpdate : 40 ms
TreeView.LoadConnectionList : 178 ms
LoadTrayiconContextMenu : 8 ms

7 yrs long delay loading sessions 8.9.14.0
zomby
zomby
Posts: 60

Hi,

I do have a request for the SSH Shell part. Usually I use the shell to manage routers and sometimes I need to copy text to the clipboard using the mouse. If the text is longer than a page, scrolling is required. Currently the scrolling speed is very slow, it takes a lot of time to scroll.

Is it possible to make the scrolling like Putty? I has 2 scrolling speed determined by how much you move the mouse up.

7 yrs VMware Synchronizer - VM Tags
zomby
zomby
Posts: 60

What I would recommend is to use latest beta and uncheck the "remember and automatically open last used database on startup" option in Keepass.

My second recommendation is to enable "Enter master key on secure desktop" in Options/Security in Keepass. This way you can be sure that keepass will get the focus during the password entering.
edited by zomby on 4/18/2013

7 yrs KeePass plugin issue
zomby
zomby
Posts: 60

André has fixed the issue with keepass in V8.2.4.0(beta)

With "remember and automatically open last used database on startup" DISABLED, it works perfectly now.

Thank you André for the very fast response!

7 yrs KeePass plugin issue
zomby
zomby
Posts: 60

I am using keepass 2.22 .

There is a countdown and progress bar with a cancel button, but it's not possible to cancel. The progress bar fills up until 100% and stops there. It reacts to the mouse press, but nothing happens.

7 yrs KeePass plugin issue
zomby
zomby
Posts: 60

I am spending more and more time to debug RDM issues, like a beta tester upset

7 yrs KeePass plugin issue
zomby
zomby
Posts: 60

yes, I am using several different keepass databases which are specified manually.

If you set keepass not to open the last used database, RDM will not open it. This is bug#1 ( this was worked well before ), then RDM will wait forever and it's not possible to cancel, I have to kill RDM. This is bug #2.

If keepass set to open the last database, RDM try to open the keepass db again and you have to enter the password several times and the same keepass db will open multiple times.


Keepass worked well before, but there was a change in RDM and now if you don't open the db in advance in keepass, it simply doesn't work.

7 yrs KeePass plugin issue
zomby
zomby
Posts: 60

I had upgraded to RDM 8.2.2.0, latest keepass, reinstalled the plugin and still the same.

Plese be more specific, what do I need to update.

7 yrs KeePass plugin issue
zomby
zomby
Posts: 60

Since the last keepass plugin version, RDM doesn't open the keepass file. If keepass is running, it works fine, but if it's not running, not. I am using several keepass databases. I tried to set keepass not to open the last used file and doesn't open any database if RDM starts the keepass application.
Even it waits forever, I have to kill RDM manually using the task manager.

7 yrs KeePass plugin issue