Forum

Posts by WesleyT (WesleyT)

WesleyT
WesleyT
Posts: 7

For my local test users I have checked the box in "Is Member" under the Role that I want them to be a member of.
I have also tried checking the "View" box under Groups on the users pages, as well as in the Security Group itself. However none of these things appear to be adding the user to the group.

Any other suggestions?

6 yrs Multiple domains in RDMS
WesleyT
WesleyT
Posts: 7

For the domain users it shows the Roles and Groups but doesn't show anything when it's one of the Users I've created.

In the information above this it shows "Login type" as Domain for all users.

In the event logs on the RDMS console, everytime I log in with one of these users it shows the below - the users do however logon with no problems and there are no bad password prompts on the client.

DirectoryServicesCOMException - Logon failure: unknown user name or bad password.


at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.get_AdsObject()
at System.DirectoryServices.DirectorySearcher.FindAll(Boolean findMoreThanOne)
at System.DirectoryServices.DirectorySearcher.FindOne()
at Devolutions.RemoteDesktopManager.Server.DomainManager.GetUserGroups(String domainMachine, String domain, String userName, String password, Boolean recursive) in c:\Dev\devolutions\Websites\RemoteDesktopManagerOnline\Common\Managers\DomainManager.cs:line 211

6 yrs Multiple domains in RDMS
WesleyT
WesleyT
Posts: 7

Thanks very much for the response.

In order to get around this I've decided to set the users from Domain B up as RDMS users. I have checked both "Authenticate with RMDS user" and "Authenticate with domain user" checkboxes.
While I can logon with the user account I've created, it does not seem to be getting access to the Security group that I have added View rights to. Likewise if I add it as a member of a role it doesn't recognize it's membership.

When I view "My data source information" it does not show anything under Groups or Roles. In the tree view of the sessions, I can't see any of the restricted items.

Is there a problem with using 2 authentication methods?

6 yrs Multiple domains in RDMS
WesleyT
WesleyT
Posts: 7

I have an RDMS setup with 2 Security groups - 1 from Domain A and 1 from Domain B. Domain A and B both have full trusts between them.

If a user logs on from Domain A in the Security group that I've added it is auto created and assigned to the correct RDMS Security Group. If a user from Domain B tries to logon it receives an error message about being unauthorised and the user account is not created.

Are trust domains allowed in RDMS and is there a way for users in Domain B to logon with auto created accounts?

Thanks,
Wesley

6 yrs Multiple domains in RDMS
WesleyT
WesleyT
Posts: 7

I've checked the Builtin\Users group in SQL and it has Public, db_datareader, and db_datawriter roles on the DB.

PMd with Screenshots

6 yrs Security Group Membership from Roles
WesleyT
WesleyT
Posts: 7

Sorry not talking about permissions in the Database. The permissions within Remote Desktop Manager itself do not appear to be created.

For example I have created "Security Group 1" and "Role 1". "Role 1" grants View permissions on "Security Group 1". A member who is part of the AD group that is mapped to "Role 1" can login to the database but can then see everything in the tree (not just the Folders that I have locked down to "Security Group 1". Looking at the users permissions in RDM no permissions are applied.
Going to "My Data Source Information" shows the user as belonging to no Roles OR Groups.

6 yrs Security Group Membership from Roles
WesleyT
WesleyT
Posts: 7

I'm currently using RDM v9.2.10.0 (Global license) with a SQL Data source and having some issues with Roles.

On my SQL server I have added BuiltIn\Users to the Database with Read and write privileges and this has meant that Domain users can successfully connect to the SQL Datasource and their account is automatically created in RDM.
I have created Roles in RDM using AD Groups and have user accounts that are members of one group or the other. I have also created Security Groups that I have then applied permissions for using the Roles.

My problem is that when a user is a member of a AD Group with a matching Role and logs on for the first time, their user account is created but no permissions or Role membership is applied. Do I need RDMS for this to actually work or have I misconfigured the system somewhere?

6 yrs Security Group Membership from Roles