Forum

Posts by zim2323 (zim2323)

zim2323
zim2323
Posts: 136

@Alexandre

I am now seeing intermittent lockups with only a single embedded RDP session open. I have tested on 2019.1.11 and 2019.1.12. I've tried with manual tab activation both on and off. Definitely worse with it CHECKED.

Chris

8 mths RDM 2019.1 bugs
zim2323
zim2323
Posts: 136

@Alexandre

Ah, sorry I misunderstood. I'll uncheck and see if that helps in this newer version.

8 mths RDM 2019.1 bugs
zim2323
zim2323
Posts: 136

@Alexandre

No, options stayed activated through upgrade. You had me enable that option, which seemed to help until the latest update. I have had 2 more lockups since my last msg.

8 mths RDM 2019.1 bugs
zim2323
zim2323
Posts: 136

@Alexandre Roy

I have had another hard lockup of RDM this morning. I upgraded to 2019.1.11.0 prior to this issue. I have been working fine with multiple embedded RDP sessions open until this mornings update. I verified that Manual Tab Creation is still checked in Advanced settings.

Chris

8 mths RDM 2019.1 bugs
zim2323
zim2323
Posts: 136

This change seems to have worked. I'll continue to test and if there are any additional issues I will report back.

8 mths RDM 2019.1 bugs
zim2323
zim2323
Posts: 136

Upgraded from 14.1.3.

Theme is same I've used for the last 3-4 years. Default - Light

8 mths RDM 2019.1 bugs
zim2323
zim2323
Posts: 136

Always embedded.

8 mths RDM 2019.1 bugs
zim2323
zim2323
Posts: 136

Yes!

I have the following in 6 separate events from today. Listed as type "Error Silent".


System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
at System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)
at System.Reflection.Assembly.GetTypes()
at Devolutions.RemoteDesktopManager.Managers.AddOnManager.Load()

I've also noted that I only seem to get these locks when opening more than 1 RDP session. I've had a single session open for several hours without issue so far.

Thanks!
Chris

8 mths RDM 2019.1 bugs
zim2323
zim2323
Posts: 136

I'm having an issue in 2019.1.9.0 where the entire interface locks. I can still work within the RDP session with the current focus, but nothing else works. I have to open Task Manager and force Remote Desktop Manager closed and open it new. I've had this happen 3 times in the last 30 minutes.

8 mths RDM 2019.1 bugs
zim2323
zim2323
Posts: 136

@Stefane

Attached screenshot of 'Vew Certificate'.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

I keep getting the following every time I open RDM and Tools Manager to update plugins. <attached>

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

So far 99% better then it was before with ONLY the 2 additional settings added to the CFG file. I had 1 focus issues yesterday and 1 very small screen repaint issue this morning. So far though, overall, the issues I was having is nearly non-existent.

Is there anything else you need me to test or change to try and narrow this down more?

Chris Miller

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

I had 1 focus issue where an app behind RDM popped over when continuing activity inside an active RDP session, but other than that, no more issues with screen repaint. I'll continue to monitor and give status.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

So far, making those 2 changes in the CFG file, I am no longer seeing focus and refresh artifact issues. I'll continue to beat it up and if I see anything I'll try the other RDP type. So far, it's looking promising.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

Thanks for all your help! I'll continue to work through the suggestions today. I've added the above settings to the config. I'll test regular RDP for a bit before changing to FreeRDP.

zim2323

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

The only thing I really do is RDP related, so I couldn't tell you whether or not anything else is affected.

As for the 2 settings, I can't find them in the file already so I'm assuming I need to add them. Where do I add them?

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

@David, If you're asking me, then yes. I typically don't change anything but tool locations and the individual session configs.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

@Alexandre

Any update on the screen redraw issue? I've played with a gazillion settings and nothing resolves the issue.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

@Alexandre

I changed this setting and this has not resolved the issue either.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

@Alexandre

To this point I've tried all combinations of smart connect, no compression, no bitmap, full color(32bit), etc and none of them have improved the issue. When I get some time today/Monday, I'll reinstall RDM on my Surface Pro 3 laptop again and make sure that the issue still isn't there.

zim2323

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

@Alexandere

Thanks for your time yesterday for our troubleshooting session. Per your email and the subsequent post here, I have disabled compression. I set all other settings (smart reconnect,etc) back to where they were to test from "baseline". I have a heavy amount of work in RDP sessions scheduled today, so I should be able to give some good feedback.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

@Alexandre

As I stated before, unfortunately I am not allowed to video my desktop, however I can get you on for a remote session (go figure).

It's been this way for several RDM versions from Windows 64bit version 7 through all builds of Windows 10. Currently we're still on build 1703. 1803 is slated to roll out later next month.

Email sent.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

Ok, so I've had enough time already this morning with 13.9.4.0 to tell you that the focus/screen redraw issues are actually "worse". That is, mouse clicks are far less responsive, and instead of being able to click to any other TAB and then back to fix the issue, now I have to flip back and forth several times before the screen updates properly.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

Yesterday afternoon I used RDM quite a bit and didn't notice any specific focus issues. I'll report back if they are still present.

Thanks!

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

I closed and reopened 13.9.3 and the problem "went away". It was the first time I had experienced this in a LONG time. I think early v10 or v11 was the last time I saw it. I'm installing 13.9.4 now.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

So, 2 things,

1) As of 13.9.3.0 I now have the double-click issue. I'll restart the app and also try installing 13.9.4.0 later today to see if either resolves the issue.

2) I opened a help desk quite a while ago about issues with screen paint/redraw issues. I tried several suggestions for "similar" issues that you received calls on, but I want to bring this up here to see if it can get a little more attention to fix. When I have 1 or more sessions (RDP) open within RDM, I will randomly have issues where the underlying windows on my desktop will take focus. Sometimes those windows come forward in whole and I'm now "in that window", and other times I have a half "painted" RDP session where the RDP session windows are either not there or partially drawn. Help Desk requested a video but this is a business PC and I cannot take videos, though I could do a remote session. I have confirmed that other vendors when I'm sharing my screen with them also see this, as well as when mirroring my screen to a monitor. I do not have this issue when using RDM on my home PC. Any help, thoughts, etc. would be greatly appreciated. I have grown increasingly frustrated with this issue.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

13.9.2.0

I confirm Rene Zimmermann issue with focus switching with Quick Connect session.

Also, I'm getting a certificate error when opening RDM.

2 yrs RDM 14 Beta
zim2323
zim2323
Posts: 136

Thank you Andre!

That fixed the plugin and it now shows installed!

Appreciate the quick response!

Chris

6 yrs SCCM 2012 add on not found
zim2323
zim2323
Posts: 136

Even though it installed on another machine with a brand new (never had RDM before) install?

6 yrs SCCM 2012 add on not found
zim2323
zim2323
Posts: 136

The only thing different between this machine and the old is I have an XML loaded on my machine with all my connections. Is there something that could be blocking that?

I know when I re-installed and imported, it required me to install the VMwareView addon because I have a session using that. Any chance that something could be preventing that from being used?

6 yrs SCCM 2012 add on not found