DVLS: Hourly Backup Error on DVLS Cluster

DVLS: Hourly Backup Error on DVLS Cluster

avatar

DVLS Server: 2022.3.16.0

Hi All

We're using a DVLS Cluster behind a Load Balancer.
Both Servers are Running at the same time which is working great.

But yesterday i noticed that i have a hourly Error Message in my Mail Account:

SqlException - Cannot open backup device
'\\server.domain.local\Backup$\DevolutionsServerConsole_07112022_060000.bak'.
Operating system error 32(The process cannot access the file because it is
being used by another process.). BACKUP DATABASE is terminating abnormally. at
Microsoft.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean
breakConnection, Action`1 wrapCloseInAction) at
Microsoft.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject
stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) at
Microsoft.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand
cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler,
TdsParserStateObject stateObj, Boolean& dataReady) at
Microsoft.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName,
Boolean isAsync, Int32 timeout, Boolean asyncWrite) at
Microsoft.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1
completion, Boolean sendToPipe, Int32 timeout, Boolean& usedCache, Boolean
asyncWrite, Boolean inRetry, String methodName) at Microsoft.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at
Devolutions.Server.DatabaseBackupManager.ExecuteDatabaseBackup(BackupJobEntity
job) --- Cannot open backup device
'\\server.domain.local\Backup$\DevolutionsServerConsole_07112022_060000.bak'.
Operating system error 32(The process cannot access the file because it is
being used by another process.). BACKUP DATABASE is terminating abnormally. 


Is it possible, that there is the Problem, that because of both Servers are active (with running Services), that both Servers try to do the Backup at the same time?
The Backup seems to be created successfully. Are Files are available.
Should i disable the Service on the Fallback Server?

Best Regards,
Andreas

All Comments (2)

avatar

Hello Andreas,

Thank you for contacting us regarding this matter.

That is exactly the issue, the scheduler service needs to be running on only one server, or it will attempt to run the backup query at the same time on the SQL, which will fail. It will cause other issues as well with the other tasks it runs on the SQL.

You can simply disable the scheduler on the secondary server, this way if the primary server goes down, you will be able to start it quickly.

Best regards,

Richard Boisvert

avatar

Hi Richard

Thats what ive supposed 😊

Thanks a lot!

Best Regards,
Andreas