Forum / Remote Desktop Manager Mac - Support

Wrong keyboard layout

  • Create an Issue
  • Cancel

Hi All,

I tried the beta on mac. I have hungarian keyboard layout in Macbook Air (the bluetooth keyboard is same).
When i connected to a terminal server with hungarian keyboard layout some keys are change.
'0' key change to í and 'í' key changed to 0. (i think 'í' key is not exist in english keyboard. I have totally 79 button on keyboard)
All other keys are fine.

Best regards.

Clock6 yrs

Hi

We support different keyboard layouts. Can you check your connection settings:

Local Resources > Keyboard > Keyboard layout

And select Hungarian?

Note that I don't think the keyboard layout will be reflected if you connect to an existing session.

Let me know if that helps,

Richard

Richard Markievicz

signaturesignature

Clock6 yrs

Hi,

I tried this settings but it doesn't help.
I think my problem based on exactly the '0' and 'í' button. This 2 button have a special physical location on hungarian keyboard.
Any other buttons are working correctly only this 2 button exchanged each other.
That easier imagine the problem, i attached a picture about the keyboard.
Thank you for your answer.

Krisztian

Clock6 yrs

Sorry, here is the picture.

Keyboard.jpg
Clock6 yrs

Hi

Sorry if I'm not understanding you correctly.

If I connect to my remote session using the "Hungarian" keyboard layout, I hit the key directly above 'Tab' ('~' on my keyboard, '0' on yours) and it prints a '0'. Are you saying that when you hit this key, it prints 'í'?

Of course I can't test the 'í' key myself, because my keyboard does not have that key. But you are saying that, when you press that key, it prints a '0'?

Thanks, Richard

Richard Markievicz

signaturesignature

Clock6 yrs

Hi,

Yes it's completely true. The two key '0' and 'í' exchange each other.
This problem is appears not only RDMGR, it's exists in other RDP clients like CoRD.
We have more than 10 apple computer but the problem exists in all of them. We tested each machine.
We already purchased Devolution RDMGR software for windows clients and used RDMGR through virtual windows environment without problem.

Thanks, Krisztian

Clock6 yrs

Hi,

OK thank you for clarifying that.

I will forward this information to the FreeRDP developers.

Thanks, Richard

Richard Markievicz

signaturesignature

Clock6 yrs

Hi,

For the sake of fixing this bug, please help me with the following:

Can you tell me which keyboard layout are you using normally on Windows? I see there exists two possible Hungarian keyboard layouts:

Hungarian 0x0000040E
Hungarian (101-key) 0x0001040E

Notice these are two separate keyboard layouts with different keyboard layout ids. You can use the following page as reference:
http://msdn.microsoft.com/en-ca/goglobal/bb964651.aspx

Second, can you point me to keyboard models on amazon or ebay (or the apple website in your case) that you know for sure are of the same type as the keyboard you are using?

I can easily understand why the hungarian keyboard could cause issues, but so far the only way I could think of to fix this problem would be to buy a hungarian keyboard, use the same keyboard layout as you, reproduce the issue with a known test case and then fix it.

Clock6 yrs

Hi,

We just bought an Apple Hungarian keyboard. We will be able to test this shortly.

Benoît Sansregret

signaturesignature

Clock6 yrs

Hi,

I think i use simple Hungarian (0x0000040E) layout.
I tried to search keyboard on amazon or ebay but i didn't found yet.
Your college Benoit Sansreget sent me an answer about you bought one.
Thank you for your answer and a lot of work on my problem.


awakecoding wrote:

Hi,

For the sake of fixing this bug, please help me with the following:

Can you tell me which keyboard layout are you using normally on Windows? I see there exists two possible Hungarian keyboard layouts:

Hungarian 0x0000040E
Hungarian (101-key) 0x0001040E

Notice these are two separate keyboard layouts with different keyboard layout ids. You can use the following page as reference:
http://msdn.microsoft.com/en-ca/goglobal/bb964651.aspx

Second, can you point me to keyboard models on amazon or ebay (or the apple website in your case) that you know for sure are of the same type as the keyboard you are using?

I can easily understand why the hungarian keyboard could cause issues, but so far the only way I could think of to fix this problem would be to buy a hungarian keyboard, use the same keyboard layout as you, reproduce the issue with a known test case and then fix it.

Clock6 yrs

Hi,

Thank you, we'll keep you posted once we receive the keyboard. I found the exact same keyboard you are using on eBay based on the picture you sent. Once I have the keyboard, it shouldn't take long to fix it.

Clock6 yrs

Hi,

I think we resolved the issue with the hungarian keyboard.
The fix is available in version 0.9.47.0
You can get it by clicking Check for Updates

Thank you for your feedback and patience

Benoît Sansregret

signaturesignature

Clock6 yrs

Hi,

Just a note: for the fix to work you need to be using the Hungarian keyboard layout on Mac OS X as well. The reason why the keys were inverted is because of an oddity of the Apple Hungarian keyboard: the hardware actually sends the keys inverted, and the Mac OS X Hungarian keyboard layout puts them back in the correct order. The Windows keyboard layout, however, expect those keys to be in the correct order from the start, so we need to detect this inversion and fix it on the client side before sending the keys to the remote machine. The only way this could be detected was to compare the resulting characters provided by OS X on those specific cases to detect the inverting of the keys in the case of the Hungarian keyboard layout, and proceed to fix the input.

Clock6 yrs

Hi,

Thank you for your work! I tried the new version and it works correctly.

Thanks, Krisztian

Benoit Sansregret wrote:

Hi,

I think we resolved the issue with the hungarian keyboard.
The fix is available in version 0.9.47.0
You can get it by clicking Check for Updates

Thank you for your feedback and patience

Clock6 yrs

Hi,

I had to change the last fix to support the hungarian keyboard.
You now have to set the keyboard layout in the local resource tab to your desired keyboard layout.
After the that the fix should be the same.

Sorry for the inconvenience

Benoît Sansregret

signaturesignature

Clock6 yrs

Hi All,

I updated RDM to the new version: 0.9.53.0
The keyboard problem appeared again. 0 and í key are changed.
In the previous version this was ok.

Thanks, Krisztian

Clock6 yrs

Hi,

Sorry about that I will check what is going on.

Thank you for reporting that

Benoît Sansregret

signaturesignature

Clock6 yrs

Hi,

The fix implemented on version before version 0.9.50.0 caused an other issue and we had to change it.
On version 0.9.50.0, you need to change the keyboard layout in your session configuration for your keyboard to work properly.

This is the current state of the application.

But good news, on the next version 0.9.54.0, we will be able to detect the connected keyboard and you will not need to change the keyboard layout for your keyboard to work properly.

Sorry for the inconvenience and tell me if you need more help.

Benoît Sansregret

signaturesignature

Clock6 yrs

Hi All,

I found this problem in the Enterprise edition for oOS X version 3.0.6.0. Is there any way to solve this issue?
Thank you in advance!
Regards, Peter

Clock4 yrs

Hi Peter,

Could you describe exactly what behaviour you have and what are you expecting?

Best Regards,

Benoît Sansregret

signaturesignature

Clock4 yrs

Hi,

As Krisztian wrote earlier, the '0' and 'Í' characters are swapped on hungarian mac keyboards, even if i set the keyboard to hungarian in the session properties. I use the RDM version 3.0.6.0
You wrote that you resolved the problem in 0.9.47.0 but later you had to change it back. Now it's still not solved, so i would be very grateful, if you could resolve this "swapped character" issue.
Thanks, Peter

Clock4 yrs

Thank you for the precision I will looking that as soon as possible.

Benoît Sansregret

signaturesignature

Clock4 yrs

Hi Peter,

I made a few tests with and without the old fix and the current version is supposed to work correctly.
I made a test and if I set my mac and remote machine keyboard to Hungarian it seem to work correctly (I used the Keyboard viewer to make sure I hit the keys that don't appear on my keyboard). You shouldn't have to change anything to your Remote Desktop Manager Entry.

I built you a version with the old fix that you can try if you want. I'll send you the download link in a private message.

If the old fix is the only thing that solve your issue I'll see to add an option for it.

Best Regards,

Benoît Sansregret

signaturesignature

Clock4 yrs

Hi,

I tried the release you built me. It works fine even i set the layout to hungarian or leave it invariant language. Thank you for your support! It's possible to implement this fix into the later public versions?
Thanks again!
Regards, Peter

Clock4 yrs

Hi Peter,

Yes we will the toughest part will be to find a good name for the setting.

Benoît Sansregret

signaturesignature

Clock4 yrs

Hi Peter,

Next Release will have the settings you want.
It will be called Invert Hungarian Characters and it will be located in the Local Resources tab of an RDP entry.

Best Regards,

Benoît Sansregret

signaturesignature

Clock4 yrs

Hi Benoit,

Thank you for the support and for the good news!
Regards, Peter

Clock4 yrs

Hi everyone,

I'm got the same issue, but it's not only the 0 and í key switched, but other characters (What you can type by pressing Command, etc) are TOTALLY incorrectly positioned. I'm testing Max OS X 10.11 El Capitan via VMware Workstation 12, and I do also have a hungarian keyboard (Not Apple keyboard). The keyboard layout sat to Hungarian of course.
Just to see, by the default I reach the @ character by pressing option ⌥ + V. But now I have to press ⌥ + Q to do it.
And all the other characters are just messed up.

I've been looking for any program which makes me able to add a custom layout but didn't really find one.

Any ideas what can I do with this?

Waiting for your response, Richard.

Clock4 yrs

Hi Richard,

As I don't have a physical Hungarian keyboard available I use the Mac Keyboard viewer to see where the key are supposed to be positioned. you see the @ character is obtained by pressing the ⌥+q which is different from the Hungarian keyboard I have seen in Windows.

I think the problem you experience i due to VMware Workstation and not Remote Desktop Manager.
VMware Workstation transfer the keystroke correctly but those keystrokes are not interpreted correctly on the Mac.
Remote Desktop Manager doesn't transfer the keyboard stoke directly (by design) so your connected computer doesn't receive the correct characters.

We have similar behaviour using VNC to connect to a Mac and then test Remote Desktop Manager

Unfortunately, we currently don't support custom layout for keyboard, but it's on our TODO list we just not there yet.

Best Regards,

Benoît Sansregret

signaturesignature

Clock4 yrs