Forum / Remote Desktop Manager Mac - Bug Report

FreeRDP: Undocked has one tab

  • Create an Issue
  • Cancel

I'm using my display undocked. There is always one tab used which is a wast of space:

tab+example

Nice to have tabs in Embedded mode, but no use in Undocked mode.

tab example.png
Clock6 yrs

I can understand how this is a problem.

If we remove the tab bar completely, there is no longer a target to drop additional tabs onto.

I think perhaps the best thing might be, to have a shortcut to show/hide the tab bar (like in Safari).

What do you think of that?

Richard

Richard Markievicz

signaturesignature

Clock6 yrs

Richard Markiewicz wrote:

I think perhaps the best thing might be, to have a shortcut to show/hide the tab bar (like in Safari).

Thanks for your feedback. Really nice that you guys listen to your customers, better said: users of your program.

Put a switch into the Preferences?

I do not need to have more sessions in one window, I use multiple windows placed on several virtual screens. In my work I am doing several tasks at the same time. So every customer gets his own virtual screen: RDP session, ticket opened in a web browser, some documents etc. Switching from one customer to another moves everything related to that customer. Thats the way I keep my work organized.

Clock6 yrs

Hi,

It's a good idea. I've added this for the next version.

Thanks, Richard

Richard Markievicz

signaturesignature

Clock6 yrs

If you get the latest version (0.9.29.0), there is a setting in Preferences > General > User Interface called "Show the tab bar on undocked windows".

If you uncheck that option, the tab bar will not be shown on undocked windows (it will not affect any undocked windows that you already have open).

Let me know any problems!

Thanks, Richard

Richard Markievicz

signaturesignature

Clock6 yrs

Thanks Richard! Working great.

Clock6 yrs

Big Grin

Richard Markievicz

signaturesignature

Clock6 yrs