Forum / Remote Desktop Manager - Feature Request

Portable settings

  • Create an Issue
  • Cancel

Many of my complimenting apps to RDM (filezilla, putty, nxclient etc) are portable so in RDM -> Options -> Installation Path each app needs to be manually updated

Session info is stored in a db but the RDM settings I assume are in the registry?


Is it possible to keep the RDM setting in an xml or ini file in order to make the installation more portable.

Clock8 yrs

Hi,
RDM can be configured to be portable. Install RDM on youtr usb key, the application will save the file remotedesktopmanager.cfg directly on the usb key (in the installation folder). After that, you will be able to configure your other application path relatively to the RDM installation path. You can also configure you data source to be on the usb or use Remote Desktop Manager Online.

I hope this help. We will create soon a tutorial about this

David Hervieux

signaturesignature

Clock8 yrs

David,

Can RDM be made portable without the explicit use of removable drives?
So can I configure RDM so that everything is in one directory. Also the .cfg file?

Cheers!

Sjoerd

Clock8 yrs

Hi,
It's possible, you can specify the folder relative to the installation path, for example:

..\..\PuttyPortable

David Hervieux

signaturesignature

Clock8 yrs

I mean the config file of remotedesktopmanager. I have several users here having installed RDM and on one computer RDM looks for the %appdata% folder, another RDM looks for %localappdata%, and other users have RDM look for the config file next to the EXE.
But I cannot understand how RDM looks for the config file.

I would like to know how I can tell my RDM to look for the config file next to itself.

Cheers!

Sjoerd

Clock8 yrs

I know this topic is a little bit complicated. With the latest beta, it's more simple to create a file name override.cfg in the installation path and specify where you want the config file to be saved. This mean that in your case, the override.cfg file will contains this:

.

A dot to specify that you want it in the current installation path.

David Hervieux

signaturesignature

Clock8 yrs

Thanks! exactly what I needed...

Cheers!

Sjoerd

Clock8 yrs

It does not work on all computers... I just created the override.cfg file on one computer and that works. Moved to the next one, created the override.cfg and RDM asks for the license etc every time I start it. It does not remember anything.... Any ideas?

Cheers!

Sjoerd

Clock8 yrs

Do you use the beta version on all computers, because this was introduced in the beta only ?

David Hervieux

signaturesignature

Clock8 yrs

yep, all betas here....

Cheers!

Sjoerd

Clock8 yrs

Couldn't this be related to some users taking over their computers with RDP and some access it physically? Can this functionality be turned off in 'portable mode'?

Cheers!

Sjoerd

Clock8 yrs

It's not supposed, the application should look first at the override.cfg. Can you open the Option and go in the advanced tab page, you will see at the bottom right a small label, this indicate where the option cfg come from: This should write override.

David Hervieux

signaturesignature

Clock8 yrs

Yep it does, but after closing and reopening RDM it again asks for everything is does normally the first time...
I have checked the entire computer for devoltions/remotedesktopmanager stuff, but cannot find any reason for this not to work...

Cheers!

Sjoerd

Clock8 yrs

Hi,
Do you save the cfg in program files ? The problem might be related to the vista virtualization.

http://support.microsoft.com/kb/927387

David Hervieux

signaturesignature

Clock8 yrs

The problem is on a WinXP machine. My Win7 laptop is working fine with the portable version.

Cheers!

Sjoerd

Clock8 yrs

Can you send me a printscreen of the last option tab page?

David Hervieux

signaturesignature

Clock8 yrs

I cannot really grasp what is going on. I spend a lot of time trying to get it working in portable mode.

Finally just now rebooted my pc for something else and voila RDM portable works like a charm....

Cheers!

Sjoerd

Clock8 yrs

David, Still the problem remained and I now know what is causing this...
When you enable 'portable' mode by use of the override.cfg and you place this portable version in a subfolder of %program files%, then it will not remember anything.
When you move this folder in some other folder, everything seems to be working fine.

Cheers!

Sjoerd

Clock8 yrs

you cant use %programfiles%/Remotedesktopmanager/ as directory, just use a subdir %programfiles%/Remotedesktopmanager/config/ for example - probably its working with next version, cause in this version is a small bug with the config cut instead of copy i think...

Clock8 yrs

Hi,
The problem is really linked to the Vista virtualization. Long time ago, this is why I moved the cfg file to local settings. This will be better to move the config file to something like this: C:\RDM

David Hervieux

signaturesignature

Clock8 yrs

It's working with the override.cfg configured with a period and placing the entire app in a non-system folder like: c:\RDM.

Cheers!

Sjoerd

Clock8 yrs