Forum / Remote Desktop Manager Mac - Bug Report

Mac Beta Bug - Can't connect to SQL Data Source

  • Create an Issue
  • Cancel

Hi RDM

Well I finally got around to trying RDM Mac Beta! Straight away I ran into a showstopper problem - I can't connect to my SQL Server Data Source. Screenshots attached with all the versions (eg - OS X Mavericks), error messages and log files you will want (all obtained with Debug level 1). Other info you may need :

- We did a "Check for updates" - we were already on the latest version
- We've tried both Integrated Authentication and simple SQL logins - same result
- We can successfully "ping records", so it's not a name resolution or network connectivity problem
- We've also tried the IP address of the server - same result
- On the SQL Server, I don't even see a failed login attempt in the logs - it's as though the client just doesn't attempt to connect at all!

Also, I wanted to mention that it's trivial to force the App to display a plain-text copy of your password on screen. All you need to do is set Debug to 1 and then click "Test Database". Not good. As a minimum - could you replace the password with '*' characters before displaying it?

Thanks

Des

Error Message 1.jpg
Error Message 2.jpg
OS Version.jpg
RemoteDesktopManager.log
Clock7 yrs

First thing I did was connecting RDM to our MSSQL database and I have no problem at all.

Clock7 yrs

Hi RDMers

I have fixed this issue. Sorry for the false alarm, but it was an issue that is worth noting. My SQL Server has multiple instances running on it, and when we were configuring the RDM Mac Data Source, I forgot to specify the instance to connect to! It was connecting to one of the other instances instead! (Presumably a default instance...)

So, we solved the problem by putting "fullyqualifiedservername\instancename" into the "Server" configuration field in RDM.

Sorted!

Des

Clock7 yrs