Forum / Remote Desktop Manager Mac - Bug Report

Crash when quitting RDP and saying no

  • Create an Issue
  • Cancel

When I quit the RDM application but say no to the "are you sure you want to quit" dialog box the application crashes. Crash data attached.

crash[2].txt
Clock7 yrs

This is fixed in the next version.

Thank you for the feedback smile

Richard

Richard Markievicz

signaturesignature

Clock7 yrs

This should be resolved in the current version (0.9.10.0). Please let me know if you see the issue again!

Thanks, Richard

Richard Markievicz

signaturesignature

Clock7 yrs

That issue seems to be fixed but I did get a crash almost immediately after connecting to a session after upgrading (attached).

Also - I'm getting "cannot find mstsc.exe" errors on some of my connections now. It appears to only be connections that are set-up with the default setting of "External" display. If I change it to Embedded (tabbed), they work fine.

crash[3].txt
Clock7 yrs

The 'External' mode launches the connection in the Microsoft RDP client (if it's installed).

Previously this wasn't implemented on the OS X version, so if you had this option set we would just default to displaying in a tab.

This option is now available on OS X in the latest version, so 'External' mode behaves properly again. If you have MS RDP client installed, the connection will now open in that.

The crash is strange. It looks like it happened when you closed a tab? Or it was just immediately after connecting? Does it reoccur/reproducible?

Thanks, Richard

Richard Markievicz

signaturesignature

Clock7 yrs

I haven't been able to make it crash since... I'll upload a new crash report with more details if I can make it happen again.

As far as the external monitor - would it be possible to set tabbed as the default? All of mine are currently set to external since that is what the default option is when creating a new entry.

Thanks!

Clock7 yrs

Hi,

Opening 'External' (in the MS RDP client) is the default on Windows, where it makes a lot of sense to do that (MS RDP is always installed).

I agree that on the OS X version, it makes more sense to defaulting to a tabbed connection.

We will implement this quickly.

Thanks, Richard

Richard Markievicz

signaturesignature

Clock7 yrs

You guys rock!

Clock7 yrs

Hi

Just to let you know - we actually exposed this last week, but I forgot to come back here and update you - you can now configure the default for new connections on the OS X client.

Go to "Preferences > General" and there is a setting "Open embedded by default..."

If you check that, newly created connections will default to the embedded mode.

Thanks, Richard

Richard Markievicz

signaturesignature

Clock6 yrs

Check and check, thanks!!

Clock6 yrs

Hello Richard,
Change from external monitor to embedded definitely fix my issue with new connections. I do have installed the "Remote Desktop Connection" that comes with OS X 10.9. Do I need a different client for the "external" monitor to work?

Clock6 yrs

Hi

Just to clarify a few things:

The meaning of the 'Display' option is not which monitor it runs on.

External - open the connection with the MS RDP client (if installed)
Embedded - use FreeRDP and open in an embedded ('docked') tab inside the app
Undocked - use FreeRDP and open in a new window ('undocked') tab inside the app

I don't think any version of OS X ever came with the Microsoft RDP client. Is it possible that you downloaded sometime in the past? It seems you have the 'old' version of the client - it was released many years ago and never really updated.

MS has a new version of the client (it's called "Microsoft Remote Desktop" rather than "Remote Desktop Connection") and it's only available in the Mac App Store. That's the only version of the client that we support, since the previous one is so old.

Let me know if you have some more questions on this

Thanks, Richard

Richard Markievicz

signaturesignature

Clock6 yrs