Forum / Remote Desktop Manager - Feature Request

Friendly name

  • Create an Issue
  • Cancel

Would it be possible to have an additional field for a Friendly or Display name that is common accross all modules/add-ons?
When using sub-connections in many modules I need to reference the IP or Hostname and the only options refer to the Name.
for example:
I have an RDP connection called www1 (Friendly name)
it's hostname is for example something like GIW-WWW1-MPLS or IP of 1.1.1.1
Lets say it uses a different port other than 3389 also.
When creating sub connections for ftp for example I am unable to reference the parent with anything other than $PARENT_NAME$ as the $PARENT_HOST$ includes the port number.
Either you could separate the port number for RDP sessions or for the sake of sub-connections you could have perhaps a blank host where you can define various info like server info and that sub-connection can then refer to as many sub-connection could exist for a specific host.

or you could add the ability to define custom variables for a particular connection. I think mRemote has this feature.
<em>edited by shorvath on 11/26/2010</em>

Clock8 yrs

Hi,
For sure custom variable should be nice. I have a small of solution for you, you can use the custom fields and use it in your parent.

I just did some test, and I don't understand, the port is not included in the PARENT_HOST with a RDP connection. Can you reproduce it in the version 5.9 ?

David Hervieux

signaturesignature

Clock8 yrs

You're right it doesn't pickup the port number. I just assumed it would. Apologies for the assumption.
I guess my main issue is is that some of my parent hosts don't always have a hostname option that I can use for the sub connections.
There are workarounds eg. put those connections with hostnames as the parent, but it looses consistency with the order of my connections.
In my opinion I think a base connection which all sub connections can piggy back from would be good.
Your suggestion for custom fields does sound linke a good one.
I will try it out.
<em>edited by shorvath on 11/29/2010</em>

Clock8 yrs

I tried your suggestion.
I added a session of type "Text".
I plan to use this session as a parent for all sub-connections.
Under "Information- Other" I changed "Custom #1" to HOSTNAME.
In the sub connection I added a session of type RDP and under "General - Computer" I added $PARENT_HOSTNAME$
This doesn't work.
What am I doing wrong?

Clock8 yrs

Hi,
the variable for the custom field should be $PARENT_CUSTOM_FIELD1$... but this time it's my mistake, I was sure that this was supported but it was on my todo list to add these variables. Give me few hours, I will add this and send you another build.
<em>edited by dhervieux on 11/29/2010</em>

David Hervieux

signaturesignature

Clock8 yrs

Hi,
I uploaded an internal version with the custom field variables:

http://remotedesktopmanager.com/download/Setup.RemoteDesktopManager.5.9.0.2.exe

David Hervieux

signaturesignature

Clock8 yrs

Thanks,
I tried the new release and it works fine.
I did notice that if you enter the wrong Variable
eg $CUSTOM_FIELD1$ instead of $PARENT_CUSTOM__FIELD1$
it gives an error stating that you are low on virtual memory

Clock8 yrs

It would also be nice to be able to convert an existing session to be a sub-connection somehow.

Clock8 yrs

I second that! This is cool stuff!!

Cheers, Kent

Clock8 yrs

Hi, I'm afraid this is not working.
If I have another rdp session open above the host although it is not a parent, it connects to this session.
eg I have the following layout
SITE1 (Folder)
-server1 (type text) (Custom #1)
- rdp (rdp session, child to server1) ($PARENT_CUSTOM_FIELD1$)
- server 2 (type text) (Custom #1)
- rdp (rdp session, child to server2) ($PARENT_CUSTOM_FIELD1$)

If server1 rdp is connected then rdp for server2 connects to server1's rdp session instead of server2
If server1 is not connected then server2 rdp connects as expected.

Clock8 yrs

Hi,
It's really weird, I will do some test because I really don't know what might cause this side effect.

David Hervieux

signaturesignature

Clock8 yrs

Hi,
I reproduced the problem, it's a bug in the clone. the session ID is the same. Is it possible to you created the second session with the Duplicate menu?

David Hervieux

signaturesignature

Clock8 yrs