Forum / Remote Desktop Manager - AddOns

Juniper-Netscreen Add On

  • Create an Issue
  • Cancel

Is there a possibility of managing Netscreen VPNs via RDM?
We currently use Netscreen-Remote (SafeNet SoftRemote)
<em>edited by shorvath on 11/16/2010</em>

Clock10 yrs

Hi,
Do you know if it's possible to open and close it in command line ?

David Hervieux

signaturesignature

Clock10 yrs

Hi,
Yes I can confirm that there is a Command Line method of connecting.
I'de say if one is to be created it would work like most other VPN add Ons
The CLI takes the following options:


C:\Program Files\Juniper\NetScreen-Remote>vpn.exe /?
vpn [-silent] -presencecheck
[-silent] -reload
[-silent] -activate
[-silent] -deactivate
[-silent] -retrieve
-import <filename> [<password>
[-silent | -gui] -connect <group name\connection name> [<wait_interval>]
[-silent | -gui] -disconnect <group name\connection name> <wait_interval>]
[-silent | -gui] -certexists <issuer DN> <subject DN>
<em>edited by shorvath on 11/17/2010</em>

Clock10 yrs

I thought of using the Command line option in RDM if only I could relate it to another session in some way.
I have probably 50 RDP sessions that each need a vpn connection to be established first.
I hope that's clear.

Clock10 yrs

Hi,
Yes it's possible, but you will have to create a command line session for each different vpn connection. After that, you can select in the VPN tab a specific session.

David Hervieux

signaturesignature

Clock10 yrs

I've done that. It's just a little awkward and time consuming.
I've been using your app for some time now and really think it's a valuable asset.
I've used others in the past but this is by far the best.
I've just started in a new company so in a short time I will push for the enterprise to be purchased.


Thanks for a great app. smile

Clock10 yrs

Thank you, like I wrote, I added Juniper VPN to our todo and even if we can test it, we hope that it's something that you could do for us?

David Hervieux

signaturesignature

Clock10 yrs

Of course. With pleasure

Clock10 yrs

Hello,
What should be the default value of "wait_interval" ?

Thanks
André Sanscartier
Devolutions inc.

shorvath wrote:

Hi,
Yes I can confirm that there is a Command Line method of connecting.
I'de say if one is to be created it would work like most other VPN add Ons
The CLI takes the following options:


C:\Program Files\Juniper\NetScreen-Remote>vpn.exe /?
vpn [-silent] -presencecheck
[-silent] -reload
[-silent] -activate
[-silent] -deactivate
[-silent] -retrieve
-import <filename> [<password>
[-silent | -gui] -connect <group name\connection name> [<wait_interval>]
[-silent | -gui] -disconnect <group name\connection name> <wait_interval>]
[-silent | -gui] -certexists <issuer DN> <subject DN>
edited by shorvath on 11/17/2010

André Sanscartier

signaturesignature

Clock10 yrs

Hello everyone,
"Juniper-Netscreen AddOn" has been added to the "VPNAddOn.dll".
Please try it and send us back your comments.

We are not able to test it.
http://remotedesktopmanager.com/download/AddOn/VPN1.3.0.0.zip

Thanks!

André Sanscartier

signaturesignature

Clock10 yrs

Works like a charm.
I haven't tested extensively but so far so good.
You rock!!!

Clock10 yrs

So far the only issue I see is when I try and integrate the vpn into the rdp connection.
eg In the rdp connection properties under vpn.
if I enter the connection details there and double click the rdp session, the vpn connects successfully but the rdp session never initiates and eventually it closes

Clock10 yrs

Hi,
I suspect that the VPN is opened after the RDP connection is made. You can change the VPN wait time in the application options. It's in the Advanced tab page, change the setting for the After VPN connection delay. You can also try to open your session in external mode to see if you get another error.

David Hervieux

signaturesignature

Clock10 yrs

Hi,
I uploaded a new version with a small delay after the execution:

http://remotedesktopmanager.com/download/AddOn/VPN1.3.0.1.zip

David Hervieux

signaturesignature

Clock10 yrs

Yep that works like a charm.

Thanks.

Clock10 yrs