Forum / Remote Desktop Manager - Support

Suddenly stuck in "always on top" mode

  • Create an Issue
  • Cancel

I don't know what I've done, but suddenly my Remote Desktop Manager is in "always on top" mode - No matter what I do, I can't see windows behind it until I move it out of the way. So far I can't find anything in the options and was hoping somebody could help me out. I considered restarting the app but I have a few dozen open RDP sessions and would prefer not to go that route if possible. Thanks in advance.

Clock7 yrs

Hi,
There is a parameter in File->Options

It's in the UI Options list

Always on top

David Hervieux

signaturesignature

Clock7 yrs

Ok, looks like I have a bug, then, along with a nasty UI glitch.

I have RDM maximized on my second monitor. I went to file-options, which opened the options dialog, but it's stuck behind RDM and since RDM is the parent window, I can't get to its child! I can't alt-tab to the options. I can't minimize all because RDM stays up. If I Aero-peek, I can see the options dialog and can see clear as day that under UI Options - general, "Always on top" is unchecked. But I can't click on it.

I guess I have to kill the RDM process and orphan my 40+ open sessions, unless anybody has any other ideas.

Clock7 yrs

You could try the Escape key or Alt F4

David Hervieux

signaturesignature

Clock7 yrs

Thanks, tried those but they didn't work. I finally got it back but it took some voodoo.

I RDPed to my desktop from my laptop, which has a lower resolution. When I went back to my desktop, the RDM screen was smaller than the options box and I could click cancel. However, I shot myself in the foot because I then went to File - Options and even though RDM wasn't maximized, the options screen opened dead center behind the main window. Argh!

I then RDPed from my laptop, setting the resolution to 640x480 (which is fun). I was then able to cancel the options dialog. I then made the RDM window as small as possible and this time was able to open the options box and do things to it. I enabled 'always on top', was told I'd need to restart the application, cursed it, and clicked ok. I then went back and disabled 'always on top', clicked ok, and my problem has been resolved. The app is no longer on top of any windows and so far everything is peaches and gravy.

Clock7 yrs

@JerkyChew. I just ran into the same problem. Thanks for the solution. I also had to turn it on , then off again to send the application to the background.

Clock3 mths