Hello,

I'm experiencing really slow startup on new installation on our VDI infrastructure with Windows 7, even with 8.2.17.0. After startup, it works fine.

It takes 2 minutes for the Splash screen and another one for the full program. Removing the splash screen, the automatic update and switching to the Classic UI don't work. Also, removing the AppData\Local\Devolutions folder and reinstalling the program itself was unsucessful. The Data Source is the default local empty XML file.
I suspect there is something wrong with these VMs, because even the installations takes dozens of minutes.

What could I check?

Thank you,
Nico

Clock6 yrs

Hi,
I suspect that .NET has some issue to JIT the code. .NET use an intermediary code and it compiles on startup. If you restart the application, does it open quickly?

David Hervieux

signaturesignature

Clock6 yrs

No, if I restart the application it still takes 3 minutes to startup ;-(

Nico

Clock6 yrs

Hi,
Take a look at this topic

http://help.remotedesktopmanager.com/troubleshooting_startupperformance.htm

The one about the slow start-up

David Hervieux

signaturesignature

Clock6 yrs

YES, making the .config file resolves the problem totally (I read it in the past, but I forgot it ...).

Thanks a lot,
Nico


PS: could I suggest to place this setting (also) among the others in the GUI Advanced Configuration?

Clock6 yrs

Unfortunately it's not a real setting. It's a Windows directive but I will verify what we can do.

David Hervieux

signaturesignature

Clock6 yrs

Hello,

today I tried the Beta 8.9.10 in the hope of a faster statup process. But unfortunately the startup time did not change. Using the "RemoteDesktopManager.exe.config" did not accelerate the start process.

The 32-bit version needs about 30 seconds, the 64-bit version 44 seconds.

Are this normal startup times?

RDM starts from an SSD harddrive.
edited by Tom on 9/2/2013

Clock6 yrs

@Tom - Could you start the app with the /Profiler (both x86 & x64) and send me the profiler logs.

slavergne at devolutions.net

Thanks

Stefane Lavergne

signaturesignature

Clock6 yrs

Hi Stéfane,

you got a mail. Thank you!


Tom

Clock6 yrs

Hi,
Have you seen this topic about the slow start-up?

http://help.remotedesktopmanager.com/troubleshooting_startupperformance.htm

David Hervieux

signaturesignature

Clock6 yrs

David Hervieux wrote:

Hi,
Have you seen this topic about the slow start-up?

http://help.remotedesktopmanager.com/troubleshooting_startupperformance.htm


Hi David,

yes I know this topic and changed some settings ... but without success.

Clock6 yrs

Ok,
I will wait for stefane and see what he got from the profiling trace

David Hervieux

signaturesignature

Clock6 yrs