Forum / Remote Desktop Manager - Support

license is only valid for older version of application

  • Create an Issue
  • Cancel

I'm currently running Remote Desktop Manager 2019.2.22 64-bit Enterprise Edition.
It says free upgrade until 5/1/2020.

We're trying to install RDM to a new machine using the same Enterprise credentials but we're getting:


Sorry, your license is only valid for an older version of the application. Your software maintenance period is expired.


1. How is it that we have numerous installs all with the same credentials that are still running and say they are valid through 5/1/2020?
2. If we had to install an older version... how do we know what the last supported version is for the license?

Thanks.

Jamie

Clock2 mths

OK... after an uninstall and re-install... now it appears to be working. RDM has updated and it is reporting that it's good through 5/1/2020 as the other existing installs are.

Not sure what's going on there... but it seems resolved on the one machine. We have another machine to build so we'll see what happens.

Clock2 mths

Hello,

Thankyou for your feedback.

Are you using our custom installer feature to deploy RDM properly on your workstation?
https://helpcloud.devolutions.net/custominstaller_introduction.htm

Best regards,



Jeff Dagenais
signaturesignature

Clock2 mths

No, we have been just downloading the latest installer from the Devolutions site.
https://remotedesktopmanager.com/home/download

We have not looked into the custom installer option.

Thanks.

Jamie

Clock2 mths

Mystery solved... Yes we received an updated license... but no one was told about it. It just got filed away for safe keeping. Spock
Existing installations / accounts had the new license applied, but when we were trying to create a new install (using the old license) we got the message.

Thanks.

Jamie

Clock2 mths

Hello,

Glad that you have found the culprit of the issue!

Thank you for your feedback.

Best regards,



Jeff Dagenais
signaturesignature

Clock2 mths