Forum / Remote Desktop Manager IOS - Support

RDM iOS app, offline mode not possible

  • Create an Issue
  • Cancel

Hi there,
with the iOS app for RDM, i cannot activate the offline mode. The offline mode is grayed out and is disabled.
Interestingly, the same DB user (mssql) can activate the offline mode in the desktop version without any problems.

What do you have to do, so that this also works on the smartphone?

thx for any help.
Stefan


Clock2 mths

Hello,

What version of RDM Windows are you running?

Are you authenticating on the database using database user ?

Best regards,



Jeff Dagenais
signaturesignature

Clock2 mths

Hi Jeff,

>>What version of RDM Windows are you running
latest

>>Are you authenticating on the database using database user
yes, for this user

Best regards
Stefan

Clock2 mths

Hello,

I think I have been able to reproduce your issue.
I enabled the prompt for offline mode on startup and auto go offline options on RDM iOS and I am not able to go in offline mode.

I opened a ticket to our engineering department regarding this.
The ticket number is RDMI-732.

Best regards,



Jeff Dagenais
signaturesignature

Clock2 mths

Jeff,
Thanks for the quick analysis.

i think you're right, if i remember correctly i did the same.

best regards,
Stefan

Clock2 mths


Hi,

This is just to let you know that the fix will be in the next release which should be in a few days.

Best Regards,

Nicolas Dufour

signaturesignature

Clock2 mths


Hi Nicolas and Jeff,
first merry Christmas and thank you for the quick fix.
But it only works 50%, now i can go offline but not online.
When i try to go online, i get the error message that the Datasource is offline, only a restart of the APP helps.

best regards
Stefan

Clock27 days

Hi Stefan,

Thank you, we will investigate.

Best Regards,

Nicolas Dufour

signaturesignature

Clock26 days


Hi,

To confirm - your issue is that the Go Online option as shown in this image doesn't work?

image

Thank you.

Best Regards,

Benoît Racine

signaturesignature

Clock20 days


Hi Benoit,
Exactly, after going offline works, but not always switch to online.
When i select "Go online" in the menu, i get the error message "The data source is offline".
Only restarting the app will help here.

Best regards
Stefan

Clock20 days


Hi Stefan,

I am unable to reproduce the issue on my end. Could you post the values for the following settings in your mssql data source :

-Login mode (Database login/Custom login)

-Always ask password (ON/OFF)

-Allow change username (ON/OFF)
-Two Factor (None/Google Authenticator/Duo)

-Private Vault (Default/None/Online Drive)

-Do you have multiple Vaults/Repositories?

Thank you

Best Regards,

Benoît Racine

signaturesignature

Clock19 days

Hi Benoit,
>>-Login mode (Database login/Custom login)

Database login

>>Always ask password (ON/OFF)
?? use Touch ID

>>-Allow change username (ON/OFF)
??

>>-Two Factor (None/Google Authenticator/Duo)
None

>>-Private Vault (Default/None/Online Drive)
None

>>-Do you have multiple Vaults/Repositories?
No

Best regards
Stefan


Clock14 days

Any news here ?

Clock12 days

Hi Stefan,

We haven't been able to reproduce the issue. We will continue to work on it
next week.

Best Regards,

Nicolas Dufour

signaturesignature

Clock11 days


Hi Stefan,

I'd like to make sure we are on the same page.


-Are you using the latest version of the app, 2019.2.3?


-Can you confirm your data source has the same screen as the one shown below?

image

Thank you

Best Regards,

Benoît Racine

signaturesignature

Clock9 days

H benoit,
i can confirm both.
The interesting thing is, if the app is offline and this error message comes up, i can test / ping the server and DB in the app.

best regards.
Stefan

Clock7 days


Hi Stefan,

Thank you the information. Unfortunately we are not able to reproduce the issue at this time. We will try to fix the issue but we will be taking stabs in the dark so we can't guarantee that we will be able to fix it.


Thank you for your understanding.

Best Regards,

Benoît Racine

signaturesignature

Clock7 days