Forum / Remote Desktop Manager - Support (Deutsch)

Import Passwordsafe 8 CSV

  • Create an Issue
  • Cancel

Hallo,

wir prüfen gerade dem Import von Passwordsafe 8 CSV Dateien.

Leider wird der Import immer direkt mit folgendem Fehler quittiert:

Ungültiges CSV-Format. Bitte prüfen Sie die Anwendungsprotokolle für weitere Informationen.

Die exportierte CSV hat folgende Trenner:
"Organisationseinheit";"Beschreibung";"Benutzername";"Passwort";"Internetadresse";"EMail-Adresse";"V7 Ordnerpfad";"Kommentar"

Welches Format muss die CSV haben, damit der import von Passwordsafe Daten korrekt funktioniert?
Wir nutzen den Import mittels des Passwordsafe Felds


Grüße


Patrick


Clock5 mths

Hallo Patrick,

nur um sicherzugehen - den Import versuchst du mit:

Datei => Importieren => Sitzung mittels CSV Assistent importieren => Benutzername => Password Safe (.csv) ?

Auf jeden Fall müssen die ; Trennzeichen zu , ersetzt werden (z.B. mittels Notepad++)

Hier findest du eine CSV-Beispiel Formatierung.


Gibt es irgendwelche Einträge unter Hilfe => Anwendungsprotokolle ?

lg,
Min

Clock5 mths

Hallo,

ich konnte das Problem eingrenzen.
In einigen Beschreibungsfeldern befinden sich Zeilenumbrüche. Das gefällt dem System wohl nicht.
Gibt es einfache Möglichkeiten der Formatierung?
\n löst es nicht.
Bei ~ 10.000 zu importierenden Einträgen ist der Aufwand jede CSV anzupassen recht komplex.


Wenn ich die Zeilenumbrüche entferne ist ein Import möglich.
Ich habe Testweise die Beschreibung dann wieder mit entsprechenden Umbrüchen editiert.
Beim Export erscheint die CSV dann identisch.

Grüße


Patrick

Clock5 mths

Hallo Patrick,

alles klar - danke für die Information!

Wäre es möglich einen Dummy-Export von Einträgen mit Zeilenumbrüchen (es reichen 4-5), die aktuell nicht zum Importieren funktionieren, zu erhalten?

Du kannst diesen entweder über diesen Link hochladen oder per E-Mail an ticket@devolutions.net mit einem Verweis auf diesen Thread senden.

Danke!

lg,
Min

Clock5 mths

Hallo,

ich habe die csv Datei soeben hochgeladen.

Danke für die Unterstützung.

Grüße


Patrick

Clock5 mths

Hello,

Sorry to jump in. That said, we have been able to reproduce this issue using the test sample that you have provided us.
A ticket on that matter has been assigned to our engineering department and we will be in touch as soon as we will have more information on this.

Best regards,



James Lafleur

signaturesignature

Clock5 mths

Dear James,

is there any new information?


Regards,


Patrick

Clock3 mths

Hello Patrick,

After a discussion with our engineering department, they explained that this issue is caused by the current format of your csv file which is not supported by RDM. Unfortunately, it would be difficult to change our current integration in order to be able to support it. That said, they are still looking at different ways to achieve this.

The only workaround at this time is the one mentioned by Min, where you would need to edit the content of your csv file and have your description on only one line instead of multiples. We are aware that this might not be the best option for you since you have over 10 000 entries in this file.

Best regards,



James Lafleur

signaturesignature

Clock3 mths