Forum / Remote Desktop Manager - Beta

Password prompt behind RdM startup logo

  • Create an Issue
  • Cancel

Hey,

We use Azure SQL as datasource; this prompts for a password. I notice the prompt is behind the 'topmost' window with the RdM logo (loading screen).
I only noticed since I am using the beta (using 20119.2.9.0 64 bit).


See printsceen in attachment.

2019-10-14_09h18_14.png
Clock2 mths

Hello,

This is very strange.

After the loading process, are you able to enter your password or the RDM logo screen is always present?

Best regards,



Jeff Dagenais

signaturesignature

Clock2 mths

The loading screen is always present while i need to type in the password.
Note that this is a popup when accessing the Azure SQL database (this comes from the adal module).
I just noticed that when i have displays it showed the login on the 2nd display this time - so no overlap issue this time.


I can move the underlaying window and then enter my credentials so its quite ok ; but not used friendly wink

Clock2 mths

Hello,

I suspect that you are using your Office365 account to authenticate on your database. Am I correct?

If yes, could you follow the steps in this help article to properly configure your Azure environment to accept this authentication method without using adalsql?
https://help.remotedesktopmanager.com/datasources_advanced_sqlazure_configureappregistration.htm

Best regards,



Jeff Dagenais

signaturesignature

Clock2 mths

Hi,

Behavior which we observe is actually the same, only the lucky thing is that there is enough space to enter the password. RDM Logo screen remains in front from the login form, see attached screenshot. (O365 Login)

Regards, Marcel

LoginForm.png
Clock2 mths

Hello,

I am waiting for the database upgrade on our SQL Azure test database so that I can try to reproduce the issue on my end.
As of now, the workaround would be to go in File -> Options -> General -> Application Start and uncheck the show splash screen option.

Best regards,



Jeff Dagenais

signaturesignature

Clock2 mths

Hello,

Sorry for the delay in my response.

My BD has been upgraded and I was able to test your behavior. I have the exact same issue as you.

A ticket has been opened to our engineering department.
The ticket number is RDMW-3868

Best regards,



Jeff Dagenais

signaturesignature

Clock28 days

Hello,

We may have a fix regarding this in RDM 2019.2.11.0. Could you give it a try?

You can download it here
https://remotedesktopmanager.com/home/download#Beta


Best regards,



Jeff Dagenais

signaturesignature

Clock26 days

At our environment this fix is ok, RDM Logo is disappearing and Login form is focussed in/to front.

Thnx.

Clock26 days