Forum / Remote Desktop Manager - Support

SSH Session copy wrapped text is adding LF

  • Create an Issue
  • Cancel


I am running RDM 2019.1.41 on Windows 10. When I cat a file on any of the Linux systems I manage if the lines are longer than the screen width it will auto wrap them. This is fine but when I select these lines and try to paste them into another session or notepad LF (line feeds) are added and the lines are broken up into multiple lines. If I'm copying a command line script or an encryption key this corrupts it so that it doesn't work on the target system. When I use xterm on my linux workstation it will wrap on the screen but when I copy it doesn't add CR or LFs and keeps each line intact. Any help you can get with resolving this would be much appreciated.

Devin

Clock10 days

Hi Devin,

I expected something like that to happen. Not adding LF was the original behaviour, but some user complained, that in certain situations, lines would get concatenated. This is because some applications output lines with spaces filling the rest of the line and wrap to the next line.

We will add an option to the terminal window to select the way copy is made: either preserve wrapping or preserve screen formatting.

Regards!

Denis Vincent

signaturesignature

Clock10 days

Actually it seems like its preserving what I see on the screen with the wrapping by inserting CR or LF when I copy. The behavior I'm looking for is to just leave a long line long. I don't want to copy and paste it as I see it on the screen with the wrapping intact I want to copy and paste it as the long line it is in real life. So I want to have it wrap on the screen but when I select it I don't want it to add CR or LF where the line wraps at the right of the screen, just preserve original CR and/or LFs that were there in the original data.

Regards,

Devin

Clock10 days

Hello,

We will have a toggle-able option in the SSH shell toolbar called "preserve formatting on copy". This should let you achieve what you want.
This will be available starting with RDM 2019.2.10.0.

Regards,

Hubert Mireault

signaturesignature

Clock8 days

I got the same problem with @devin01, it is very annoyed and make mistake when editing one-line command, I thinks many peoples got the same problem with me. Hope it can be fixed on the next version..

Clock2 days