Forum / Remote Desktop Manager - Beta

SSH agent forwarding only seems to work when "Use SSH authentication agent" is also enabled

  • Create an Issue
  • Cancel


Hi

Using 2019.2.8.0, the key agent manager starts on application startup and prompts me for my passphrase for my ssh key - all good.


In previous RemoteDesktopManagerFree versions (5.1.3.0 for example) for SSH sessions I have used General -> Advanced -> "Allow SSH authentication agent forwarding" on its own. I was then able to ssh into our SSH gateway (using a different auth method) and from there (with "ForwardAgent yes" set in .ssh/config on the SSH gateway) I was able to ssh to other hosts using the authentication agent forwarded from RDMF.

This only seems to work now when I also select General -> Advanced - > "Use SSH authentication agent" - I don't want to use this option when connecting to the first host (SSH gateway.) Without this option selected, I am prompted for passphrase when ssh'ing from the SSH gateway to a second host.


I think the previous way of working is expected behaviour.


[angus@sshgateway ~]$ tail -1 .ssh/config
ForwardAgent yes


I hope this makes sense ...

Regards
Angus

RDMF.png
Clock2 mths

Hello,

We will investigate and try to reproduce the issue. I open a ticket with the engineering department to look at this issue.

Best regards,



David Grandolfo

signaturesignature

Clock2 mths