Forum / Remote Desktop Manager - Support

Respect PS1 terminal settings

  • Create an Issue
  • Cancel

Hello,

I have a custom PS1 environment variable which Putty respects, but RDM does not. I am sure it is an issue with me not knowing how to configure this correctly.

Here is my PS1:
\[\033[38;5;196m\]\u\[\]\[\033[38;5;15m\]@\[\]\[\033[38;5;27m\]\h\[\]\[\033[38;5;15m\] \[\]\[\033[38;5;230m\]\@\[\]\[\033[38;5;15m\] 1 \$ \[\]

rdm.png is how it loos on Remote Desktop Manager, Putty.png is how it looks via Putty.

Thanks!
Ryan

rdm.png
putty.png
Clock3 mths

Hello,

I was able to reproduce this behavior; I'm not sure if it's a missing configuration or because this feature is not yet implemented in our SSH Engine.

I opened a ticket with the engineering department, and we will do a follow up soon.

Best regards,



David Grandolfo

signaturesignature

Clock3 mths

Thanks David! I'm really liking RDM. I have been using it for about a week now.

Clock3 mths

Thanks for using our products, as a workaround in the meantime we fixe the issue. You can enable the Legacy terminal under File --> Option --> Type --> Terminal.

Best regards,



David Grandolfo

signaturesignature

Clock3 mths

If I understand correctly, this is because colors are specified in the 256 color mode. If it's the case, I already have a ticket to add 256 color support (RDMW-3360), I'll probably also add true color support as well.

Regards.

Denis Vincent

signaturesignature

Clock3 mths

Thanks, look forward to this being corrected!

Clock3 mths