Forum / Devolutions Password Server - Support

Import entries in private vault access denied

  • Create an Issue
  • Cancel

Dear,

We are trying to import entries into a user Private Vault and when at step 2 of the process (Analyze) we have an access denied error (Tried to import in an invalid vault)

Export was done on Password Vault Manager and works fine if you are administrator, in case of normal user it fails. We tested with several user and the same on all.

Thx.

Clock10 days


Hello,

What Password Server version are you using?

Are you trying to import using RDM or from the DPS web interface?

Best regards,



Érica Poirier

signaturesignature

Clock10 days

Hello,

We are using DPS 2019.1.17.0.

We have done the export in Password Vault Manager from a user private vault and we are trying to import it into Password Server (web) using wen interface in this user Private Vault.

If I do this as administrator (Admin Private Vault) it works, but seems none of our users can import in their Private Vault. Creating manual entries works.

Thx for your help on this matter.

Clock9 days

Hello,

Unfortunately, we are unable to reproduce this behaviour internally.

How the Import permission is configured in Administration - Data Source Permissions - Entries?

Could you please send me a screen capture of the error message?

Do you have any relevant error messages in the DPS logs? Please see the following online help page on how to view logs.
https://helpserver.devolutions.net/configure_dvlslogs.htm

Best regards,



Érica Poirier

signaturesignature

Clock9 days

Hello

This is the screenshot of the Entries section in Administration

chrome_2019-09-13_07-19-37.png
Clock8 days

This is the error message we have

Import entries error.png
Clock8 days

Also by checking logs I received the new release popup and in the fixes I see the following one, does it means I should better update to this release?

  • DPS - Fix that you could no longer import into Private Vault without the import permission

Clock8 days

I checked the logs when trying to import and no error message displayed.

Clock8 days

I just upgraded to latest version 20 and issue persist

Any other clue or idea?

Clock8 days


Hello,

Thank you for the detailed information. We will try to reproduce this internally and will get back to you with our findings.

Best regards,



Érica Poirier

signaturesignature

Clock8 days

Hello,

We have been able to reproduce your issue. A ticket has been sent to our engineering department. Once an update will be available, we will post it in this thread. For future references, the internal ticket number is DPS-3595.

The main cause of this issue is because the user doesn't have access to the Default vault. So, the workaround is to assign the Default vault to the user who wants to import entries in its private vault.

Best regards,



Érica Poirier

signaturesignature

Clock8 days

Hi,

I confirm that enabling "Default" Vault to that user makes the import working in the "Private Vault"

Waiting for fix then.

Thx.

Clock5 days