Forum / Remote Desktop Manager - Support

Shift key doesn't work over Apple Remote Desktop (Mac OS Catalina)

  • Create an Issue
  • Cancel

Attempting to connect to a Mac Mini running Mac OS Catalina, the shift key does not work. The On-screen keyboard correctly reflects the shift button being pressed but when typing in other apps and password fields, the shift key doesn't change the characters as expected. I've tried from Windows 10 Home and Professional workstations. There doesn't appear to be any relevant information in the application logs.

Clock4 mths

Hello,

I opened a ticket to our engineering department regarding the issue.
The ticket number is RDMW-3631.

On a side note, what version of RDM are you currently running?

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock3 mths

2019.1.41, I'll submit diagnostics as well.

Clock3 mths

Hello,

Thank you for the diagnostic. It has been added to the ticket.

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock3 mths

I have met same issue, has this been resolved?
If not, any plan to fix the issue?
Thanks.

Clock2 mths

Hello,

As per the ticket opened to our engineering department, it seems that we have encountered this issue on multiple platforms.
They are working on a fix, but it's not completed yet.

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock2 mths

Same issue here..

Clock2 mths

Any updates on this fix? I have several Apple servers I have to physically log on to as RDM won't send uppercase characters.

Clock2 mths

Same issue here as well.

Clock2 mths

Hello,
We have on developer assigned but this is not an easy one.

David Hervieux

signaturesignature

Clock2 mths


It works fine with a standard vnc client.

Is this confirmed to be just issue with Catalina ?

Clock2 mths


Hi,

Yes, so far, I've only been able to reproduce this issue on Catalina.

I can confirm that connecting with a standard VNC client or RDM with a VNC session does work.
However, in that case, the ARD protocol is not used.
The ARD protocol brings a couple of improvements over the standard VNC connection

- encrypted inputs
- optimized image encodings.
I'm actively working on it but as ARD is a closed protocol, this is not an easy task.

Jonathan Lafontaine

signaturesignature

Clock1 mth

Same issues here, using the onscreen keyboard I note that pressing the buttons makes the keyboard react appropriately however when pressing the other button it appears to not use the shift. Also noted that the control key for me is behaving the same way. Running v2019.2.14.0

Clock27 days


Hi,

The shift key issue has been fix internally and should be available in the next release.
Do you have an example control key combination that is currently not working?
I could try to replicate the issue on our side.

Jonathan Lafontaine

signaturesignature

Clock27 days

I was seeing it I believe with browsers mainly (control+shift+tab) but trying it just now to confirm it appears to be working. Updated to Catalina 10.15.1 since I tried so not sure if that fixed it or there was some other issue. Shift behaviors still the same but as mentioned the next build should have something for that.

Clock27 days

I'll try to replicate on my side nonetheless and if you encounter any keyboard issues in the next release, let me know.

Jonathan Lafontaine

signaturesignature

Clock27 days

Confirmed fixed here. Thank you, though I'll have to find an alternative 10000 steps a day now!

Clock14 days

Confirmed it’s working in the new build for me as well

Clock13 days

Thanks! It works now!

Clock3 days

But i have problem with Russian symbols. Its doesn't transfered to Calaina through ARD protocol (((((

Clock3 days


I'll take a look into it.

Jonathan Lafontaine

signaturesignature

Clock3 days


Could you please elaborate a bit more about your setup?

Client site, what is your keyboard layout. And on the server?
What key was sent incorrectly? What was the output and what were you expecting?

Regards

Jonathan Lafontaine

signaturesignature

Clock3 days