Forum / Wayk Now - Support

I cannot connect to my remote machine

  • Create an Issue
  • Cancel


Hi,


I cannot connect to my remote machine.


here is error log

WaykNow.log
Clock3 mths

I have a license and I use the enterprise version. Thanks!

Clock3 mths

Hi Erick

Sorry to hear about the issue connecting.

The log file shows that the remote machine could not be resolved (that is, it couldn't be found by Wayk Den).

Is the remote machine a new installation, or was it working before?

Is the remote machine showing "Ready" and the green light for Wayk Den connectivity?

Thanks and kind regards,

Richard Markievicz

signaturesignature

Clock3 mths


Hi,

yes. the remote machine was on "Ready" mode. This used to work before. Any thoughts?

Clock3 mths

Hi,

What is the OS running on the remote machine ? Is it a windows machine with the wayk now msi installed ?

If the remote machine is a Windows with the msi installed, you can see if the service is running with that command :
>sc query wayknowservice

If it is not running, you can start it:
> net start wayknowservice

If it is running, you can try to restart it:
> net stop wayknowservice
> net start wayknowservice

Let me know if it helps.

Thanks and kind regards,

François Dubois

signaturesignature

Clock3 mths


Hi,

I seems like it was always running. I restarted the service. I will connect from home later today and will let you know.

if it works, the my question will be why does it become unresponsive at one point?


image

Clock3 mths

Hi Erick,

The service could be unresponsive if it crashes for some reasons. To help us investigate the issue, you could activate the logs on the service. From an elevated command prompt :

> net stop wayknowservice
> wayk-now config --global logginglevel 1
> net start wayknowservice

And then the log file will be available in %PROGRAMDATA%\Wayk\Logs.

Let me know if the service restart fixed your issue. If it fixed, you could activate the log and send us logs if your service become unresponsive again in future. If it didn't fix, send me your service log, I will have a look to be sure that everything is fine with the service.

Thank you in advance
Best regards

François Dubois

signaturesignature

Clock3 mths


Hi,

I still cannot connect. Please find attached, the logs for my remote machine. I enabled this: wayk-now config --global logginglevel 1.


Thanks!

WaykNow.log
Clock3 mths

Hi Erick,

What you sent me seems to be logs from the application and not the service. Service logs are located here : %PROGRAMDATA%\Wayk\logs. The file is named NowService.log.

If you could send me that file, I would appreciate. Let me know if you have difficulties to find that file. It should be there if you ran the steps in my previous message.

Thank you in advance
Best regards

François Dubois

signaturesignature

Clock3 mths


Hi,

I found the file but it is not logging any errors at all. any thoughts?

Thanks!


Clock3 mths


Hi,

I can connect sometimes. But when i disconnect my session, the remote machine keeps saying that is `Sharing active` and then I cannot connect anymore.


image

Clock3 mths

Hi Erick

Can you confirm you are running the latest (3.3.1) on the remote machine?

Thanks and kind regards,

Richard Markievicz

signaturesignature

Clock3 mths


Yes I am.

image

Clock3 mths

Hi Erick

Can you check for and, if present, provide us with the following file(s):

%windir%\temp\nowsession.log
%windir%\temp\waykhost.log

We would also be interested to see the NowService.log, even if no apparent errors are logged, the sequence of events and so on can often reveal important information.

Thanks and kind regards,

Richard Markievicz

signaturesignature

Clock3 mths

Sure. Please find attached.

WaykHost.log
NowSession.log
NowService.log
Clock3 mths


my remote machine just gave me a new Source ID: 567 983, is that OK?

I used to connect using another source ID, any thoughts?

Clock3 mths


Hi,

Any thoughts? I really need this resolve today

Clock3 mths

Hi Erick,

I'm looking the issue right now. There is two things :

1 - Your Source ID changed because your service is probably down. Could you confirm if your service (Wayk Now Unattended) is up or down ? Because the service has a Source ID, but if it doesn't run, the wayk now application itself will have another Source ID.

2 - The process NowSession seems to be crashed. Could you validate if you have a process NowSession.exe running ? Here are a few steps that you could do :

1 - Close the application WaykNow. No process WaykNow.exe should be running.
2 - Stop the service. No process NowService.exe should be running.
3 - Look if you have a process NowSession.exe running. If it is the case, kill it.
4 - Look if you have a process WaykHost.exe running, and kill it if it is running.
5 - Start the service

After those steps, you should be back on track. If it is not the case, please send me all logs again, it would mean that one process always crash for an unknown reason.

Thanks


François Dubois

signaturesignature

Clock3 mths


1 - My service is not down. But the source ID changed

image

Clock3 mths


So I restarted all the service and i got back the same sourceId : 867144.

However, still cannot connect all the logs are attached

NowService.log
NowSession.log
WaykHost.log
Clock3 mths

This is teh log for my client machine

WaykNow.log
Clock3 mths


any thoughts?

also, form my client machine, how do I get the secure remote delegation to pop up again? i cleared my Credentials from the client machine


image


Clock3 mths

Hi,

I'm looking your issue, I will give you feedback as soon as possible.

Thank you

François Dubois

signaturesignature

Clock3 mths


Hi Erick,

We are sorry for the inconvenience. We have a few stability fixes that could potentially improve your situation, we will work on producing an early 3.3.2 build tomorrow such that you can give it a shot.

We were unable to pinpoint a single cause of failure other than the service appears to become unresponsive. In the past, many such issues were caused by IPC failures with TCP sockets, and we have a few unreleased fixes that remove the last bits of TCP sockets for IPC in favour of named pipes. With a bit of luck, your issues should go away. The other set of unreleased fixes that could potentially resolve your issue are fixes for the recently modified capture mode that added support for the Windows DXGI API, but also introduced a few stability issues.

Best regards,

Marc-André Moreau

signaturesignature

Clock3 mths


Hi Marc,

How soon the update is coming today?

Thanks!
Erick

Clock3 mths


Hi Erick,

I have produced a Wayk Now 3.3.2-RC1 build candidate here for you to test: https://gofile.io/?c=5GFn1O

Let me know if it fixes the issue for you.


Best regards,

Marc-André Moreau

signaturesignature

Clock3 mths


Hi,


It says this upload does not exist, any thoughts?

Thanks!

Clock3 mths


Hi Erick,

For some reason, the link URL was lowercased when I made my post, which broke the download id. Please paste the URL with the original casing, and it should work.

Best regards,

Marc-André Moreau

signaturesignature

Clock3 mths


Hi,


link doesn't work still all capital cases: https://gofile.io/?c=5GFN1O

Clock3 mths


Hi Erick,

I didn't mean it to be all capitalized, I just meant that the forum had a bug where it made the link all lowercase. The URL is case sensitive. Please use the following URL with this exact casing "5GFn1O" at the end:


https://gofile.io/?c=5GFn1O

Marc-André Moreau

signaturesignature

Clock3 mths